summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-01-29 13:24:58 -0800
committerMatt Turner <mattst88@gentoo.org>2017-01-29 13:26:19 -0800
commitb3c3e010f395cecefcc8cd5bb7ef05a227f18336 (patch)
tree8205d22f84d77f4fbb74709cf431b3b12dc89c7a
parentx11-apps/xauth: Depend on dev-util/cmdtest for tests. (diff)
downloadgentoo-b3c3e010f395cecefcc8cd5bb7ef05a227f18336.tar.gz
gentoo-b3c3e010f395cecefcc8cd5bb7ef05a227f18336.tar.bz2
gentoo-b3c3e010f395cecefcc8cd5bb7ef05a227f18336.zip
x11-apps/xauth: Version bump to 1.0.10.
-rw-r--r--x11-apps/xauth/Manifest1
-rw-r--r--x11-apps/xauth/xauth-1.0.10.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/x11-apps/xauth/Manifest b/x11-apps/xauth/Manifest
index c620eb9bad6c..f70a48508433 100644
--- a/x11-apps/xauth/Manifest
+++ b/x11-apps/xauth/Manifest
@@ -1 +1,2 @@
+DIST xauth-1.0.10.tar.bz2 162176 SHA256 5afe42ce3cdf4f60520d1658d2b17face45c74050f39af45dccdc95e73fafc4d SHA512 1ddcd80848c4efffc6d0a576177f92a3ce47eb871a6c7e2097d96491aec027404d437e0bd792714ef423989153a9644f5ff179bde4dfeb4b340636d642d5849f WHIRLPOOL 9ed291e2699fa34b49cb05c9ea2934cbe6b4361b0eec138734cadd741551b299f266ee50827b86f558beba47ff5c5c2f695279000f00fc720125e915f7e8e26b
DIST xauth-1.0.9.tar.bz2 154976 SHA256 56ce1523eb48b1f8a4f4244fe1c3d8e6af1a3b7d4b0e6063582421b0b68dc28f SHA512 e7b8e950a3e9e36131041692a22b2390c75df94fa8b5f4ea2ef2d79778e000865b1b0ec5930612dedb782d451022ee52c7c9a404d249809adb4b905b66f44d0b WHIRLPOOL 16f2686a181281610df55d405738d0a39fd7fa891a58606b13abed3754179802e1b22a938ef43d6d4205dfa8ff7f764f5e1c5323e58bed080ccd33ca4f4f0134
diff --git a/x11-apps/xauth/xauth-1.0.10.ebuild b/x11-apps/xauth/xauth-1.0.10.ebuild
new file mode 100644
index 000000000000..102fdf1c91a9
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.0.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils xorg-2
+
+DESCRIPTION="X authority file utility"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="ipv6 test"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmdtest )"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ )
+ xorg-2_src_configure
+}
+
+src_test() {
+ # Address sandbox failure, bug #527574
+ addwrite /proc/self/comm
+ autotools-utils_src_test
+}