summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-05-07 15:58:19 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-05-07 15:58:43 -0500
commitb47c2b767419cdf7e49ef9c6079bfe383b733c80 (patch)
treee08bb485be8c7fc37e35a2c42a5daa721e83f845
parentwww-client/firefox: bump revision (diff)
downloadgentoo-b47c2b767419cdf7e49ef9c6079bfe383b733c80.tar.gz
gentoo-b47c2b767419cdf7e49ef9c6079bfe383b733c80.tar.bz2
gentoo-b47c2b767419cdf7e49ef9c6079bfe383b733c80.zip
dev-vcs/python-gitlab: 2.2.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--dev-vcs/python-gitlab/Manifest1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-2.2.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-vcs/python-gitlab/Manifest b/dev-vcs/python-gitlab/Manifest
index 61ebc53c3f26..0db9a63f4835 100644
--- a/dev-vcs/python-gitlab/Manifest
+++ b/dev-vcs/python-gitlab/Manifest
@@ -2,3 +2,4 @@ DIST python-gitlab-1.13.0.tar.gz 121434 BLAKE2B f8a9af4f389b4759891e26de305c48a7
DIST python-gitlab-1.7.0.tar.gz 110657 BLAKE2B 1003d3373d3ef5474b1d5c10b1c6af57e7467cec432fc1eb75b4e1ba7766361641f25461ac2bf1b7692dab855d4e5cbc204240ede3568e71ed1af75682807fb0 SHA512 ad50d989e27948ff5188f4191ad3b7f1e1b45608627b2042bf02d635b2aa8da0a24f6b0383f483a01df54e4ab14576e7e4252576b9c2bdf67a187ae6aad69d53
DIST python-gitlab-1.8.0.tar.gz 115603 BLAKE2B 8ebebc1735e5531b4f95d82122b6ecf78fd541bce503f0cdf8c47b2ec2edab89efcad6c0ab39d82b57ffb8c3e341cb2160916b7df6c4886465e90557db3141c3 SHA512 4843aefb7cd363520e9065cfc08b81ec2c5c2c9cbdb5d6adbd35ec0f615bafd40e66746739c910b5e7e041f06e2aa9dc8beb8a884a714e6837cd5fb6fefb53be
DIST python-gitlab-1.9.0.tar.gz 116460 BLAKE2B f0a0d9679e4e742d966c678f8dcc6b2464e5ae8a013038221b3c484e6bb6ae23c166f82fec85c3560ebbce3cf80bc23657b1b906d8c6f284a64589545acdb035 SHA512 cb0d58896f55837f7088ab08551f2e9f9f82e8a04c19979a69bc042c95cdb2d04174dec49a236ddcf1344c50e9ffc6f929750b008bf6e619225c80bf9490afaa
+DIST python-gitlab-2.2.0.tar.gz 136178 BLAKE2B 23f04638ba34f63048143e834342ea81e8a8cacdbc0502490543bc5b6de9fea6a58c884bc4111aea0fb27a343d22b9dfc62d5000b873ab90105f6aa5a80b7ff5 SHA512 bdf34e4b9e45f5767faf81d52caf1b800d931a105940bb80b1e58cc8efc34a319196a6aa437d49215f0f4ff24359cc2497853486698a23413b2bb3dfe169e5e3
diff --git a/dev-vcs/python-gitlab/python-gitlab-2.2.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-2.2.0.ebuild
new file mode 100644
index 000000000000..fb687ff4c2f1
--- /dev/null
+++ b/dev-vcs/python-gitlab/python-gitlab-2.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Python command line interface to gitlab API"
+HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/python-gitlab/python-gitlab"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="test"
+
+BDEPEND="test? (
+ dev-python/httmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r *.rst docs
+}