summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-23 20:42:01 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-08-02 22:17:56 +0200
commitb63509b589c4ce92914865b4db422c0317fe4583 (patch)
tree13973c6c97ab9e76751911b9a89c0ca6401c47ec
parentx11-plugins/wmpower: EAPI7, improve ebuild (diff)
downloadgentoo-b63509b589c4ce92914865b4db422c0317fe4583.tar.gz
gentoo-b63509b589c4ce92914865b4db422c0317fe4583.tar.bz2
gentoo-b63509b589c4ce92914865b4db422c0317fe4583.zip
x11-plugins/wmrack: EAPI7, improve ebuild
-rw-r--r--x11-plugins/wmrack/wmrack-1.4-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/wmrack/wmrack-1.4-r1.ebuild b/x11-plugins/wmrack/wmrack-1.4-r1.ebuild
new file mode 100644
index 000000000000..f40d1f916205
--- /dev/null
+++ b/x11-plugins/wmrack/wmrack-1.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="a sound mixer and CD player dockapp"
+HOMEPAGE="http://wmrack.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=( CHANGES README TODO )
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's:gcc:$(CC):' \
+ -e 's:$(OBJECTS) -o:$(OBJECTS) $(LDFLAGS) -o:' "${S}"/Makefile.in || die
+}
+
+src_install() {
+ emake LIBDIR="${D}/usr/$(get_libdir)/WMRack" \
+ MANDIR="${D}/usr/share/man" BINDIR="${D}/usr/bin" \
+ install
+ einstalldocs
+}