summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2021-01-21 20:46:34 +0800
committerBenda Xu <heroxbd@gentoo.org>2021-01-24 15:45:44 +0800
commitb7887f20464f5712259ca57a618fea681f01d42b (patch)
tree93e1f1134102c6f80fdddaaef18938ee632fb958
parentsci-libs/rocSPARSE: BLAS for sparse computation. (diff)
downloadgentoo-b7887f20464f5712259ca57a618fea681f01d42b.tar.gz
gentoo-b7887f20464f5712259ca57a618fea681f01d42b.tar.bz2
gentoo-b7887f20464f5712259ca57a618fea681f01d42b.zip
sci-libs/hipSPARSE: SPARSE marshalling library.
Closes: https://github.com/gentoo/gentoo/pull/19145 Bug: https://bugs.gentoo.org/650804 Bug: https://github.com/gentoo/gentoo/pull/10724 Suggested-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Suggested-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-3.0.12, Repoman-3.0.1 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--sci-libs/hipSPARSE/Manifest1
-rw-r--r--sci-libs/hipSPARSE/hipSPARSE-4.0.0-r1.ebuild49
-rw-r--r--sci-libs/hipSPARSE/metadata.xml19
3 files changed, 69 insertions, 0 deletions
diff --git a/sci-libs/hipSPARSE/Manifest b/sci-libs/hipSPARSE/Manifest
new file mode 100644
index 000000000000..f1697cac2574
--- /dev/null
+++ b/sci-libs/hipSPARSE/Manifest
@@ -0,0 +1 @@
+DIST hipSPARSE-4.0.tar.gz 271756 BLAKE2B d774632c145a842c5dd97df6e0c1c3b3fc6986a5d3e000564b3b9b4f8a9c72bc01b360baf93a82f8a70a85b8ee1833f4e767a48021d3869391000551ed00e614 SHA512 78c9501e6f9f8b0727d2f2207814048f8c784b2b06797559d6f639244cb1439e9218a46c582a6b337b15791519f0bcb9e0f42c17bff00c096c797c96cc7660ae
diff --git a/sci-libs/hipSPARSE/hipSPARSE-4.0.0-r1.ebuild b/sci-libs/hipSPARSE/hipSPARSE-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..6db7fd375008
--- /dev/null
+++ b/sci-libs/hipSPARSE/hipSPARSE-4.0.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="ROCm SPARSE marshalling library"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipSPARSE"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/hipSPARSE/archive/rocm-${PV}.tar.gz -> hipSPARSE-$(ver_cut 1-2).tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND=">=dev-util/rocminfo-$(ver_cut 1-2)
+ =dev-util/hip-$(ver_cut 1-2)*
+ =sci-libs/rocSPARSE-${PV}*"
+DEPEND="${RDPEND}"
+
+S="${WORKDIR}/hipSPARSE-rocm-${PV}"
+
+src_prepare() {
+ sed -e "s/PREFIX hipsparse//" \
+ -e "/<INSTALL_INTERFACE/s,include,include/hipsparse," \
+ -e "s:rocm_install_symlink_subdir(hipsparse):#rocm_install_symlink_subdir(hipsparse):" \
+ -i library/CMakeLists.txt || die
+
+ eapply_user
+ cmake_src_prepare
+}
+
+src_configure() {
+ # Grant access to the device
+ addwrite /dev/kfd
+ addpredict /dev/dri/
+
+ # Compiler to use
+ export CXX=hipcc
+
+ local mycmakeargs=(
+ -DHIP_RUNTIME="ROCclr"
+ -DBUILD_CLIENTS_TESTS=OFF
+ -DBUILD_CLIENTS_SAMPLES=OFF
+ -DCMAKE_INSTALL_INCLUDEDIR=include/hipsparse
+ )
+
+ cmake_src_configure
+}
diff --git a/sci-libs/hipSPARSE/metadata.xml b/sci-libs/hipSPARSE/metadata.xml
new file mode 100644
index 000000000000..b745c3d73285
--- /dev/null
+++ b/sci-libs/hipSPARSE/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gentoo@holzke.net</email>
+ <name>Wilfried Holzke</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ROCmSoftwarePlatform/hipSPARSE</remote-id>
+ </upstream>
+</pkgmetadata>