summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-30 21:07:29 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-30 21:13:46 +0200
commitb7a4174e075a922a255c0ff4a6ebd4f6d0437c61 (patch)
tree8295e33b5ca69551939e30c2d2b765c50c55568c
parentnet-wireless/chirp: bump (diff)
downloadgentoo-b7a4174e075a922a255c0ff4a6ebd4f6d0437c61.tar.gz
gentoo-b7a4174e075a922a255c0ff4a6ebd4f6d0437c61.tar.bz2
gentoo-b7a4174e075a922a255c0ff4a6ebd4f6d0437c61.zip
dev-lang/python: Remove remnants of python-updater
Remove the remaining dependencies on deprecated python-updater, and update the postinst messages appropriately. For Python 2.7, the message has been removed altogether since it is the oldest version supported by PYTHON_TARGETS. For the remaining versions, just inform about potential PYTHON_TARGETS changes necessary. The modified versions are not revision-bumped to avoid unnecessary rebuilds due to a minor change. The versions that are still newest-visible (i.e. not replaced by another version or revision bump) will be bumped when python-updater is lastrited.
-rw-r--r--dev-lang/python/python-2.7.10-r1.ebuild17
-rw-r--r--dev-lang/python/python-2.7.11-r2.ebuild17
-rw-r--r--dev-lang/python/python-2.7.12.ebuild15
-rw-r--r--dev-lang/python/python-3.3.5-r3.ebuild5
-rw-r--r--dev-lang/python/python-3.3.5-r8.ebuild5
-rw-r--r--dev-lang/python/python-3.4.3-r1.ebuild5
-rw-r--r--dev-lang/python/python-3.4.3-r7.ebuild5
-rw-r--r--dev-lang/python/python-3.4.4.ebuild5
-rw-r--r--dev-lang/python/python-3.4.5.ebuild3
9 files changed, 14 insertions, 63 deletions
diff --git a/dev-lang/python/python-2.7.10-r1.ebuild b/dev-lang/python/python-2.7.10-r1.ebuild
index 5715577a3362..aaf1b143e04e 100644
--- a/dev-lang/python/python-2.7.10-r1.ebuild
+++ b/dev-lang/python/python-2.7.10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -64,8 +64,7 @@ DEPEND="${RDEPEND}
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
doc? ( dev-python/python-docs:${SLOT} )"
-PDEPEND="app-eselect/eselect-python
- app-admin/python-updater"
+PDEPEND="app-eselect/eselect-python"
S="${WORKDIR}/${MY_P}"
@@ -329,12 +328,6 @@ src_install() {
python_domodule epython.py
}
-pkg_preinst() {
- if has_version "<${CATEGORY}/${PN}-${SLOT}" && ! has_version "${CATEGORY}/${PN}:2.7"; then
- python_updater_warning="1"
- fi
-}
-
eselect_python_update() {
if [[ -z "$(eselect python show)" || ! -f "${EROOT}usr/bin/$(eselect python show)" ]]; then
eselect python update
@@ -347,12 +340,6 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
-
- if [[ "${python_updater_warning}" == "1" ]]; then
- ewarn "You have just upgraded from an older version of Python."
- ewarn "You should switch active version of Python ${PV%%.*} and run"
- ewarn "'python-updater [options]' to rebuild Python modules."
- fi
}
pkg_postrm() {
diff --git a/dev-lang/python/python-2.7.11-r2.ebuild b/dev-lang/python/python-2.7.11-r2.ebuild
index 50bc7a255dbb..9eeab0c3fe8c 100644
--- a/dev-lang/python/python-2.7.11-r2.ebuild
+++ b/dev-lang/python/python-2.7.11-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -66,8 +66,7 @@ DEPEND="${RDEPEND}
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
doc? ( dev-python/python-docs:${SLOT} )"
-PDEPEND=">=app-eselect/eselect-python-20140125-r1
- app-admin/python-updater"
+PDEPEND=">=app-eselect/eselect-python-20140125-r1"
S="${WORKDIR}/${MY_P}"
@@ -343,12 +342,6 @@ src_install() {
fi
}
-pkg_preinst() {
- if has_version "<${CATEGORY}/${PN}-${SLOT}" && ! has_version "${CATEGORY}/${PN}:2.7"; then
- python_updater_warning="1"
- fi
-}
-
eselect_python_update() {
if [[ -z "$(eselect python show)" || ! -f "${EROOT}usr/bin/$(eselect python show)" ]]; then
eselect python update
@@ -357,12 +350,6 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
-
- if [[ "${python_updater_warning}" == "1" ]]; then
- ewarn "You have just upgraded from an older version of Python."
- ewarn "You should switch active version of Python ${PV%%.*} and run"
- ewarn "'python-updater [options]' to rebuild Python modules."
- fi
}
pkg_postrm() {
diff --git a/dev-lang/python/python-2.7.12.ebuild b/dev-lang/python/python-2.7.12.ebuild
index 15f7436a60ec..992882b2ebd3 100644
--- a/dev-lang/python/python-2.7.12.ebuild
+++ b/dev-lang/python/python-2.7.12.ebuild
@@ -66,8 +66,7 @@ DEPEND="${RDEPEND}
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
doc? ( dev-python/python-docs:${SLOT} )"
-PDEPEND=">=app-eselect/eselect-python-20140125-r1
- app-admin/python-updater"
+PDEPEND=">=app-eselect/eselect-python-20140125-r1"
S="${WORKDIR}/${MY_P}"
@@ -343,12 +342,6 @@ src_install() {
fi
}
-pkg_preinst() {
- if has_version "<${CATEGORY}/${PN}-${SLOT}" && ! has_version "${CATEGORY}/${PN}:2.7"; then
- python_updater_warning="1"
- fi
-}
-
eselect_python_update() {
if [[ -z "$(eselect python show)" || ! -f "${EROOT}usr/bin/$(eselect python show)" ]]; then
eselect python update
@@ -357,12 +350,6 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
-
- if [[ "${python_updater_warning}" == "1" ]]; then
- ewarn "You have just upgraded from an older version of Python."
- ewarn "You should switch active version of Python ${PV%%.*} and run"
- ewarn "'python-updater [options]' to rebuild Python modules."
- fi
}
pkg_postrm() {
diff --git a/dev-lang/python/python-3.3.5-r3.ebuild b/dev-lang/python/python-3.3.5-r3.ebuild
index 6ff606d7d48d..42477ed50fc6 100644
--- a/dev-lang/python/python-3.3.5-r3.ebuild
+++ b/dev-lang/python/python-3.3.5-r3.ebuild
@@ -54,8 +54,7 @@ DEPEND="${RDEPEND}
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
doc? ( dev-python/python-docs:${SLOT} )"
-PDEPEND="app-eselect/eselect-python
- app-admin/python-updater"
+PDEPEND="app-eselect/eselect-python"
S="${WORKDIR}/${MY_P}"
@@ -319,8 +318,6 @@ pkg_postinst() {
ewarn "You have just upgraded from an older version of Python."
ewarn
ewarn "Please adjust PYTHON_TARGETS (if so desired), and run emerge with the --newuse or --changed-use option to rebuild packages installing python modules."
- ewarn
- ewarn "For legacy packages, you should switch active version of Python and run 'python-updater [options]' to rebuild Python modules."
fi
}
diff --git a/dev-lang/python/python-3.3.5-r8.ebuild b/dev-lang/python/python-3.3.5-r8.ebuild
index 996044988259..e7f91bd72fb4 100644
--- a/dev-lang/python/python-3.3.5-r8.ebuild
+++ b/dev-lang/python/python-3.3.5-r8.ebuild
@@ -60,8 +60,7 @@ DEPEND="${RDEPEND}
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )
doc? ( dev-python/python-docs:${PYVER} )"
-PDEPEND=">=app-eselect/eselect-python-20140125-r1
- app-admin/python-updater"
+PDEPEND=">=app-eselect/eselect-python-20140125-r1"
S="${WORKDIR}/${MY_P}"
@@ -363,8 +362,6 @@ pkg_postinst() {
ewarn "You have just upgraded from an older version of Python."
ewarn
ewarn "Please adjust PYTHON_TARGETS (if so desired), and run emerge with the --newuse or --changed-use option to rebuild packages installing python modules."
- ewarn
- ewarn "For legacy packages, you should switch active version of Python and run 'python-updater [options]' to rebuild Python modules."
fi
}
diff --git a/dev-lang/python/python-3.4.3-r1.ebuild b/dev-lang/python/python-3.4.3-r1.ebuild
index 0f32b9467bb0..d7dab168b3cb 100644
--- a/dev-lang/python/python-3.4.3-r1.ebuild
+++ b/dev-lang/python/python-3.4.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -51,8 +51,7 @@ DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.65
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )"
-PDEPEND="app-eselect/eselect-python
- app-admin/python-updater"
+PDEPEND="app-eselect/eselect-python"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-lang/python/python-3.4.3-r7.ebuild b/dev-lang/python/python-3.4.3-r7.ebuild
index 38e922817b31..51a14dbb6eb6 100644
--- a/dev-lang/python/python-3.4.3-r7.ebuild
+++ b/dev-lang/python/python-3.4.3-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -53,8 +53,7 @@ DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.65
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )"
-PDEPEND=">=app-eselect/eselect-python-20140125-r1
- app-admin/python-updater"
+PDEPEND=">=app-eselect/eselect-python-20140125-r1"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-lang/python/python-3.4.4.ebuild b/dev-lang/python/python-3.4.4.ebuild
index e1e7af2f93e7..a5ef671d7e85 100644
--- a/dev-lang/python/python-3.4.4.ebuild
+++ b/dev-lang/python/python-3.4.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -53,8 +53,7 @@ DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.65
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )"
-PDEPEND=">=app-eselect/eselect-python-20140125-r1
- app-admin/python-updater"
+PDEPEND=">=app-eselect/eselect-python-20140125-r1"
S="${WORKDIR}/${MY_P}"
diff --git a/dev-lang/python/python-3.4.5.ebuild b/dev-lang/python/python-3.4.5.ebuild
index 9491f2da175d..433a3a373da8 100644
--- a/dev-lang/python/python-3.4.5.ebuild
+++ b/dev-lang/python/python-3.4.5.ebuild
@@ -53,8 +53,7 @@ DEPEND="${RDEPEND}
>=sys-devel/autoconf-2.65
!sys-devel/gcc[libffi]"
RDEPEND+=" !build? ( app-misc/mime-types )"
-PDEPEND=">=app-eselect/eselect-python-20140125-r1
- app-admin/python-updater"
+PDEPEND=">=app-eselect/eselect-python-20140125-r1"
S="${WORKDIR}/${MY_P}"