summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-05-01 16:37:52 +0200
committerPacho Ramos <pacho@gentoo.org>2018-05-01 21:34:33 +0200
commitb85a5b81ae9bc8cb150d6726f053693f799671c7 (patch)
treea076cf428d1ea6829d0a1517d8eb1956c3cf4bdf
parentgames-puzzle/tod: Drop old (diff)
downloadgentoo-b85a5b81ae9bc8cb150d6726f053693f799671c7.tar.gz
gentoo-b85a5b81ae9bc8cb150d6726f053693f799671c7.tar.bz2
gentoo-b85a5b81ae9bc8cb150d6726f053693f799671c7.zip
games-puzzle/tong: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--games-puzzle/tong/files/tong-1.2-datadir.patch4
-rw-r--r--games-puzzle/tong/files/tong-1.2-fps.patch4
-rw-r--r--games-puzzle/tong/files/tong-1.2-makefile.patch4
-rw-r--r--games-puzzle/tong/tong-1.2-r1.ebuild44
4 files changed, 50 insertions, 6 deletions
diff --git a/games-puzzle/tong/files/tong-1.2-datadir.patch b/games-puzzle/tong/files/tong-1.2-datadir.patch
index d0279ac3b874..92a8bb4c18a1 100644
--- a/games-puzzle/tong/files/tong-1.2-datadir.patch
+++ b/games-puzzle/tong/files/tong-1.2-datadir.patch
@@ -1,5 +1,5 @@
---- tong.cpp.orig
-+++ tong.cpp
+--- a/tong.cpp.orig
++++ b/tong.cpp
@@ -202,7 +202,6 @@
Tetrad *tetrad, *nexttetrad;
Paddle *paddle;
diff --git a/games-puzzle/tong/files/tong-1.2-fps.patch b/games-puzzle/tong/files/tong-1.2-fps.patch
index 8ce66ebf1d31..86566646b8d6 100644
--- a/games-puzzle/tong/files/tong-1.2-fps.patch
+++ b/games-puzzle/tong/files/tong-1.2-fps.patch
@@ -1,5 +1,5 @@
---- tong.cpp.orig
-+++ tong.cpp
+--- a/tong.cpp.orig
++++ b/tong.cpp
@@ -64,6 +64,8 @@
#define DEMO_TIME 8000
diff --git a/games-puzzle/tong/files/tong-1.2-makefile.patch b/games-puzzle/tong/files/tong-1.2-makefile.patch
index 68b4547d9427..ad9b283f4785 100644
--- a/games-puzzle/tong/files/tong-1.2-makefile.patch
+++ b/games-puzzle/tong/files/tong-1.2-makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.orig
-+++ Makefile
+--- a/Makefile.orig
++++ b/Makefile
@@ -1,11 +1,10 @@
# TONG! makefile, tweak as you see fit
diff --git a/games-puzzle/tong/tong-1.2-r1.ebuild b/games-puzzle/tong/tong-1.2-r1.ebuild
new file mode 100644
index 000000000000..a16067fc57ba
--- /dev/null
+++ b/games-puzzle/tong/tong-1.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+DESCRIPTION="Tetris and Pong in the same place at the same time"
+HOMEPAGE="http://www.nongnu.org/tong/"
+SRC_URI="http://www.nongnu.org/tong/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,joystick,video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[vorbis]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ default
+ eapply \
+ "${FILESDIR}/${P}-makefile.patch" \
+ "${FILESDIR}/${P}-fps.patch" \
+ "${FILESDIR}/${P}-datadir.patch"
+ sed -i \
+ -e "s:\"media/:\"/usr/share/${PN}/media/:" \
+ media.cpp option.cpp option.h pong.cpp tetris.cpp text.cpp \
+ || die
+ cp media/icon.png "${T}/${PN}.png" || die
+}
+
+src_install() {
+ dobin tong
+ dodir "/usr/share/${PN}"
+ cp -r media/ "${ED}/usr/share/${PN}" || die
+ dodoc CHANGELOG README making-of.txt CREDITS
+
+ make_desktop_entry tong TONG
+ doicon "${T}/${PN}.png"
+}