summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-07-21 05:38:34 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-07-21 05:39:00 +1000
commitb92c2a8065a28156ad53d681b5d38d4e2e7cde25 (patch)
tree147028f56cf30066f3d03d2d7f48485f661171d4
parentsci-physics/hoomd-blue: version bump (diff)
downloadgentoo-b92c2a8065a28156ad53d681b5d38d4e2e7cde25.tar.gz
gentoo-b92c2a8065a28156ad53d681b5d38d4e2e7cde25.tar.bz2
gentoo-b92c2a8065a28156ad53d681b5d38d4e2e7cde25.zip
app-editors/focuswriter: version bump
Package-Manager: portage-2.3.0
-rw-r--r--app-editors/focuswriter/Manifest1
-rw-r--r--app-editors/focuswriter/files/focuswriter-1.5.6-unbundle-qtsingleapplication.patch36
-rw-r--r--app-editors/focuswriter/focuswriter-1.5.6.ebuild57
3 files changed, 94 insertions, 0 deletions
diff --git a/app-editors/focuswriter/Manifest b/app-editors/focuswriter/Manifest
index b1ad14f0e935..b5b73cef5a49 100644
--- a/app-editors/focuswriter/Manifest
+++ b/app-editors/focuswriter/Manifest
@@ -1 +1,2 @@
DIST focuswriter-1.5.5-src.tar.bz2 5249014 SHA256 b6a2085587864b2685516d20870d9375803ccdf3472e66bf457382d028c1da0e SHA512 aed6a2e203dcf349ff7fef6caa8e7ab1dbba80da988933c06d6f4ea1ad49ad4c4546b30aaacf9373d1234cb8934daac36f00d0d7b3512d9c3fc4f1e1b273a766 WHIRLPOOL 29795304e6d6687d16d2774cd4d28d0c45382474391d7ad62fa557a134e7c5d11ba6bf81bb81df2b0fb3727b4bb32f705d8fe73a7129f44c8485cc9d8b19b2e1
+DIST focuswriter-1.5.6-src.tar.bz2 5274057 SHA256 ec22ce097ae48d46c9a5c485630a885d67b7a281ca6b760d9d494546ed284b17 SHA512 a8d53d13fc1efb385eb8d9a93cb2ebde688d0d52e7f9ba4cb72cd7181e5ab1cff046358c217e45c939ae5a7f618acfddd57eef4ca0f02e3bb046dfdf361d26b9 WHIRLPOOL 79ec3af30e86ccca46a6c07615b7183541983792f809fdda8a159bd83785f5fe799828d994c23903421dd0628c61a6aa12686826b4d56ca66f6aaaa01f87f64f
diff --git a/app-editors/focuswriter/files/focuswriter-1.5.6-unbundle-qtsingleapplication.patch b/app-editors/focuswriter/files/focuswriter-1.5.6-unbundle-qtsingleapplication.patch
new file mode 100644
index 000000000000..f22f382f98dd
--- /dev/null
+++ b/app-editors/focuswriter/files/focuswriter-1.5.6-unbundle-qtsingleapplication.patch
@@ -0,0 +1,36 @@
+--- a/focuswriter.pro
++++ b/focuswriter.pro
+@@ -90,13 +90,14 @@
+ src/spelling/dictionary_provider_voikko.cpp
+
+ lessThan(QT_MAJOR_VERSION, 5) {
+ SOURCES += src/sdl/sound.cpp
+ } else {
++ CONFIG += qtsingleapplication
+ SOURCES += src/sound.cpp
+ }
+ }
+
+-INCLUDEPATH += src src/fileformats src/qtsingleapplication src/qtzip src/spelling
++INCLUDEPATH += src src/fileformats src/qtzip src/spelling
+
+ # Specify program sources
+ HEADERS += src/action_manager.h \
+@@ -155,8 +156,6 @@
+ src/fileformats/rtf_tokenizer.h \
+ src/fileformats/rtf_writer.h \
+ src/fileformats/txt_reader.h \
+- src/qtsingleapplication/qtsingleapplication.h \
+- src/qtsingleapplication/qtlocalpeer.h \
+ src/qtzip/qtzipreader.h \
+ src/qtzip/qtzipwriter.h \
+ src/spelling/abstract_dictionary.h \
+@@ -219,8 +218,6 @@
+ src/fileformats/rtf_tokenizer.cpp \
+ src/fileformats/rtf_writer.cpp \
+ src/fileformats/txt_reader.cpp \
+- src/qtsingleapplication/qtsingleapplication.cpp \
+- src/qtsingleapplication/qtlocalpeer.cpp \
+ src/qtzip/qtzip.cpp \
+ src/spelling/dictionary_dialog.cpp \
+ src/spelling/dictionary_manager.cpp \
diff --git a/app-editors/focuswriter/focuswriter-1.5.6.ebuild b/app-editors/focuswriter/focuswriter-1.5.6.ebuild
new file mode 100644
index 000000000000..6ad1ab913e02
--- /dev/null
+++ b/app-editors/focuswriter/focuswriter-1.5.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit fdo-mime gnome2-utils qmake-utils
+
+DESCRIPTION="A fullscreen and distraction-free word processor"
+HOMEPAGE="http://gottcode.org/focuswriter/"
+SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="LGPL-3 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/hunspell
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsingleapplication[qt5,X]
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog CREDITS NEWS README )
+
+PATCHES=( "${FILESDIR}/${PN}-1.5.6-unbundle-qtsingleapplication.patch" )
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}