summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-03 23:51:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-04 00:44:22 +0200
commitbb67834fa0e8fe243c45287e75e2810b93675d34 (patch)
tree29afd7b55d75e9149b30cf38a2e11d25ce4acfc5
parentdev-python/flask-appconfig: add Python 3.7 support, missing doc dep (diff)
downloadgentoo-bb67834fa0e8fe243c45287e75e2810b93675d34.tar.gz
gentoo-bb67834fa0e8fe243c45287e75e2810b93675d34.tar.bz2
gentoo-bb67834fa0e8fe243c45287e75e2810b93675d34.zip
dev-libs/rasqal: Drop 0.9.29
Closes: https://bugs.gentoo.org/464812 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
-rw-r--r--dev-libs/rasqal/Manifest1
-rw-r--r--dev-libs/rasqal/rasqal-0.9.29.ebuild72
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-libs/rasqal/Manifest b/dev-libs/rasqal/Manifest
index 82f8214f9b13..d408a528953e 100644
--- a/dev-libs/rasqal/Manifest
+++ b/dev-libs/rasqal/Manifest
@@ -1,2 +1 @@
-DIST rasqal-0.9.29.tar.gz 1550144 BLAKE2B 205fc4864a86447246d43b52c2defa00b17628c2a6f459dc40b0fa79b42cd306405f31f600d5ad535891d2f79c46970d77f559249d6a22578d9b83e28d2fb46c SHA512 9795e2ffd439157af7d386ef7191fed3c960e88f04e46ec80bf845986841b9fb094219c561144cbe9ada5582264b32eec4850cf8f2258661d09f2df9dbffda4d
DIST rasqal-0.9.32.tar.gz 1544623 BLAKE2B c94833d2906fc211d743d63a52478e6acc9f26c7528beb1bea0ec8c365b5d13e6ac85e57b75b920d1ccb5768112d06cf615212c7bf248120671730c5095b3c88 SHA512 071f5ff30a1271bdd747cab7991a34c75f9c0132e81d7662acb13a2e380b98c325a9b2998f6a08a393251623680074a76f58f70bdd93b5c1416779aacc7be428
diff --git a/dev-libs/rasqal/rasqal-0.9.29.ebuild b/dev-libs/rasqal/rasqal-0.9.29.ebuild
deleted file mode 100644
index 5851683b32c7..000000000000
--- a/dev-libs/rasqal/rasqal-0.9.29.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit libtool
-
-DESCRIPTION="library that handles Resource Description Framework (RDF)"
-HOMEPAGE="http://librdf.org/rasqal/"
-SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="+crypt doc gmp kernel_linux +mhash pcre static-libs test xml"
-
-RDEPEND=">=media-libs/raptor-2.0.7:2
- kernel_linux? ( >=sys-apps/util-linux-2.19 )
- pcre? ( dev-libs/libpcre )
- xml? ( dev-libs/libxml2 )
- !gmp? ( dev-libs/mpfr )
- gmp? ( dev-libs/gmp )
- crypt? (
- !mhash? ( dev-libs/libgcrypt:0 )
- mhash? ( app-crypt/mhash )
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- sys-devel/flex
- test? ( dev-perl/XML-DOM )"
-
-DOCS=( AUTHORS ChangeLog NEWS README )
-
-src_prepare() {
- sed -i -e '/random_approach/s:==:=:' configure || die #416659
- elibtoolize # g/fbsd .so versioning
-}
-
-src_configure() {
- # FIXME: From 0.9.27 to .28 --with-random-approach= was introduced, do we
- # need a logic for it? Perhaps for dev-libs/gmp?
-
- local regex=posix
- local decimal=mpfr
- local digest=internal
- local uuid=internal
-
- use pcre && regex=pcre
- use gmp && decimal=gmp
- use kernel_linux && uuid=libuuid
-
- if use crypt; then
- digest=gcrypt
- use mhash && digest=mhash
- fi
-
- econf \
- $(use_enable pcre) \
- $(use_enable static-libs static) \
- $(use_enable xml xml2) \
- --with-regex-library=${regex} \
- --with-digest-library=${digest} \
- --with-uuid-library=${uuid} \
- --with-decimal=${decimal} \
- --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
-}
-
-src_install() {
- default
- dohtml {NEWS,README,RELEASE}.html
- use doc || rm -rf "${ED}"/usr/share/doc/${PF}/html/rasqal
- find "${ED}" -name '*.la' -exec rm -f '{}' +
-}