summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-03-20 23:10:59 -0400
committerMike Gilbert <floppym@gentoo.org>2019-03-20 23:10:59 -0400
commitbddcef62229d2a58f04924e848a014980e6f47bf (patch)
treef3ab329a9727103373b847cc63d92839229a5cf3
parentapp-emulation/sen: Drop python3_7 support. Missing deps. (diff)
downloadgentoo-bddcef62229d2a58f04924e848a014980e6f47bf.tar.gz
gentoo-bddcef62229d2a58f04924e848a014980e6f47bf.tar.bz2
gentoo-bddcef62229d2a58f04924e848a014980e6f47bf.zip
sys-boot/grub: bootstrap gnulib in the live ebuild
Package-Manager: Portage-2.3.62, Repoman-2.3.12_p83 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-boot/grub/grub-9999.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 662c83807eeb..0663509415ed 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,6 +6,7 @@ EAPI=6
if [[ ${PV} == 9999 ]]; then
GRUB_AUTOGEN=1
GRUB_AUTORECONF=1
+ GRUB_BOOTSTRAP=1
fi
if [[ -n ${GRUB_AUTOGEN} ]]; then
@@ -136,6 +137,11 @@ QA_MULTILIB_PATHS="usr/lib/grub/.*"
src_unpack() {
if [[ ${PV} == 9999 ]]; then
git-r3_src_unpack
+ cd "${P}" || die
+ local GNULIB_URI="https://git.savannah.gnu.org/git/gnulib.git"
+ local GNULIB_REVISION=$(source bootstrap.conf; echo "${GNULIB_REVISION}")
+ git-r3_fetch "${GNULIB_URI}" "${GNULIB_REVISION}"
+ git-r3_checkout "${GNULIB_URI}" gnulib
fi
default
}
@@ -160,11 +166,15 @@ src_prepare() {
if [[ -n ${GRUB_AUTOGEN} ]]; then
python_setup
- bash autogen.sh || die
+ if [[ -n ${GRUB_BOOTSTRAP} ]]; then
+ eautopoint --force
+ AUTOPOINT=: AUTORECONF=: ./bootstrap || die
+ else
+ ./autogen.sh || die
+ fi
fi
if [[ -n ${GRUB_AUTORECONF} ]]; then
- autopoint() { :; }
eautoreconf
fi
}