summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorband-a-prend <torokhov-s-a@yandex.ru>2020-01-23 13:47:25 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-25 22:09:39 +0100
commitbe43680da3d0c4fb7f31ed5740dd078d3428f072 (patch)
tree7155027b1ce4a749b302bfdd10d2fb27abc327d8
parentmedia-libs/babl: add maintainer, sort IUSE and conf options (diff)
downloadgentoo-be43680da3d0c4fb7f31ed5740dd078d3428f072.tar.gz
gentoo-be43680da3d0c4fb7f31ed5740dd078d3428f072.tar.bz2
gentoo-be43680da3d0c4fb7f31ed5740dd078d3428f072.zip
media-libs/gegl: 0.4.20 version bump, 9999 deps update
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-libs/gegl/Manifest1
-rw-r--r--media-libs/gegl/gegl-0.4.20.ebuild163
-rw-r--r--media-libs/gegl/gegl-9999.ebuild10
3 files changed, 168 insertions, 6 deletions
diff --git a/media-libs/gegl/Manifest b/media-libs/gegl/Manifest
index 9a9f3f3851cd..38747b32436f 100644
--- a/media-libs/gegl/Manifest
+++ b/media-libs/gegl/Manifest
@@ -4,3 +4,4 @@ DIST gegl-0.3.34.tar.bz2 6707964 BLAKE2B 4424a2c218067bd0a77d79c2334528da393350d
DIST gegl-0.4.14.tar.bz2 7209142 BLAKE2B a056f02c3fa9e075aa62cb8cb0d8183560ac66ffed68072add3ea6afc9da3b47c9854eb4e1799c61f451287b244bee4dfc8942365f556a0e820dd7485b9fc305 SHA512 1fcec83a961c0b9c98487de99d26893f98a5401816fa6d7238af4c645672d0eb0474cdb7251b8ebcd344aff589e8979bee0304b50fcfae9513fdbf8a02068e3b
DIST gegl-0.4.16.tar.bz2 7304904 BLAKE2B a3f6021ed7b9d8b784b909057fcdc39e73b6b8b811009adae3c4a6805263e9a887e874ad662d8cd5c673ae324fe39e8f0299651139783fd3ece08675b70896fd SHA512 38eacbd53d9993ca99d061bf6f80553a86ff06bf42d1710403ac5f15629ccc9b1f4395ee7700a04cebc954ed7fe8745c5bef85453c9c56d89681dd53a1552b27
DIST gegl-0.4.18.tar.xz 4812756 BLAKE2B b8e5902b62c3549f57dd0ce52a0a406974bf8664d5b85389b79f7d698bcf2643d19861add3d8a9bd5c99036aba4da97b70884dcaacf2cb89170b995f1d1497a0 SHA512 e79874cd50e9f0c27c7dc9d9b952545c31d0a48e2b158aa54b92c3e933267877222f86ede7256f2528f18985dc85d6eadbcd809f7a3563efc4449ec7634f15fd
+DIST gegl-0.4.20.tar.xz 4826340 BLAKE2B 0d1087ea983d7fbeb7ea1edb572bea97e9b4e01aaabd5225ba07ab5cee3b369f42fe39691209f38d4d2a87d56997d9756449cafdb6288eb0864b49fb13a6a8ef SHA512 140ac1543aa24a23aa685dbd7335f21bcbf3d95c41c1451b2383f6d278842bd9f0c8c980ed27c70c67b2fefe9ba01f2d4bd4b77a1cee38ec1332c12ab3fd718d
diff --git a/media-libs/gegl/gegl-0.4.20.ebuild b/media-libs/gegl/gegl-0.4.20.ebuild
new file mode 100644
index 000000000000..5623528869a2
--- /dev/null
+++ b/media-libs/gegl/gegl-0.4.20.ebuild
@@ -0,0 +1,163 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+# vala and introspection support is broken, bug #468208
+VALA_USE_DEPEND=vapigen
+
+inherit meson gnome2-utils python-any-r1 vala
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gegl.git"
+ SRC_URI=""
+else
+ SRC_URI="http://download.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A graph based image processing framework"
+HOMEPAGE="http://www.gegl.org/"
+
+LICENSE="|| ( GPL-3+ LGPL-3 )"
+SLOT="0.4"
+
+IUSE="cairo debug ffmpeg introspection lcms lensfun libav openexr pdf raw sdl svg test tiff umfpack vala v4l webp"
+REQUIRED_USE="
+ svg? ( cairo )
+ test? ( introspection )
+ vala? ( introspection )
+"
+
+RESTRICT="!test? ( test )"
+
+# NOTE: Even current libav 11.4 does not have AV_CODEC_CAP_VARIABLE_FRAME_SIZE
+# so there is no chance to support libav right now (Gentoo bug #567638)
+# If it returns, please check prior GEGL ebuilds for how libav was integrated. Thanks!
+RDEPEND="
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/json-glib-1.2.6
+ >=media-libs/babl-0.1.74[introspection?]
+ media-libs/libnsgif
+ >=media-libs/libpng-1.6.0:0=
+ >=sys-libs/zlib-1.2.0
+ virtual/jpeg:0=
+ >=x11-libs/gdk-pixbuf-2.32:2
+ >=x11-libs/pango-1.38.0
+ cairo? ( >=x11-libs/cairo-1.12.2 )
+ ffmpeg? (
+ libav? ( media-video/libav:0= )
+ !libav? ( media-video/ffmpeg:0= )
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+ lcms? ( >=media-libs/lcms-2.8:2 )
+ lensfun? ( >=media-libs/lensfun-0.2.5 )
+ openexr? ( >=media-libs/openexr-1.6.1:= )
+ pdf? ( >=app-text/poppler-0.71.0[cairo] )
+ raw? ( >=media-libs/libraw-0.15.4:0= )
+ sdl? ( >=media-libs/libsdl-1.2.0 )
+ svg? ( >=gnome-base/librsvg-2.40.6:2 )
+ tiff? ( >=media-libs/tiff-4:0 )
+ umfpack? ( sci-libs/umfpack )
+ v4l? ( >=media-libs/libv4l-1.0.1 )
+ webp? ( >=media-libs/libwebp-0.5.0:= )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ dev-lang/perl
+ >=dev-util/gtk-doc-am-1
+ >=sys-devel/gettext-0.19.8
+ >=sys-devel/libtool-2.2
+ virtual/pkgconfig
+ test? ( $(python_gen_any_dep '>=dev-python/pygobject-3.2:3[${PYTHON_USEDEP}]') )
+ vala? ( $(vala_depend) )
+"
+
+DOCS=( AUTHORS docs/ChangeLog docs/NEWS.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.18-drop-failing-tests.patch
+ "${FILESDIR}"/${PN}-0.4.18-program-suffix.patch
+ "${FILESDIR}"/${PN}-0.4.18-cltostring_force_utf8.patch
+)
+
+python_check_deps() {
+ has_version -b ">=dev-python/pygobject-3.2:3[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # don't require Apple's OpenCL on versions of OSX that don't have it
+ if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -le 9 ]] ; then
+ sed -i -e 's/#ifdef __APPLE__/#if 0/' gegl/opencl/* || die
+ fi
+
+ # commit 7c78497b : tests that use gegl.png are broken on non-amd64
+ sed -e '/clones.xml/d' \
+ -e '/composite-transform.xml/d' \
+ -i tests/compositions/meson.build || die
+
+ # fix skipping mipmap tests due to executable not found
+ for item in "invert-crop.sh" "invert.sh" "rotate-crop.sh" "rotate.sh" "unsharp-crop.sh" "unsharp.sh"; do
+ sed -i "s:/bin/gegl:/bin/gegl-0.4:g" "${S}/tests/mipmap/${item}" || die
+ sed -i "s:/tools/gegl-imgcmp:/tools/gegl-imgcmp-0.4:g" "${S}/tests/mipmap/${item}" || die
+ done
+
+ gnome2_environment_reset
+
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ # - Disable documentation as the generating is bit automagic
+ # if anyone wants to work on it just create bug with patch
+ -Ddocs=false
+ -Dexiv2=disabled
+ -Dgdk-pixbuf=enabled
+ -Dgexiv2=disabled
+ # - There are two checks for dot, one controllable by --with(out)-graphviz
+ # which toggles HAVE_GRAPHVIZ that is not used anywhere. Yes.
+ -Dgraphviz=disabled
+ -Djasper=disabled
+ -Dlibjpeg=enabled
+ -Dlibpng=enabled
+ # - libspiro: not in portage main tree
+ -Dlibspiro=disabled
+ -Dlua=disabled
+ -Dmrg=disabled
+ -Dpango=enabled
+ -Dsdl2=disabled
+ # - Parameter -Dworkshop=false disables any use of Lua, effectivly
+ -Dworkshop=false
+ $(meson_feature cairo)
+ $(meson_feature cairo pangocairo)
+ $(meson_feature ffmpeg libav)
+ $(meson_feature lcms)
+ $(meson_feature lensfun)
+ $(meson_feature openexr)
+ $(meson_feature raw libraw)
+ $(meson_feature sdl sdl1)
+ $(meson_feature svg librsvg)
+ $(meson_feature test pygobject)
+ $(meson_feature tiff libtiff)
+ $(meson_feature umfpack)
+ # - v4l support does not work with our media-libs/libv4l-0.8.9,
+ # upstream bug at https://bugzilla.gnome.org/show_bug.cgi?id=654675
+ $(meson_feature v4l libv4l)
+ $(meson_feature v4l libv4l2)
+ $(meson_feature vala vapigen)
+ $(meson_feature webp)
+ $(meson_use introspection)
+ )
+ meson_src_configure
+}
diff --git a/media-libs/gegl/gegl-9999.ebuild b/media-libs/gegl/gegl-9999.ebuild
index 98a250798f67..25f257ba42c8 100644
--- a/media-libs/gegl/gegl-9999.ebuild
+++ b/media-libs/gegl/gegl-9999.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7}} )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
# vala and introspection support is broken, bug #468208
VALA_USE_DEPEND=vapigen
@@ -15,7 +15,7 @@ if [[ ${PV} == *9999* ]]; then
SRC_URI=""
else
SRC_URI="http://download.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
fi
DESCRIPTION="A graph based image processing framework"
@@ -39,7 +39,7 @@ RESTRICT="!test? ( test )"
RDEPEND="
>=dev-libs/glib-2.44:2
>=dev-libs/json-glib-1.2.6
- >=media-libs/babl-0.1.72[introspection?]
+ >=media-libs/babl-0.1.74[introspection?]
media-libs/libnsgif
>=media-libs/libpng-1.6.0:0=
>=sys-libs/zlib-1.2.0
@@ -65,9 +65,7 @@ RDEPEND="
webp? ( >=media-libs/libwebp-0.5.0:= )
"
-DEPEND="
- ${RDEPEND}
-"
+DEPEND="${RDEPEND}"
BDEPEND="
dev-lang/perl