summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2017-02-02 13:53:40 -0600
committerDoug Goldstein <cardoe@gentoo.org>2017-02-02 14:04:01 -0600
commitbe6e0043a41878ed56ba609da1ae6a03aea7157b (patch)
treefd08d018e08584c7c426c8b8be149142406c277e
parentfixes bug #607980 (diff)
downloadgentoo-be6e0043a41878ed56ba609da1ae6a03aea7157b.tar.gz
gentoo-be6e0043a41878ed56ba609da1ae6a03aea7157b.tar.bz2
gentoo-be6e0043a41878ed56ba609da1ae6a03aea7157b.zip
dev-util/cargo: fix build failure
Fixed build failure with a patch from Will Mortensen <will@extrahop.com>. This will cause cargo to use the proper snapshot to bootstrap itself. Gentoo-Bug: 603898 Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
-rw-r--r--dev-util/cargo/cargo-0.15.0.ebuild1
1 files changed, 1 insertions, 0 deletions
diff --git a/dev-util/cargo/cargo-0.15.0.ebuild b/dev-util/cargo/cargo-0.15.0.ebuild
index 4dc1bf59412f..7f134b34782b 100644
--- a/dev-util/cargo/cargo-0.15.0.ebuild
+++ b/dev-util/cargo/cargo-0.15.0.ebuild
@@ -134,6 +134,7 @@ src_configure() {
--host=${CTARGET}
--build=${CTARGET}
--target=${CTARGET}
+ --cargo="${WORKDIR}"/${P}/target/snapshot/bin/cargo
--enable-optimize
# --release-channel stable
--disable-verify-install