summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-18 08:10:08 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-18 08:52:32 +0200
commitbee1f1fd4746022ec0009e903a135476d71e7da5 (patch)
treef9e40e11ca892b378b293817ce32e82891dfcd93
parentdev-ruby/webmock: remove obsolete http slot (diff)
downloadgentoo-bee1f1fd4746022ec0009e903a135476d71e7da5.tar.gz
gentoo-bee1f1fd4746022ec0009e903a135476d71e7da5.tar.bz2
gentoo-bee1f1fd4746022ec0009e903a135476d71e7da5.zip
xfce-base/thunar: Bump to 1.8.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/thunar/Manifest1
-rw-r--r--xfce-base/thunar/thunar-1.8.5.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index 2a04f954fbd9..86b6aa90b8a9 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -1,3 +1,4 @@
DIST Thunar-1.6.14.tar.bz2 1964822 BLAKE2B f080f3d0634b4b4a8e11cdb902d5f300b1829979a98b573bdb6fd11b273cdc5e37f8e8c03556561b9f8730a70c7f7c34cbfbda76fe90f86cf2c443c3f426aabe SHA512 63287e35e71a6d1cb75a4d4db4d05f0fdf34d43b0ce7a2094e6aa9042d16f3eb60f7c5d755810bb0807112177e37954ba566b4f0ef701766205ed9e5561bd6e1
DIST Thunar-1.6.16.tar.bz2 1977562 BLAKE2B efad6b45a64c5c80bff3d829207a1a0b45b4b48ab168c38bbcd263445a16dc230b0c5ea7515b65d686cbf256d294bcced19b248c252478a6a1cecb393d71a7f6 SHA512 6c7b8b88e01762e606bfd9e3848a98ae5825ff431f0686dd7bbcb987e448aa4c20d7cca3fb6b7c5d5dfde91ae6f8a16e674769d168f6f875e2efe519f4cdfd1b
DIST Thunar-1.8.4.tar.bz2 2349249 BLAKE2B 4f1ac9c3177587b5ff2f3acd7220fb08921fc9db9711dd5925b65068db9bb14e7cf9d17834a96395c3fc27927030dbd2ba70d08c5b14d28e4aaf553493bce5f2 SHA512 886c0789aa19c2ab2ef34892c4afd09c857585b4796140ea3c84ccb9e1e1ca2935cf7e3a760a6ca8d8c68a5866663412500b4779878c7f48c9365c3ac7bf0eec
+DIST Thunar-1.8.5.tar.bz2 2303914 BLAKE2B e47e3e635e883ea4d044c8a66014bc11f21da780b1d834f25678763ace0609ee77755fc04b6a437f238275b0a9bf8df485cc826a6bfef93751427ee93d7e43ac SHA512 491f1a69cc1e825c9c2493af719ba22811d1300f1dfe06e98c45c878649921608d14c08e4f61551dfa3d5227ea0b0af6abad1c953d6fe4b9274ade76bc33e6cc
diff --git a/xfce-base/thunar/thunar-1.8.5.ebuild b/xfce-base/thunar/thunar-1.8.5.ebuild
new file mode 100644
index 000000000000..b16e12d6a0f6
--- /dev/null
+++ b/xfce-base/thunar/thunar-1.8.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit virtualx xdg-utils
+
+MY_P=${P^}
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/ https://docs.xfce.org/xfce/thunar/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="exif introspection libnotify pcre test +trash-panel-plugin udisks"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+COMMON_DEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.30:=
+ >=x11-libs/gdk-pixbuf-2.14:=
+ >=x11-libs/gtk+-3.22:3=
+ >=xfce-base/exo-0.12:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ pcre? ( >=dev-libs/libpcre-6:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( virtual/libgudev:= )"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? ( ${GVFS_DEPEND} )
+ udisks? (
+ virtual/udev
+ ${GVFS_DEPEND}[udisks,udev]
+ )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( AUTHORS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}