summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2017-06-07 17:55:55 -0400
committerJustin Bronder <jsbronder@gentoo.org>2017-06-07 17:56:10 -0400
commitc04c5c0fb843fe64313fba9e409ecb06bbe3c1ce (patch)
tree30b8581ba54bf80511c33e226dc02a3ded623c42
parentdev-python/sabyenc: initial import (diff)
downloadgentoo-c04c5c0fb843fe64313fba9e409ecb06bbe3c1ce.tar.gz
gentoo-c04c5c0fb843fe64313fba9e409ecb06bbe3c1ce.tar.bz2
gentoo-c04c5c0fb843fe64313fba9e409ecb06bbe3c1ce.zip
net-nntp/sabnzbd: bump 2.0.1
- Depend on dev-python/sabyenc - Re-bundle rarfile due to upstream patches - Add optional 7za support - Add dependency on dev-python/cryptography - Update pkg_postinst message for 2.x series Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--net-nntp/sabnzbd/Manifest2
-rw-r--r--net-nntp/sabnzbd/files/patches/0001-use-system-configobj.patch10
-rw-r--r--net-nntp/sabnzbd/files/patches/0002-use-system-feedparser.patch6
-rw-r--r--net-nntp/sabnzbd/files/patches/0003-use-gntp-1.0.patch6
-rw-r--r--net-nntp/sabnzbd/files/patches/0004-cfg-disable-growl-by-default.patch10
-rw-r--r--net-nntp/sabnzbd/files/patches/0005-use-system-rarfile.patch88
-rw-r--r--net-nntp/sabnzbd/metadata.xml3
-rw-r--r--net-nntp/sabnzbd/sabnzbd-2.0.1.ebuild (renamed from net-nntp/sabnzbd/sabnzbd-1.2.3-r1.ebuild)22
8 files changed, 30 insertions, 117 deletions
diff --git a/net-nntp/sabnzbd/Manifest b/net-nntp/sabnzbd/Manifest
index 51635e61cb9d..4487dcf6c42d 100644
--- a/net-nntp/sabnzbd/Manifest
+++ b/net-nntp/sabnzbd/Manifest
@@ -1 +1 @@
-DIST SABnzbd-1.2.3-src.tar.gz 2725678 SHA256 a0100d19edd9c6b528f79214a64690941281758048e4ead6671446070e1e9e24 SHA512 80677df12a278a12a20405812f4f434625fa3a9dd769d8734b92771436a82ec6810fbc180e2b9b4ca9e15efc14b79d217b1392ff2a43785b803966afb9e3eb80 WHIRLPOOL f9dd40f16fe3743a6e62d6dd4d7aa83855e0131b4a817af007f2319cb6845a604c61144f4f35a123d79d4633bbc2cee2616ebbe1e8cbf4e97729682a9e8eb436
+DIST SABnzbd-2.0.1-src.tar.gz 2715648 SHA256 62619aab1c741e5d9088bfa177418da2961b82e58f93a763154514fb9d94880f SHA512 d23d5848fc69d1e2f9ddce266af3dabc3e6fb746177fdc87cf376e2fda5ff17c60caf65af74440a5dafb23435a32c7061da92e82e2608a750a7102aa802fe748 WHIRLPOOL 2a93830067e45b4862aa13d81de9e61802f52dc230a9d578c5af0796ae943f05ea3ab00a0249bd9681010c4ab7fb95e06b08077607cbba23ce306c8bdb09979c
diff --git a/net-nntp/sabnzbd/files/patches/0001-use-system-configobj.patch b/net-nntp/sabnzbd/files/patches/0001-use-system-configobj.patch
index 32d4b27000a5..bca7f1eb2efa 100644
--- a/net-nntp/sabnzbd/files/patches/0001-use-system-configobj.patch
+++ b/net-nntp/sabnzbd/files/patches/0001-use-system-configobj.patch
@@ -1,4 +1,4 @@
-From 74213e601bdb299a18e6eda8d71d4df28d871286 Mon Sep 17 00:00:00 2001
+From 55328c07986010fd7c91c7da42bca136fc4cd2e9 Mon Sep 17 00:00:00 2001
From: Justin Bronder <jsbronder@gmail.com>
Date: Mon, 13 Feb 2017 18:20:39 -0500
Subject: [PATCH 1/5] use system configobj
@@ -8,13 +8,13 @@ Subject: [PATCH 1/5] use system configobj
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/sabnzbd/config.py b/sabnzbd/config.py
-index ab5da99..1043298 100644
+index 93dd9bb..aab1648 100644
--- a/sabnzbd/config.py
+++ b/sabnzbd/config.py
-@@ -27,9 +27,10 @@ import shutil
+@@ -26,9 +26,10 @@ import threading
+ import shutil
import sabnzbd.misc
from sabnzbd.constants import CONFIG_VERSION, NORMAL_PRIORITY, DEFAULT_PRIORITY, MAX_WIN_DFOLDER
- from sabnzbd.utils import listquote
-from sabnzbd.utils import configobj
from sabnzbd.decorators import synchronized
@@ -24,5 +24,5 @@ index ab5da99..1043298 100644
SAVE_CONFIG_LOCK = threading.Lock()
--
-2.7.3
+2.10.2
diff --git a/net-nntp/sabnzbd/files/patches/0002-use-system-feedparser.patch b/net-nntp/sabnzbd/files/patches/0002-use-system-feedparser.patch
index fef142ec6898..790e86f3c551 100644
--- a/net-nntp/sabnzbd/files/patches/0002-use-system-feedparser.patch
+++ b/net-nntp/sabnzbd/files/patches/0002-use-system-feedparser.patch
@@ -1,4 +1,4 @@
-From 04a18875d34f677a89bdf1bf57db7f236216e70e Mon Sep 17 00:00:00 2001
+From 6a28d8ba51e902e9d49ad6c18fa2de6511908119 Mon Sep 17 00:00:00 2001
From: Justin Bronder <jsbronder@gmail.com>
Date: Mon, 13 Feb 2017 18:21:28 -0500
Subject: [PATCH 2/5] use system feedparser
@@ -8,7 +8,7 @@ Subject: [PATCH 2/5] use system feedparser
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/sabnzbd/rss.py b/sabnzbd/rss.py
-index 73ec2b4..069aed0 100644
+index 9987e91..8ee1552 100644
--- a/sabnzbd/rss.py
+++ b/sabnzbd/rss.py
@@ -25,6 +25,8 @@ import time
@@ -30,5 +30,5 @@ index 73ec2b4..069aed0 100644
--
-2.7.3
+2.10.2
diff --git a/net-nntp/sabnzbd/files/patches/0003-use-gntp-1.0.patch b/net-nntp/sabnzbd/files/patches/0003-use-gntp-1.0.patch
index d8e2d82df311..d4d97fe208eb 100644
--- a/net-nntp/sabnzbd/files/patches/0003-use-gntp-1.0.patch
+++ b/net-nntp/sabnzbd/files/patches/0003-use-gntp-1.0.patch
@@ -1,4 +1,4 @@
-From 94ce3d83c9d921be01015b06881e79097aca3f82 Mon Sep 17 00:00:00 2001
+From 821a02104149aa65a6581730457eddbe082153cc Mon Sep 17 00:00:00 2001
From: Justin Bronder <jsbronder@gmail.com>
Date: Mon, 13 Feb 2017 18:23:46 -0500
Subject: [PATCH 3/5] use >=gntp-1.0
@@ -8,7 +8,7 @@ Subject: [PATCH 3/5] use >=gntp-1.0
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/sabnzbd/notifier.py b/sabnzbd/notifier.py
-index 5732f03..b1dc9d6 100644
+index f99083f..581eda0 100644
--- a/sabnzbd/notifier.py
+++ b/sabnzbd/notifier.py
@@ -39,7 +39,7 @@ from sabnzbd.constants import NOTIFY_KEYS
@@ -21,5 +21,5 @@ index 5732f03..b1dc9d6 100644
try:
import Growl
--
-2.7.3
+2.10.2
diff --git a/net-nntp/sabnzbd/files/patches/0004-cfg-disable-growl-by-default.patch b/net-nntp/sabnzbd/files/patches/0004-cfg-disable-growl-by-default.patch
index 695ace4f6b09..072c3d014626 100644
--- a/net-nntp/sabnzbd/files/patches/0004-cfg-disable-growl-by-default.patch
+++ b/net-nntp/sabnzbd/files/patches/0004-cfg-disable-growl-by-default.patch
@@ -1,4 +1,4 @@
-From 395378c67bbae92fcbb450a2353bb44e157e51e2 Mon Sep 17 00:00:00 2001
+From 6574da3da07b789a6cdbeebc8e36da8a0559924b Mon Sep 17 00:00:00 2001
From: Justin Bronder <jsbronder@gmail.com>
Date: Tue, 14 Jun 2016 08:38:54 -0400
Subject: [PATCH 4/5] cfg: disable growl by default
@@ -8,10 +8,10 @@ Subject: [PATCH 4/5] cfg: disable growl by default
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/sabnzbd/cfg.py b/sabnzbd/cfg.py
-index ecfc544..115e46e 100644
+index f06b79e..c66fe91 100644
--- a/sabnzbd/cfg.py
+++ b/sabnzbd/cfg.py
-@@ -291,7 +291,7 @@ acenter_prio_queue_done = OptionBool('acenter', 'acenter_prio_queue_done', True)
+@@ -277,7 +277,7 @@ acenter_prio_queue_done = OptionBool('acenter', 'acenter_prio_queue_done', True)
acenter_prio_other = OptionBool('acenter', 'acenter_prio_other', False)
# [ntfosd]
@@ -20,7 +20,7 @@ index ecfc544..115e46e 100644
ntfosd_prio_startup = OptionBool('ntfosd', 'ntfosd_prio_startup', True)
ntfosd_prio_download = OptionBool('ntfosd', 'ntfosd_prio_download', False)
ntfosd_prio_pp = OptionBool('ntfosd', 'ntfosd_prio_pp', False)
-@@ -305,7 +305,7 @@ ntfosd_prio_queue_done = OptionBool('ntfosd', 'ntfosd_prio_queue_done', True)
+@@ -291,7 +291,7 @@ ntfosd_prio_queue_done = OptionBool('ntfosd', 'ntfosd_prio_queue_done', True)
ntfosd_prio_other = OptionBool('ntfosd', 'ntfosd_prio_other', False)
# [growl]
@@ -30,5 +30,5 @@ index ecfc544..115e46e 100644
growl_password = OptionPassword('growl', 'growl_password')
growl_prio_startup = OptionBool('growl', 'growl_prio_startup', True)
--
-2.7.3
+2.10.2
diff --git a/net-nntp/sabnzbd/files/patches/0005-use-system-rarfile.patch b/net-nntp/sabnzbd/files/patches/0005-use-system-rarfile.patch
deleted file mode 100644
index 28b9fed106f5..000000000000
--- a/net-nntp/sabnzbd/files/patches/0005-use-system-rarfile.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From a55087bb61e68c9a14663d0c52c68b6afef51ce5 Mon Sep 17 00:00:00 2001
-From: Justin Bronder <jsbronder@gmail.com>
-Date: Mon, 13 Feb 2017 18:27:00 -0500
-Subject: [PATCH 5/5] use system rarfile
-
----
- sabnzbd/assembler.py | 2 +-
- sabnzbd/dirscanner.py | 2 +-
- sabnzbd/newsunpack.py | 2 +-
- sabnzbd/postproc.py | 2 +-
- 4 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/sabnzbd/assembler.py b/sabnzbd/assembler.py
-index 71d02a5..068ef95 100644
---- a/sabnzbd/assembler.py
-+++ b/sabnzbd/assembler.py
-@@ -24,6 +24,7 @@ import Queue
- import logging
- import struct
- import re
-+import rarfile
- from threading import Thread
- from time import sleep
- try:
-@@ -41,7 +42,6 @@ import sabnzbd.cfg as cfg
- from sabnzbd.articlecache import ArticleCache
- from sabnzbd.postproc import PostProcessor
- import sabnzbd.downloader
--import sabnzbd.utils.rarfile as rarfile
- from sabnzbd.encoding import unicoder, deunicode, is_utf8
- from sabnzbd.rating import Rating
-
-diff --git a/sabnzbd/dirscanner.py b/sabnzbd/dirscanner.py
-index 8408c64..56e6365 100644
---- a/sabnzbd/dirscanner.py
-+++ b/sabnzbd/dirscanner.py
-@@ -26,10 +26,10 @@ import zipfile
- import gzip
- import bz2
- import threading
-+import rarfile
-
- import sabnzbd
- from sabnzbd.constants import SCAN_FILE_NAME, VALID_ARCHIVES
--import sabnzbd.utils.rarfile as rarfile
- from sabnzbd.encoding import platform_encode
- from sabnzbd.newsunpack import is_sevenfile, SevenZip
- import sabnzbd.nzbstuff as nzbstuff
-diff --git a/sabnzbd/newsunpack.py b/sabnzbd/newsunpack.py
-index 27730bd..15adc4a 100644
---- a/sabnzbd/newsunpack.py
-+++ b/sabnzbd/newsunpack.py
-@@ -27,11 +27,11 @@ import logging
- from time import time
- import binascii
- import shutil
-+import rarfile
-
- import sabnzbd
- from sabnzbd.encoding import TRANS, UNTRANS, unicode2local, \
- reliable_unpack_names, unicoder, platform_encode, deunicode
--import sabnzbd.utils.rarfile as rarfile
- from sabnzbd.misc import format_time_string, find_on_path, make_script_path, int_conv, \
- flag_file, real_path, globber, globber_full, short_path, get_all_passwords
- from sabnzbd.tvsort import SeriesSorter
-diff --git a/sabnzbd/postproc.py b/sabnzbd/postproc.py
-index c13025d..f016d93 100644
---- a/sabnzbd/postproc.py
-+++ b/sabnzbd/postproc.py
-@@ -26,6 +26,7 @@ import sabnzbd
- import xml.sax.saxutils
- import time
- import re
-+import rarfile
-
- from sabnzbd.newsunpack import unpack_magic, par2_repair, external_processing, \
- sfv_check, build_filelists, rar_sort
-@@ -48,7 +49,6 @@ import sabnzbd.cfg as cfg
- import sabnzbd.nzbqueue
- import sabnzbd.database as database
- import sabnzbd.notifier as notifier
--import sabnzbd.utils.rarfile as rarfile
-
-
- class PostProcessor(Thread):
---
-2.7.3
-
diff --git a/net-nntp/sabnzbd/metadata.xml b/net-nntp/sabnzbd/metadata.xml
index 09a69c40cb43..1bd96f540af7 100644
--- a/net-nntp/sabnzbd/metadata.xml
+++ b/net-nntp/sabnzbd/metadata.xml
@@ -5,12 +5,11 @@
<email>jsbronder@gentoo.org</email>
</maintainer>
<use>
+ <flag name="7za">Add support for extracting 7za files</flag>
<flag name="rar">Add support for extracting rar files</flag>
<flag name="unzip">Add support for extracting zip files</flag>
- <flag name="yenc">Use yenc to speed up nntp encoding and decoding</flag>
</use>
<upstream>
- <remote-id type="sourceforge">sabnzbdplus</remote-id>
<remote-id type="github">sabnzbd/sabnzbd</remote-id>
</upstream>
</pkgmetadata>
diff --git a/net-nntp/sabnzbd/sabnzbd-1.2.3-r1.ebuild b/net-nntp/sabnzbd/sabnzbd-2.0.1.ebuild
index d51ad295cec2..672045429780 100644
--- a/net-nntp/sabnzbd/sabnzbd-1.2.3-r1.ebuild
+++ b/net-nntp/sabnzbd/sabnzbd-2.0.1.ebuild
@@ -19,7 +19,7 @@ SRC_URI="https://github.com/sabnzbd/sabnzbd/releases/download/${PV}/${MY_P}-src.
LICENSE="GPL-2 BSD LGPL-2 MIT BSD-1"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="+rar unzip +yenc"
+IUSE="+7za +rar unzip"
# Sabnzbd is installed to /usr/share/ as upstream makes it clear they should not
# be in python's sitedir. See: http://wiki.sabnzbd.org/unix-packaging
@@ -28,6 +28,9 @@ IUSE="+rar unzip +yenc"
# kronos, rsslib, ssmtplib, listquote, json-py, msgfmt, happyeyeballs
# pynewsleecher
#
+# dev-python/rarfile is bundled as of 2.0.1 because sabnzbd is modifying it
+# https://github.com/sabnzbd/sabnzbd/commit/de6d642b0dc6eaed63199a99d9a1a8b2e3d0018b
+#
# Also note that cherrypy is still bundled. It's near impossible to find
# out where the bundled and heavily patched version came from (pulled from
# cherrypy subversion, patched somewhere, then imported to sabnzbd and patched
@@ -39,14 +42,15 @@ RDEPEND="
>=app-arch/par2cmdline-0.4
>=dev-python/cheetah-2.0.1
dev-python/configobj
+ dev-python/cryptography
dev-python/feedparser
dev-python/gntp
dev-python/pythonutils
- dev-python/rarfile
+ dev-python/sabyenc
net-misc/wget
+ 7za? ( app-arch/p7zip )
rar? ( || ( app-arch/unrar app-arch/rar ) )
unzip? ( >=app-arch/unzip-5.5.2 )
- yenc? ( dev-python/yenc )
"
DEPEND="${PYTHON_DEPS}"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -67,9 +71,9 @@ src_prepare() {
eapply "${FILESDIR}"/patches
# remove bundled modules
- rm -r sabnzbd/utils/{feedparser,configobj,rarfile}.py || die
+ rm -r sabnzbd/utils/{feedparser,configobj}.py || die
rm -r gntp || die
- rm licenses/License-{feedparser,configobj,gntp,rarfile}.txt || die
+ rm licenses/License-{feedparser,configobj,gntp}.txt || die
eapply_user
}
@@ -117,13 +121,11 @@ pkg_postinst() {
local replacing
for replacing in ${REPLACING_VERSIONS}; do
- if [ "$(get_major_version ${replacing})" == "0" ]; then
- ewarn
- ewarn "Upgrading from ${PN}-0.x.y to ${PN}-1.x.y introduces incompatible changes, see:"
+ if [ "$(get_major_version ${replacing})" == "1" ]; then
ewarn
- ewarn " https://sabnzbd.org/wiki/introducing-1-0-0"
+ ewarn "Upgrading to ${PN}-2.x.y converts schedule items to a format"
+ ewarn "that is not compatible with earlier ${PN}-1.x.y releases."
ewarn
- ewarn "In particular, you need to let your queue complete before restarting SABnzbd+."
break
fi
done