summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-10-26 11:45:57 +0800
committerIan Delaney <idella4@gentoo.org>2015-10-26 11:47:04 +0800
commitc107dbc80a181895a413e5862ba594365d951bb5 (patch)
tree361795b7886e2d51b0c617c43a82d6e0e63794ec
parentprofiles: quote some variables in hardened/linux/musl (diff)
downloadgentoo-c107dbc80a181895a413e5862ba594365d951bb5.tar.gz
gentoo-c107dbc80a181895a413e5862ba594365d951bb5.tar.bz2
gentoo-c107dbc80a181895a413e5862ba594365d951bb5.zip
dev-python/elasticsearch-py: fix to code re IUSE doc, fixes the gentoo bug
ack to Andrew Wilcox for submission of the patch. Closes the bug Gentoo bug: #564108 Package-Manager: portage-2.2.23
-rw-r--r--dev-python/elasticsearch-py/elasticsearch-py-1.8.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/elasticsearch-py/elasticsearch-py-1.8.0.ebuild b/dev-python/elasticsearch-py/elasticsearch-py-1.8.0.ebuild
index 73ae13bfff6a..482bc302e46b 100644
--- a/dev-python/elasticsearch-py/elasticsearch-py-1.8.0.ebuild
+++ b/dev-python/elasticsearch-py/elasticsearch-py-1.8.0.ebuild
@@ -80,12 +80,14 @@ python_test() {
python_compile_all() {
cd docs || die
- emake man $(usex doc html "")
+ use doc && emake man html
}
python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
+ if use doc; then
+ export HTML_DOCS=( docs/_build/html/. )
+ doman docs/_build/man/*
+ fi
use examples && local EXAMPLES=( example/. )
- doman docs/_build/man/*
distutils-r1_python_install_all
}