summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-07-18 11:55:34 +1200
committerKent Fredric <kentnl@gentoo.org>2017-07-18 16:38:03 +1200
commitc16e51d89ade3ee46c780185a2aad20555ab154b (patch)
tree85a7c8c929f00e18b055f9adcecc3b9081a65028
parentsci-biology/bioperl-db: Fix broken test dependencies (diff)
downloadgentoo-c16e51d89ade3ee46c780185a2aad20555ab154b.tar.gz
gentoo-c16e51d89ade3ee46c780185a2aad20555ab154b.tar.bz2
gentoo-c16e51d89ade3ee46c780185a2aad20555ab154b.zip
sci-biology/bioperl-db: EAPI6/-R1 Bump
- Test infa overhauled slightly - EAPI6ified - More test changes planned - -r1 bump mostly for double-safety around EAPI6 changes Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--sci-biology/bioperl-db/bioperl-db-1.6.9-r1.ebuild61
-rw-r--r--sci-biology/bioperl-db/files/bioperl-db-1.6.9-db.patch57
2 files changed, 118 insertions, 0 deletions
diff --git a/sci-biology/bioperl-db/bioperl-db-1.6.9-r1.ebuild b/sci-biology/bioperl-db/bioperl-db-1.6.9-r1.ebuild
new file mode 100644
index 000000000000..fd3a4280fa03
--- /dev/null
+++ b/sci-biology/bioperl-db/bioperl-db-1.6.9-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+BIOPERL_RELEASE=1.6.9
+
+DIST_NAME=BioPerl-DB
+DIST_AUTHOR=CJFIELDS
+DIST_VERSION=1.006900
+inherit perl-module
+
+DESCRIPTION="Perl tools for bioinformatics - Perl API that accesses the BioSQL schema"
+HOMEPAGE="http://www.bioperl.org/"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DIST_TEST="do" # Parallelism probably bad
+
+RDEPEND="
+ >=sci-biology/bioperl-${PV}
+ dev-perl/DBD-mysql
+ dev-perl/DBI
+ sci-biology/biosql"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ dev-perl/Data-Stag
+ dev-perl/Sub-Uplevel
+ dev-perl/Test-Warn
+ dev-perl/Test-Exception
+ virtual/perl-Test-Simple
+ )
+"
+
+src_prepare() {
+ if use test; then
+ eapply "${FILESDIR}/${PN}-1.6.9-db.patch"
+ einfo "Using the following configuration details for test database:"
+ einfo " GENTOO_DB_TEST_HOST : ${GENTOO_DB_TEST_HOST:=localhost}"
+ einfo " GENTOO_DB_TEST_USER : ${GENTOO_DB_TEST_USER:=portage}"
+ einfo " GENTOO_DB_TEST_PORT : ${GENTOO_DB_TEST_PORT:=3306}"
+ einfo " GENTOO_DB_TEST_PASSWOWRD: ${GENTOO_DB_TEST_PASSWORD:=sekrit}"
+ einfo " GENTOO_DB_TEST_DATABASE : ${GENTOO_DB_TEST_DB:=biosql_test}"
+ einfo "Please ensure the relevant mysql database is configured and/or tweak"
+ einfo "environment variables to suit"
+ export GENTOO_DB_TEST_HOST GENTOO_DB_TEST_USER GENTOO_DB_TEST_PORT GENTOO_DB_TEST_PASSWORD GENTOO_DB_TEST_DB
+ fi
+ perl-module_src_prepare
+}
+src_install() {
+ mydoc="AUTHORS BUGS FAQ"
+ perl-module_src_install
+}
+src_test() {
+ einfo "Removing bundled test libraries t/lib"
+ rm -r "${S}/t/lib" || die "Cannot remove t/lib"
+ perl-module_src_test
+}
diff --git a/sci-biology/bioperl-db/files/bioperl-db-1.6.9-db.patch b/sci-biology/bioperl-db/files/bioperl-db-1.6.9-db.patch
new file mode 100644
index 000000000000..9a2d5e7bb0b6
--- /dev/null
+++ b/sci-biology/bioperl-db/files/bioperl-db-1.6.9-db.patch
@@ -0,0 +1,57 @@
+From a63725a70ab6d5cbf419d1896007b49609ac5cfa Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentfredric@gmail.com>
+Date: Tue, 18 Jul 2017 11:06:05 +1200
+Subject: [PATCH] Add env db test controls
+
+---
+ Build.PL | 10 +++++-----
+ t/DBTestHarness.pm | 11 ++++++-----
+ 2 files changed, 11 insertions(+), 10 deletions(-)
+
+diff --git a/Build.PL b/Build.PL
+index ecc402e..4d55f3a 100755
+--- a/Build.PL
++++ b/Build.PL
+@@ -97,11 +97,11 @@ sub biosql_conf {
+ or die "Error: could not write to config file '$config_file'\n";
+
+ my %config = (driver => $drivers[0],
+- host => '127.0.0.1',
+- user => 'root',
+- port => 3306,
+- password => '',
+- dbname => 'bioseqdb',
++ host => $ENV{GENTOO_DB_TEST_HOST},
++ user => $ENV{GENTOO_DB_TEST_USER},
++ port => $ENV{GENTOO_DB_TEST_PORT},
++ password => $ENV{GENTOO_DB_TEST_PASSWORD},
++ dbname => $ENV{GENTOO_DB_TEST_DB},
+ database => 'biosql',
+ schema_sql => '../biosql-schema/sql/biosqldb-mysql.sql');
+
+diff --git a/t/DBTestHarness.pm b/t/DBTestHarness.pm
+index b660429..bd0b3b7 100755
+--- a/t/DBTestHarness.pm
++++ b/t/DBTestHarness.pm
+@@ -47,12 +47,13 @@ my $counter=0;
+ # Default settings as a hash
+ my $dflt = {
+ 'driver' => 'mysql',
+- 'host' => 'localhost',
+- 'user' => 'root',
+- 'port' => undef,
+- 'password' => '',
++ 'host' => $ENV{GENTOO_DB_HOST},
++ 'user' => $ENV{GENTOO_DB_TEST_USER},
++ 'port' => ( defined $ENV{GENTOO_DB_TEST_PORT} and length $ENV{GENTOO_DB_TEST_PORT} ) ?
++ $ENV{GENTOO_DB_TEST_PORT} : undef,
++ 'password' => $ENV{GENTOO_DB_TEST_PASSWORD},
+ 'schema_sql' => ['../biosql-schema/sql/biosqldb-mysql.sql'],
+- 'database' => 'biosql',
++ 'database' => $ENV{GENTOO_DB_TEST_DB},
+ 'module' => 'Bio::DB::BioSQL::DBAdaptor'
+ };
+
+--
+2.13.1
+