summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-07 13:33:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-07 13:33:10 +0200
commitc1fa1f49fa817ba670ba07abeb8d090f8cbe78d9 (patch)
tree4f399e2e70b309e89097b0412aebc5a7807bfa56
parentdev-ros/compressed_image_transport: Bump to 1.9.5. (diff)
downloadgentoo-c1fa1f49fa817ba670ba07abeb8d090f8cbe78d9.tar.gz
gentoo-c1fa1f49fa817ba670ba07abeb8d090f8cbe78d9.tar.bz2
gentoo-c1fa1f49fa817ba670ba07abeb8d090f8cbe78d9.zip
dev-ros/theora_image_transport: Bump to 1.9.5.
Package-Manager: portage-2.3.1
-rw-r--r--dev-ros/theora_image_transport/Manifest1
-rw-r--r--dev-ros/theora_image_transport/theora_image_transport-1.9.5.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/theora_image_transport/Manifest b/dev-ros/theora_image_transport/Manifest
index 8a42cb322af4..1702843878f9 100644
--- a/dev-ros/theora_image_transport/Manifest
+++ b/dev-ros/theora_image_transport/Manifest
@@ -1,2 +1,3 @@
DIST image_transport_plugins-1.9.2.tar.gz 23734 SHA256 b610f50cdbab30abaa94980b22a444c5d898c571e3f57f0cf83ecde53877fdf0 SHA512 5ac7429cf61699f1827fdf15374aee5d951cd6aa77321f245bfe4e9771647e1bae5902646f30cb88019675e48732cd4f705eafe0931268684a449bef356bf972 WHIRLPOOL 7136449bf3fbc5f161a89c4fabac2d24fc4d4548186895e95a0aa7175ac196b5859d63da0cd59b418a570c10c767f19a8a9e7d0d408cd2c0517bff5407a512df
DIST image_transport_plugins-1.9.3.tar.gz 25291 SHA256 2d9b10f1e3c22145d58ba922dcafc72b149bb4561e641fff17eddf1510294271 SHA512 51ec14f5bef48e337146e303a4b87290c932d418621e3ae65d5a2f96247c4d0e9ac63df5c4e102f1532737448b272f07e2ce841030a33b8701febacad1698781 WHIRLPOOL c255da767e2dd668eef9499e26822b7eb3d6c144343287a34e3d396574776b29eff2ed90c384f99e1f9b53031a0f6d14a7311c0d2022bd4fc46af53c0a432025
+DIST image_transport_plugins-1.9.5.tar.gz 26268 SHA256 a3dcd3af617bcafba5b8dab5fbd89183fbaf31798ee4e4e63a91059fa110168c SHA512 54f459719a386f028578889f9b88b8b080f495d75899cee6c8bfb58204970fb2395b2a8da70034eb391ba62f4ce462cb89b97bcdc576a177444613076b5ed02c WHIRLPOOL 1796f983cd0a904b6cce58ecec4a59034ab23ca8ca7a3c2a9b3fa8764d60c1426754c3a6bdb9eaf8bcff1859768af76b3d4f3a3350ee6cd6af5cc89f90ae639a
diff --git a/dev-ros/theora_image_transport/theora_image_transport-1.9.5.ebuild b/dev-ros/theora_image_transport/theora_image_transport-1.9.5.ebuild
new file mode 100644
index 000000000000..6bc1622c2441
--- /dev/null
+++ b/dev-ros/theora_image_transport/theora_image_transport-1.9.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending an image stream encoded with the Theora codec"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_transport
+ media-libs/opencv
+ dev-ros/rosbag
+ dev-ros/pluginlib
+ media-libs/libogg
+ media-libs/libtheora[encode]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"