summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2018-07-11 23:34:26 +0200
committerJason A. Donenfeld <zx2c4@gentoo.org>2018-07-11 23:35:25 +0200
commitc20429ba0d7d8b0780575ff94f613ce646051843 (patch)
tree69ab636e6457f226e9a12ab5f4dab3c32a218542
parentdev-python/svgwrite: import new ebuild (diff)
downloadgentoo-c20429ba0d7d8b0780575ff94f613ce646051843.tar.gz
gentoo-c20429ba0d7d8b0780575ff94f613ce646051843.tar.bz2
gentoo-c20429ba0d7d8b0780575ff94f613ce646051843.zip
dev-python/pyte: version bump
Package-Manager: Portage-2.3.41, Repoman-2.3.9
-rw-r--r--dev-python/pyte/Manifest1
-rw-r--r--dev-python/pyte/pyte-0.8.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyte/Manifest b/dev-python/pyte/Manifest
index 564dc814037e..f9b730c9b521 100644
--- a/dev-python/pyte/Manifest
+++ b/dev-python/pyte/Manifest
@@ -1 +1,2 @@
DIST pyte-0.5.2.tar.gz 42719 BLAKE2B 00995c8427ade8a44dbc6dea4bea058431adb1409fbddc90b70ecd3cf4968632d66e4f21140ca5c071ea927208d40ed55606cf2d604f931970f99128c2b2dba8 SHA512 da903b31bb67e60bc8271c162f3429871d0def039cec5f63f07764fce1994236063876eb069a88783a4c7d8b0eac0646549c00f2a51ab8630287d852f05f4b0d
+DIST pyte-0.8.0.tar.gz 50415 BLAKE2B 8e707d8dd598d4b76b281de1481d238448f6ed07daa962647e61e7f5ad62da67a08112db7e21cb3522e5719514975a9b01ec06ff1cf2222590e02d9ff434369e SHA512 b1c23206f32c49ab509ac9bd4e042b043478cae35594c52c8389f5a5ba15cd0895315c42be5a0f2992b3aaa918ae282e43e88e72798a0b600307860f6df06465
diff --git a/dev-python/pyte/pyte-0.8.0.ebuild b/dev-python/pyte/pyte-0.8.0.ebuild
new file mode 100644
index 000000000000..7de14fd4a96d
--- /dev/null
+++ b/dev-python/pyte/pyte-0.8.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple VTXXX-compatible terminal emulator"
+HOMEPAGE="https://pypi.org/project/pyte/ https://github.com/selectel/pyte"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test --verbose
+}