summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-15 13:18:31 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-15 14:35:32 +0200
commitc3996ca4d671f5d0e6be00c827a309ac17bfde9a (patch)
treedcb4160dbe2c7e46ce26327d0ce3204974e613de
parentprofiles/desc: Include LLVM_TARGETS for all experimental targets (diff)
downloadgentoo-c3996ca4d671f5d0e6be00c827a309ac17bfde9a.tar.gz
gentoo-c3996ca4d671f5d0e6be00c827a309ac17bfde9a.tar.bz2
gentoo-c3996ca4d671f5d0e6be00c827a309ac17bfde9a.zip
sys-devel/llvm: Include all experimental targets in -9999
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 65914f3a340b..e6a3f23898b4 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -17,9 +17,12 @@ SRC_URI=""
EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
https://github.com/llvm-mirror/llvm.git"
+# Those are in lib/Targets, without explicit CMakeLists.txt mention
+ALL_LLVM_EXPERIMENTAL_TARGETS=( AVR Nios2 RISCV WebAssembly )
# Keep in sync with CMakeLists.txt
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
- NVPTX PowerPC Sparc SystemZ X86 XCore )
+ NVPTX PowerPC Sparc SystemZ X86 XCore
+ "${ALL_LLVM_EXPERIMENTAL_TARGETS[@]}" )
ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
# Additional licenses:
@@ -106,7 +109,10 @@ multilib_src_configure() {
-DLLVM_LIBDIR_SUFFIX=${libdir#lib}
-DBUILD_SHARED_LIBS=ON
- -DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
+ # cheap hack: LLVM combines both anyway, and the only difference
+ # is that the former list is explicitly verified at cmake time
+ -DLLVM_TARGETS_TO_BUILD=""
+ -DLLVM_EXPERIMENTAL_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
-DLLVM_BUILD_TESTS=$(usex test)
-DLLVM_ENABLE_FFI=$(usex libffi)