summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-04-16 09:48:06 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-04-16 09:48:06 +0200
commitc3c949743e9ea38e8a3a0785784c791e5ce6ea36 (patch)
tree1f0b237ea6799c8002a105e00b960777923ee9bf
parentsys-apps/file: Bump to version 5.33 (diff)
downloadgentoo-c3c949743e9ea38e8a3a0785784c791e5ce6ea36.tar.gz
gentoo-c3c949743e9ea38e8a3a0785784c791e5ce6ea36.tar.bz2
gentoo-c3c949743e9ea38e8a3a0785784c791e5ce6ea36.zip
sys-apps/file: Added "seccomp" USE flag to live ebuild.
Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--sys-apps/file/file-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/sys-apps/file/file-9999.ebuild b/sys-apps/file/file-9999.ebuild
index 3c9e2e50e4a6..5f51b583c407 100644
--- a/sys-apps/file/file-9999.ebuild
+++ b/sys-apps/file/file-9999.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="https://www.darwinsys.com/file/"
LICENSE="BSD-2"
SLOT="0"
-IUSE="python static-libs zlib"
+IUSE="python seccomp static-libs zlib"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
DEPEND="
@@ -31,7 +31,8 @@ DEPEND="
)
zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
RDEPEND="${DEPEND}
- python? ( !dev-python/python-magic )"
+ python? ( !dev-python/python-magic )
+ seccomp? ( sys-libs/libseccomp )"
src_prepare() {
default
@@ -46,6 +47,7 @@ src_prepare() {
multilib_src_configure() {
local myeconfargs=(
--enable-fsect-man5
+ $(use_enable seccomp libseccomp)
$(use_enable static-libs static)
$(use_enable zlib)
)
@@ -70,7 +72,7 @@ src_configure() {
LDFLAGS="${BUILD_LDFLAGS} -static" \
CC=${BUILD_CC} \
CXX=${BUILD_CXX} \
- econf --disable-shared
+ econf --disable-shared $(use_enable seccomp libseccomp)
fi
multilib-minimal_src_configure