summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2018-01-04 02:01:22 +1300
committerKent Fredric <kentnl@gentoo.org>2018-01-04 02:40:43 +1300
commitc4f82644e0cd24b17799458359a2962c30562260 (patch)
tree6db358b7c89a5cce5739418c6608bc1353be8f86
parentnet-vpn/tor: 0.3.1.9-r1 stable on ppc and ppc64, bug #642524 (diff)
downloadgentoo-c4f82644e0cd24b17799458359a2962c30562260.tar.gz
gentoo-c4f82644e0cd24b17799458359a2962c30562260.tar.bz2
gentoo-c4f82644e0cd24b17799458359a2962c30562260.zip
dev-perl/RRD-Simple: EAPI6 + tests
- EAPI6ify - Enable tests - Add USE=examples - Cleanup useless deps - Cleanup useless tests - Hard disable phone-home logic - Fix test failures without '.' in @INC - Patch tests for various changes in Perl Inf/Nan handling - Patch tests for various changes in RRDtool - Patch tests for parallel testing Package-Manager: Portage-2.3.18, Repoman-2.3.6
-rw-r--r--dev-perl/RRD-Simple/Manifest1
-rw-r--r--dev-perl/RRD-Simple/RRD-Simple-1.440.0-r2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/RRD-Simple/Manifest b/dev-perl/RRD-Simple/Manifest
index 88380a4cb11f..e3bcbc838035 100644
--- a/dev-perl/RRD-Simple/Manifest
+++ b/dev-perl/RRD-Simple/Manifest
@@ -1 +1,2 @@
+DIST RRD-Simple-1.44-patches-1.tar.xz 3740 BLAKE2B 164370f9a121efee897b17ae11e7f02f3ea92a69ca05851d8902b1a08ce629c096bd20ee9fe00758ddf7f309d9c1b4470c601e183fc7eb3b38950fb5339661d1 SHA512 d9f28d2da3ef2478c031c29eb80cd89a618391e0cbc7360cbf17281a971b7411761259682ff954af6b968e87d400e84dd125fff90adc248b92cd82903c364372
DIST RRD-Simple-1.44.tar.gz 303444 BLAKE2B 5f303a809839e389713743737405e6ad70038c4756546be00b6d2e7ea65bd0f887654c286b3ca30306fcde01e143d0b8f882c59b6a26376c30c557285e333dc8 SHA512 3cf11e08ec5ceb6ba81d9a12944a24fad0af644a8ba0f4c5e2dde4dd47fe6fc50db89be36c6a110a90209e5faac143cb5a063dddfb0a13f359a12511a51369a0
diff --git a/dev-perl/RRD-Simple/RRD-Simple-1.440.0-r2.ebuild b/dev-perl/RRD-Simple/RRD-Simple-1.440.0-r2.ebuild
new file mode 100644
index 000000000000..d8f2032c76e2
--- /dev/null
+++ b/dev-perl/RRD-Simple/RRD-Simple-1.440.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=NICOLAW
+DIST_VERSION=1.44
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Simple interface to create and store data in RRD files"
+SRC_URI+=" https://dev.gentoo.org/~kentnl/distfiles/${PN}-${DIST_VERSION}-patches-1.tar.xz"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ net-analyzer/rrdtool[perl]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ >=dev-perl/Test-Deep-0.93.0
+ )
+"
+PATCHES=( "${WORKDIR}/patches" )