summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-07-11 17:23:56 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-11 22:50:27 +0100
commitc55a34b09296fbca977c8012a23119855c006bea (patch)
treeb009e092956b64716eb4a3dd5c0008030afff756
parentsys-apps/sed: arm/m68k/s390/sh stable wrt bug #658388 (diff)
downloadgentoo-c55a34b09296fbca977c8012a23119855c006bea.tar.gz
gentoo-c55a34b09296fbca977c8012a23119855c006bea.tar.bz2
gentoo-c55a34b09296fbca977c8012a23119855c006bea.zip
app-admin/filebeat: bump to 5.6.10
Package-Manager: Portage-2.3.41, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9186
-rw-r--r--app-admin/filebeat/Manifest1
-rw-r--r--app-admin/filebeat/filebeat-5.6.10.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-admin/filebeat/Manifest b/app-admin/filebeat/Manifest
index 4908178eb0bb..a1775a26dfc1 100644
--- a/app-admin/filebeat/Manifest
+++ b/app-admin/filebeat/Manifest
@@ -1,4 +1,5 @@
DIST filebeat-5.5.2.tar.gz 18075191 BLAKE2B 9786cb8f3db003c86e4bc6d56fcac660b615e7e6ad82d0912f70c545f2af3caab605be739481355466438a1769c20b28db576d208af6b0af9620ce6408068215 SHA512 ad92b41a9ceaad6c6e6fc80d0adccd7fe03a7056d121484bcf35c6a46b2061a5ef6d32121dd12d59b51e7678769da5c405b1d549fa130631ae3f1989b78fba48
+DIST filebeat-5.6.10.tar.gz 18211551 BLAKE2B 5ed3a3d63fc758757cdb30e999a10bee15c8a66d7b4b603f755ebdfad712f4b48c2a1b79612dcfe3ce89d29458e672276b26f188ea3509ce4c349e2bff8b7508 SHA512 cca193e0c03ca5451c6158ab8f0669bf24aa0d34d46f2a4808d27f4ce1ff701dca6ea2db7a72275a635ea4e091571aa73e0b51228750b140a5340d27cba0e982
DIST filebeat-5.6.9.tar.gz 18209544 BLAKE2B 41891b984240af46fb3d9d7818203d7ef8fd5a089d7683877e3907061259442da4884976cfefcc90666699ebe3adb1ce6c87a026a50b07e218a5de6b642b9472 SHA512 2aa40afbd0f1c987aebf51d22aa03c87048766a4c7d41938ff27ffca841666d34cfbf08ae120d98d222a7d3ff447bbce9f1d65b434aef1c9d73c5019aa1558a1
DIST filebeat-6.1.1.tar.gz 17061456 BLAKE2B 5a5d23618f8140f3815c499305d99ae3dc4c4caa49535043040387922f924ee49a9494b5139f34a70d74173d97332b92909fc74e2f91a2fc0f288ef5d1493ade SHA512 54e85cfce58ba724f6b2892f115ac9ef5b1bb89ce8dc6f2a977e50ccfc07cf95fc578e46e0cadd96acd90c59f4b01446851b93c519afa094ff6dcdb7e716219a
DIST filebeat-6.2.4.tar.gz 19466271 BLAKE2B 417f1db19b7fdd9bcf66f2c3dcdf2aaa6be9ba5edff1c97a0b8f4a5d7953ef27bcbd860e097fb40e67b3b42b795b684dabb2995eee572243831f749a7184b625 SHA512 49293e28e4ca769a88f7b889ea888a559ae7e142698714e24bf5519d00c2030237cac591590aa284f17792906a6137333173716ddf5db4496217f8b5a054b19c
diff --git a/app-admin/filebeat/filebeat-5.6.10.ebuild b/app-admin/filebeat/filebeat-5.6.10.ebuild
new file mode 100644
index 000000000000..4537daa105ba
--- /dev/null
+++ b/app-admin/filebeat/filebeat-5.6.10.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
+HOMEPAGE="https://www.elastic.co/products/beats"
+SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+DEPEND=">=dev-lang/go-1.9.2"
+RDEPEND="!app-admin/filebeat-bin"
+
+S="${WORKDIR}/src/github.com/elastic/beats"
+
+src_unpack() {
+ mkdir -p "${S%/*}" || die
+ default
+ mv beats-${PV} "${S}" || die
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
+}
+
+src_install() {
+ keepdir /var/{lib,log}/${PN}
+
+ fperms 0750 /var/{lib,log}/${PN}
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+
+ docinto examples
+ dodoc ${PN}/{filebeat.yml,filebeat.full.yml}
+
+ insinto "/etc/${PN}"
+ doins ${PN}/{filebeat.template.json,filebeat.template-es2x.json,filebeat.template-es6x.json}
+
+ exeinto "/usr/share/${PN}"
+ doexe libbeat/scripts/migrate_beat_config_1_x_to_5_0.py
+
+ dobin filebeat/filebeat
+}
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ elog "Please read the migration guide at:"
+ elog "https://www.elastic.co/guide/en/beats/libbeat/5.0/upgrading.html"
+ elog ""
+ elog "The migration script:"
+ elog "${EROOT%/}/usr/share/filebeat/migrate_beat_config_1_x_to_5_0.py"
+ elog ""
+ fi
+
+ elog "Example configurations:"
+ elog "${EROOT%/}/usr/share/doc/${PF}/examples"
+}