summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2017-03-29 06:16:37 -0600
committerNicolas Bock <nicolasbock@gentoo.org>2017-05-20 06:17:17 -0600
commitc8af52cff98d4f0cfce581412ddd0df1b97ef889 (patch)
tree5c986eab3324dc7bded9aacea6fd2227e5524dce
parentmedia-video/cinelerra: Use upstream versionning now that we stopped using sna... (diff)
downloadgentoo-c8af52cff98d4f0cfce581412ddd0df1b97ef889.tar.gz
gentoo-c8af52cff98d4f0cfce581412ddd0df1b97ef889.tar.bz2
gentoo-c8af52cff98d4f0cfce581412ddd0df1b97ef889.zip
media-gfx/shotwell: Version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--media-gfx/shotwell/Manifest2
-rw-r--r--media-gfx/shotwell/metadata.xml4
-rw-r--r--media-gfx/shotwell/shotwell-0.26.0.ebuild62
-rw-r--r--media-gfx/shotwell/shotwell-0.26.1.ebuild62
4 files changed, 130 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index 47999ef67d7d..cf9969cce8be 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -1,2 +1,4 @@
DIST shotwell-0.24.6.tar.xz 5401300 SHA256 ecbbe8be422f0a228eb5a9d42f948f14d0b4ad4206dd503e3438be589595f947 SHA512 48f4595950700b3d193b7d73d4ff45abda1544de66c6252fcf98e94e58f284a0491b08d11045a96b8581f3370d759346739d3da1ef85311717908c33ab1c25c6 WHIRLPOOL a3f1127eb24ede554ccc1c08402aceb008728dff8ada56831f51729ae324f8c0bc425e6b04d210bd830ed3ce337a6805aef59f9d9bb9d7354127942c6794d141
DIST shotwell-0.25.0.1.tar.xz 5398404 SHA256 e69c96b3ee650aed8f83dfe099e01d85f83ab19f56995a90d48681fdf26400a6 SHA512 6a071b0b7d84bf78727b84e0ba707d6d7f5408a0b942962771b24a79381c102c58c06b4895eba69527215103279946f4e33b14410a1ce6dd58d3dba3870975df WHIRLPOOL 7ab54b4b28d1db631e9a359ab803a6a4447a6642b44daf59ed4970e49ee40cf23208f7bf0754eaccfa6ed10ad4b3f02110769dad4f32ff13b1173f636c4d6b62
+DIST shotwell-0.26.0.tar.xz 5583732 SHA256 305df4d49971eb10f2a04b577ebbd9448202f13d51aa02608e433b8613df1024 SHA512 fd25bd24593360ae3d1f4cf5960d8ff2023f965e5d3bb70b80801a4c23103b570ae856e243c08e486b428c746b6f82bf3c3982a21689e72be7d2dfc3aec16ccf WHIRLPOOL df449129ee5d8b0a4ec5826b2a106e228fe3f9daca864038e02524b04d568d336b3c4acfa76ec57a510acaa5ccf839a3f0d2f2c35e5602e05a01690a8ce1fac5
+DIST shotwell-0.26.1.tar.xz 5593092 SHA256 0a60cc8a132fd962ed8c73f82b3f8ad7cbf1014bb93e89eee83e5c9a8c0b5375 SHA512 82cc95b3b173fbcd3cbb4f5d42f24fcb951b34039af1fdbd062d3f334aa2c305640833a7279cb79e02f0334da8b3a85cd8aadff45a80161ab0d2fbcd14278cd1 WHIRLPOOL 8cbf50548eec1bb7b53d6d2df75dacc3b464b7790a0bbcceed799c948e5e3f777ad6f7f547ae2ef74d42466c06db94368ebf8fa0125908cb57ca200c49456119
diff --git a/media-gfx/shotwell/metadata.xml b/media-gfx/shotwell/metadata.xml
index a2b09843cfc9..cdcc03cf8c1d 100644
--- a/media-gfx/shotwell/metadata.xml
+++ b/media-gfx/shotwell/metadata.xml
@@ -5,6 +5,10 @@
<email>hwoarang@gentoo.org</email>
<name>Markos Chandras</name>
</maintainer>
+ <maintainer type="person">
+ <email>nicolasbock@gentoo.org</email>
+ <name>Nicolas Bock</name>
+ </maintainer>
<maintainer type="project">
<email>graphics@gentoo.org</email>
<name>Gentoo Graphics Project</name>
diff --git a/media-gfx/shotwell/shotwell-0.26.0.ebuild b/media-gfx/shotwell/shotwell-0.26.0.ebuild
new file mode 100644
index 000000000000..5d5a82fa7382
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.26.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome2 multilib toolchain-funcs vala versionator
+
+MY_PV=$(get_version_component_range 1-2)
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-crypt/gcr-3[gtk]
+ >=dev-db/sqlite-3.5.9:3
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libgee-0.8.5:0.8
+ >=dev-libs/libxml2-2.6.32:2
+ gnome-base/dconf
+ >=media-libs/gexiv2-0.10.4
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gstreamer:1.0
+ media-libs/lcms:2
+ >=media-libs/libexif-0.6.16:=
+ >=media-libs/libgphoto2-2.5:=
+ >=media-libs/libraw-0.13.2:=
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ >=net-libs/libsoup-2.42.0:2.4
+ net-libs/webkit-gtk:4
+ virtual/libgudev:=[introspection]
+ >=x11-libs/gtk+-3.14.0:3[X]
+
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.7
+ >=sys-devel/m4-1.4.13
+ virtual/pkgconfig
+"
+
+# This probably comes from libraries that
+# shotwell-video-thumbnailer links to.
+# Nothing we can do at the moment. #435048
+QA_FLAGS_IGNORED="/usr/libexec/${PN}/${PN}-video-thumbnailer"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}
diff --git a/media-gfx/shotwell/shotwell-0.26.1.ebuild b/media-gfx/shotwell/shotwell-0.26.1.ebuild
new file mode 100644
index 000000000000..5d5a82fa7382
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.26.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.28"
+
+inherit gnome2 multilib toolchain-funcs vala versionator
+
+MY_PV=$(get_version_component_range 1-2)
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=app-crypt/gcr-3[gtk]
+ >=dev-db/sqlite-3.5.9:3
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libgee-0.8.5:0.8
+ >=dev-libs/libxml2-2.6.32:2
+ gnome-base/dconf
+ >=media-libs/gexiv2-0.10.4
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gstreamer:1.0
+ media-libs/lcms:2
+ >=media-libs/libexif-0.6.16:=
+ >=media-libs/libgphoto2-2.5:=
+ >=media-libs/libraw-0.13.2:=
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ >=net-libs/libsoup-2.42.0:2.4
+ net-libs/webkit-gtk:4
+ virtual/libgudev:=[introspection]
+ >=x11-libs/gtk+-3.14.0:3[X]
+
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.7
+ >=sys-devel/m4-1.4.13
+ virtual/pkgconfig
+"
+
+# This probably comes from libraries that
+# shotwell-video-thumbnailer links to.
+# Nothing we can do at the moment. #435048
+QA_FLAGS_IGNORED="/usr/libexec/${PN}/${PN}-video-thumbnailer"
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure --disable-static
+}