summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhkgz <hkgz@localhost.localdomain>2016-03-03 13:14:47 +0000
committerhkgz <hkgz@localhost.localdomain>2016-03-03 15:14:47 +0200
commitc9a513f5fca425af368156b1272145ce6a9a6980 (patch)
treeac54c700253decbfa7b3046fab602c8822c4e195
parentdev-lang/yap: avoid compile-time MPI-YAP interface redefinitions (diff)
downloadgentoo-c9a513f5fca425af368156b1272145ce6a9a6980.tar.gz
gentoo-c9a513f5fca425af368156b1272145ce6a9a6980.tar.bz2
gentoo-c9a513f5fca425af368156b1272145ce6a9a6980.zip
media-video/mplayer: added vcd and yuv4mpeg USE flags, bug #574806
-rw-r--r--media-video/mplayer/metadata.xml2
-rw-r--r--media-video/mplayer/mplayer-1.2.1.ebuild8
-rw-r--r--media-video/mplayer/mplayer-1.3.0.ebuild8
-rw-r--r--media-video/mplayer/mplayer-9999.ebuild8
4 files changed, 14 insertions, 12 deletions
diff --git a/media-video/mplayer/metadata.xml b/media-video/mplayer/metadata.xml
index c6d7f2f154ed..0bde38230254 100644
--- a/media-video/mplayer/metadata.xml
+++ b/media-video/mplayer/metadata.xml
@@ -32,9 +32,11 @@
<flag name="toolame">Enable toolame MPEG-2 encoding</flag>
<flag name="tremor">Enable internal support for Vorbis</flag>
<flag name="twolame">Enable twolame MPEG-2 encoding</flag>
+ <flag name="vcd">Enables VCD support</flag>
<flag name="vidix">Support for vidix video output</flag>
<flag name="xanim">Enables support for xanim based codecs</flag>
<flag name="xvmc">Enables X-Video Motion Compensation support</flag>
+ <flag name="yuv4mpeg">Enables yuv4mpeg video output</flag>
<flag name="zoran">Enables ZR360[56]7/ZR36060 video output</flag>
</use>
</pkgmetadata>
diff --git a/media-video/mplayer/mplayer-1.2.1.ebuild b/media-video/mplayer/mplayer-1.2.1.ebuild
index e524a124d3e7..c2a89edb32fa 100644
--- a/media-video/mplayer/mplayer-1.2.1.ebuild
+++ b/media-video/mplayer/mplayer-1.2.1.ebuild
@@ -17,8 +17,8 @@ ftp gif ggi gsm +iconv ipv6 jack joystick jpeg jpeg2k kernel_linux ladspa
+libass libcaca libmpeg2 lirc live lzo mad md5sum +cpu_flags_x86_mmx cpu_flags_x86_mmxext mng mp3 nas
+network nut openal opengl +osdmenu oss png pnm pulseaudio pvr
radio rar rtc rtmp samba selinux +shm sdl speex cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_ssse3
-tga theora tremor +truetype toolame twolame +unicode v4l vdpau vidix
-vorbis +X x264 xanim xinerama +xscreensaver +xv xvid xvmc zoran"
+tga theora tremor +truetype toolame twolame +unicode v4l vcd vdpau vidix
+vorbis +X x264 xanim xinerama +xscreensaver +xv xvid xvmc yuv4mpeg zoran"
VIDEO_CARDS="s3virge mga tdfx"
for x in ${VIDEO_CARDS}; do
@@ -299,7 +299,7 @@ src_configure() {
$(use_enable network networking)
$(use_enable joystick)
"
- uses="bl bluray enca ftp rtc" # nemesi <- not working with in-tree ebuild
+ uses="bl bluray enca ftp rtc vcd" # nemesi <- not working with in-tree ebuild
myconf+=" --disable-nemesi" # nemesi automagic disable
for i in ${uses}; do
use ${i} || myconf+=" --disable-${i}"
@@ -422,7 +422,7 @@ src_configure() {
################
# Video Output #
################
- uses="directfb md5sum sdl"
+ uses="directfb md5sum sdl yuv4mpeg"
for i in ${uses}; do
use ${i} || myconf+=" --disable-${i}"
done
diff --git a/media-video/mplayer/mplayer-1.3.0.ebuild b/media-video/mplayer/mplayer-1.3.0.ebuild
index 8a5b4011be4d..c5eb0851e7a4 100644
--- a/media-video/mplayer/mplayer-1.3.0.ebuild
+++ b/media-video/mplayer/mplayer-1.3.0.ebuild
@@ -17,8 +17,8 @@ ftp gif ggi gsm +iconv ipv6 jack joystick jpeg jpeg2k kernel_linux ladspa
+libass libcaca libmpeg2 lirc live lzo mad md5sum +cpu_flags_x86_mmx cpu_flags_x86_mmxext mng mp3 nas
+network nut openal opengl +osdmenu oss png pnm pulseaudio pvr
radio rar rtc rtmp samba selinux +shm sdl speex cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_ssse3
-tga theora tremor +truetype toolame twolame +unicode v4l vdpau vidix
-vorbis +X x264 xanim xinerama +xscreensaver +xv xvid xvmc zoran"
+tga theora tremor +truetype toolame twolame +unicode v4l vcd vdpau vidix
+vorbis +X x264 xanim xinerama +xscreensaver +xv xvid xvmc yuv4mpeg zoran"
VIDEO_CARDS="s3virge mga tdfx"
for x in ${VIDEO_CARDS}; do
@@ -293,7 +293,7 @@ src_configure() {
$(use_enable network networking)
$(use_enable joystick)
"
- uses="bl bluray enca ftp rtc" # nemesi <- not working with in-tree ebuild
+ uses="bl bluray enca ftp rtc vcd" # nemesi <- not working with in-tree ebuild
myconf+=" --disable-nemesi" # nemesi automagic disable
for i in ${uses}; do
use ${i} || myconf+=" --disable-${i}"
@@ -416,7 +416,7 @@ src_configure() {
################
# Video Output #
################
- uses="directfb md5sum sdl"
+ uses="directfb md5sum sdl yuv4mpeg"
for i in ${uses}; do
use ${i} || myconf+=" --disable-${i}"
done
diff --git a/media-video/mplayer/mplayer-9999.ebuild b/media-video/mplayer/mplayer-9999.ebuild
index 586f70ab309c..1e3a45bfd0dd 100644
--- a/media-video/mplayer/mplayer-9999.ebuild
+++ b/media-video/mplayer/mplayer-9999.ebuild
@@ -17,8 +17,8 @@ ftp gif ggi gsm +iconv ipv6 jack joystick jpeg jpeg2k kernel_linux ladspa
+libass libcaca libmpeg2 lirc live lzo mad md5sum +cpu_flags_x86_mmx cpu_flags_x86_mmxext mng mp3 nas
+network nut openal opengl +osdmenu oss png pnm pulseaudio pvr
radio rar rtc rtmp samba selinux +shm sdl speex cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_ssse3
-tga theora tremor +truetype toolame twolame +unicode v4l vdpau vidix
-vorbis +X x264 xanim xinerama +xscreensaver +xv xvid xvmc zoran"
+tga theora tremor +truetype toolame twolame +unicode v4l vcd vdpau vidix
+vorbis +X x264 xanim xinerama +xscreensaver +xv xvid xvmc yuv4mpeg zoran"
VIDEO_CARDS="s3virge mga tdfx"
for x in ${VIDEO_CARDS}; do
@@ -293,7 +293,7 @@ src_configure() {
$(use_enable network networking)
$(use_enable joystick)
"
- uses="bl bluray enca ftp rtc" # nemesi <- not working with in-tree ebuild
+ uses="bl bluray enca ftp rtc vcd" # nemesi <- not working with in-tree ebuild
myconf+=" --disable-nemesi" # nemesi automagic disable
for i in ${uses}; do
use ${i} || myconf+=" --disable-${i}"
@@ -416,7 +416,7 @@ src_configure() {
################
# Video Output #
################
- uses="directfb md5sum sdl"
+ uses="directfb md5sum sdl yuv4mpeg"
for i in ${uses}; do
use ${i} || myconf+=" --disable-${i}"
done