summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-24 01:07:20 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-24 01:08:36 +0100
commitcc751d0130e7b00df9ffb6f6356c91061150c8ca (patch)
treed9c077bd8da5c9b4af4b1ce5837baa333f97c704
parentmedia-libs/libmms: EAPI-7++, autotools-multilib-- (diff)
downloadgentoo-cc751d0130e7b00df9ffb6f6356c91061150c8ca.tar.gz
gentoo-cc751d0130e7b00df9ffb6f6356c91061150c8ca.tar.bz2
gentoo-cc751d0130e7b00df9ffb6f6356c91061150c8ca.zip
media-sound/dcaenc: EAPI-7 bump, fix IUSE=alsa automagic
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-sound/dcaenc/dcaenc-2-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-sound/dcaenc/dcaenc-2-r2.ebuild b/media-sound/dcaenc/dcaenc-2-r2.ebuild
new file mode 100644
index 000000000000..03cb57ac54c9
--- /dev/null
+++ b/media-sound/dcaenc/dcaenc-2-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="DTS Coherent Acoustics audio encoder"
+HOMEPAGE="https://aepatrakov.narod.ru/index/0-2
+https://gitlab.com/patrakov/dcaenc"
+SRC_URI="https://aepatrakov.narod.ru/olderfiles/1/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa"
+
+RDEPEND="alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-static
+ $(use_enable alsa)
+ )
+ ECONF_SOURCE=${S} econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name "*.la" -delete || die
+}