summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-16 13:07:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-16 13:08:52 +0200
commitcdba8f00dae74bb2667a46cd587da973d7bbb802 (patch)
tree230f267d72e9a025c3e6e7f4e3d782e3faf2ce22
parentdev-python/pyinotify: enable py3.10 (diff)
downloadgentoo-cdba8f00dae74bb2667a46cd587da973d7bbb802.tar.gz
gentoo-cdba8f00dae74bb2667a46cd587da973d7bbb802.tar.bz2
gentoo-cdba8f00dae74bb2667a46cd587da973d7bbb802.zip
dev-python/python-podman: Ignore integration tests entirely
Ignore integration tests entirely rather than deselecting them, in order to avoid additional test dependencies. Closes: https://bugs.gentoo.org/802447 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-podman/python-podman-3.2.0.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-python/python-podman/python-podman-3.2.0.ebuild b/dev-python/python-podman/python-podman-3.2.0.ebuild
index 716d1e8876bd..58c9d7fd927b 100644
--- a/dev-python/python-podman/python-podman-3.2.0.ebuild
+++ b/dev-python/python-podman/python-podman-3.2.0.ebuild
@@ -34,13 +34,11 @@ distutils_enable_tests pytest
python_test() {
local deselect=(
- # integration tests require a workable podman server,
- # and it doesn't seem to work in ebuild env
- podman/tests/integration
-
# TODO
podman/tests/unit/test_volumesmanager.py::VolumesManagerTestCase::test_get_404
)
- epytest ${deselect[@]/#/--deselect }
+ # integration tests require a workable podman server,
+ # and it doesn't seem to work in ebuild env
+ epytest podman/tests/unit ${deselect[@]/#/--deselect }
}