summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Eden <yamakuzure@gmx.net>2016-11-12 16:23:42 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-12 16:39:05 +0100
commitcdcd619623d85b22cf53304952ab00cf880626a6 (patch)
treea066f59f6f64b335d81ae5eac7307e450227bd0e
parentsci-misc/boinc: New ebuild for boinc-7.4.52 (diff)
downloadgentoo-cdcd619623d85b22cf53304952ab00cf880626a6.tar.gz
gentoo-cdcd619623d85b22cf53304952ab00cf880626a6.tar.bz2
gentoo-cdcd619623d85b22cf53304952ab00cf880626a6.zip
sci-misc/boinc: Fix linker errors with wxGTK for boinc-7.6.33
Gentoo-Bug: 587462 >=x11-libs/wxGTK-3.0.2.0-r3 has webview removed. This patch adds webview to the CLIENTGUILIBS. Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2768 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sci-misc/boinc/boinc-7.6.33-r1.ebuild157
-rw-r--r--sci-misc/boinc/files/fix_webview.patch11
2 files changed, 168 insertions, 0 deletions
diff --git a/sci-misc/boinc/boinc-7.6.33-r1.ebuild b/sci-misc/boinc/boinc-7.6.33-r1.ebuild
new file mode 100644
index 000000000000..7d8033ce2b1b
--- /dev/null
+++ b/sci-misc/boinc/boinc-7.6.33-r1.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER=3.0
+
+inherit autotools flag-o-matic linux-info systemd user versionator wxwidgets
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="The Berkeley Open Infrastructure for Network Computing"
+HOMEPAGE="http://boinc.ssl.berkeley.edu/"
+SRC_URI="https://github.com/BOINC/boinc/archive/client_release/${MY_PV}/${PV}.tar.gz -> ${P}.tar.gz"
+RESTRICT="mirror"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X cuda curl_ssl_libressl +curl_ssl_openssl static-libs"
+
+REQUIRED_USE="^^ ( curl_ssl_libressl curl_ssl_openssl ) "
+
+# libcurl must not be using an ssl backend boinc does not support.
+# If the libcurl ssl backend changes, boinc should be recompiled.
+RDEPEND="
+ !sci-misc/boinc-bin
+ !app-admin/quickswitch
+ >=app-misc/ca-certificates-20080809
+ net-misc/curl[-curl_ssl_gnutls(-),curl_ssl_libressl(-)=,-curl_ssl_nss(-),curl_ssl_openssl(-)=,-curl_ssl_axtls(-),-curl_ssl_cyassl(-),-curl_ssl_polarssl(-)]
+ sys-apps/util-linux
+ sys-libs/zlib
+ cuda? (
+ >=dev-util/nvidia-cuda-toolkit-2.1
+ >=x11-drivers/nvidia-drivers-180.22
+ )
+ X? (
+ dev-db/sqlite:3
+ media-libs/freeglut
+ sys-libs/glibc:2.2
+ virtual/jpeg:0=
+ x11-libs/gtk+:2
+ >=x11-libs/libnotify-0.7
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl,webkit]
+ )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ app-text/docbook-xml-dtd:4.4
+ app-text/docbook2X
+"
+
+S="${WORKDIR}/${PN}-client_release-${MY_PV}-${PV}"
+
+pkg_setup() {
+ # Bug 578750
+ if use kernel_linux; then
+ linux-info_pkg_setup
+ if ! linux_config_exists; then
+ ewarn "Can't check the linux kernel configuration."
+ ewarn "You might be missing vsyscall support."
+ elif kernel_is -ge 4 4 \
+ && linux_chkconfig_present LEGACY_VSYSCALL_NONE; then
+ ewarn "You do not have vsyscall emulation enabled."
+ ewarn "This will prevent some boinc projects from running."
+ ewarn "Please enable vsyscall emulation:"
+ ewarn " CONFIG_LEGACY_VSYSCALL_EMULATE=y"
+ ewarn "in /usr/src/linux/.config, to be found at"
+ ewarn " Processor type and features --->"
+ ewarn " vsyscall table for legacy applications (None) --->"
+ ewarn " (X) Emulate"
+ ewarn "Alternatively, you can enable CONFIG_LEGACY_VSYSCALL_NATIVE."
+ ewarn "However, this has security implications and is not recommended."
+ fi
+ fi
+}
+
+src_prepare() {
+ # prevent bad changes in compile flags, bug 286701
+ sed -i -e "s:BOINC_SET_COMPILE_FLAGS::" configure.ac || die "sed failed"
+
+ # >=x11-libs/wxGTK-3.0.2.0-r3 has webview removed, bug 587462
+ epatch "${FILESDIR}"/fix_webview.patch
+
+ eautoreconf
+
+ use X && need-wxwidgets unicode
+}
+
+src_configure() {
+ econf --disable-server \
+ --enable-client \
+ --enable-dynamic-client-linkage \
+ --disable-static \
+ --enable-unicode \
+ --with-ssl \
+ $(use_with X x) \
+ $(use_enable X manager) \
+ $(usex X --with-wx-config="${WX_CONFIG}" --without-wxdir)
+}
+
+src_install() {
+ default
+
+ keepdir /var/lib/${PN}
+
+ if use X; then
+ newicon "${S}"/packages/generic/sea/${PN}mgr.48x48.png ${PN}.png
+ make_desktop_entry boincmgr "${PN}" "${PN}" "Math;Science" "Path=/var/lib/${PN}"
+ fi
+
+ # cleanup cruft
+ rm -rf "${ED}"/etc || die "rm failed"
+
+ newinitd "${FILESDIR}"/${PN}.init ${PN}
+ newconfd "${FILESDIR}"/${PN}.conf ${PN}
+ systemd_dounit "${FILESDIR}"/${PN}.service
+}
+
+pkg_preinst() {
+ enewgroup ${PN}
+ # note this works only for first install so we have to
+ # elog user about the need of being in video group
+ local groups="${PN}"
+ if use cuda; then
+ group+=",video"
+ fi
+ enewuser ${PN} -1 -1 /var/lib/${PN} "${groups}"
+}
+
+pkg_postinst() {
+ echo
+ elog "You are using the source compiled version of boinc."
+ use X && elog "The graphical manager can be found at /usr/bin/boincmgr"
+ elog
+ elog "You need to attach to a project to do anything useful with boinc."
+ elog "You can do this by running /etc/init.d/boinc attach"
+ elog "The howto for configuration is located at:"
+ elog "http://boinc.berkeley.edu/wiki/Anonymous_platform"
+ elog
+ # Add warning about the new password for the client, bug 121896.
+ if use X; then
+ elog "If you need to use the graphical manager the password is in:"
+ elog "/var/lib/boinc/gui_rpc_auth.cfg"
+ elog "Where /var/lib/ is default RUNTIMEDIR, that can be changed in:"
+ elog "/etc/conf.d/boinc"
+ elog "You should change this password to something more memorable (can be even blank)."
+ elog "Remember to launch init script before using manager. Or changing the password."
+ elog
+ fi
+ if use cuda; then
+ elog "To be able to use CUDA you should add boinc user to video group."
+ elog "Run as root:"
+ elog "gpasswd -a boinc video"
+ fi
+}
diff --git a/sci-misc/boinc/files/fix_webview.patch b/sci-misc/boinc/files/fix_webview.patch
new file mode 100644
index 000000000000..6c141eb7c829
--- /dev/null
+++ b/sci-misc/boinc/files/fix_webview.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac 2016-07-06 11:16:41.000000000 +0200
++++ b/configure.ac 2016-07-06 11:45:51.088155620 +0200
+@@ -1250,7 +1250,7 @@
+ CLIENTGUIFLAGS="${CLIENTGUIFLAGS} -DNDEBUG"
+ fi
+
+-CLIENTGUILIBS="${WX_LIBS} ${SQLITE3_LIBS}"
++CLIENTGUILIBS="${WX_LIBS} $($WX_CONFIG_WITH_ARGS --libs webview) ${SQLITE3_LIBS}"
+
+ if test "${enable_client_release}" = "yes" ; then
+ if test "x${WX_LIBS_STATIC}" = "x" ; then