summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-07-24 20:06:07 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-08-02 22:21:31 +0200
commitceb61b5e41f5917e79d8cfc940e619e107afdfd7 (patch)
treeef2133d2d94fe9c88150db9bbc827454f68db4c7
parentx11-plugins/wmsystemtray: add EAPI7 ebuild (diff)
downloadgentoo-ceb61b5e41f5917e79d8cfc940e619e107afdfd7.tar.gz
gentoo-ceb61b5e41f5917e79d8cfc940e619e107afdfd7.tar.bz2
gentoo-ceb61b5e41f5917e79d8cfc940e619e107afdfd7.zip
x11-plugins/wmsystray: EAPI7, improve ebuild
-rw-r--r--x11-plugins/wmsystray/files/wmsystray-0.1.1-gcc-3.4.patch4
-rw-r--r--x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild46
2 files changed, 48 insertions, 2 deletions
diff --git a/x11-plugins/wmsystray/files/wmsystray-0.1.1-gcc-3.4.patch b/x11-plugins/wmsystray/files/wmsystray-0.1.1-gcc-3.4.patch
index 538a7ce0aa6a..74f11a5ce73c 100644
--- a/x11-plugins/wmsystray/files/wmsystray-0.1.1-gcc-3.4.patch
+++ b/x11-plugins/wmsystray/files/wmsystray-0.1.1-gcc-3.4.patch
@@ -1,5 +1,5 @@
---- wmsystray/ui.c.orig 2004-08-25 11:14:51.265675224 +0000
-+++ wmsystray/ui.c 2004-08-25 11:09:56.676459592 +0000
+--- a/wmsystray/ui.c 2004-08-25 11:14:51.265675224 +0000
++++ b/wmsystray/ui.c 2004-08-25 11:09:56.676459592 +0000
@@ -28,6 +28,7 @@
int width, height, pos_x, pos_y;
Pixmap bg_pixmap;
diff --git a/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild b/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..d48af6dcae9a
--- /dev/null
+++ b/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop
+
+DESCRIPTION="Window Maker dock app that provides a system tray for GNOME/KDE applications"
+HOMEPAGE="https://github.com/bbidulock/wmsystray"
+SRC_URI="https://github.com/bbidulock/wmsystray/releases/download/${PV}/${P}.tar.bz2"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+# Let's honour Gentoo CFLAGS and use correct install program
+# Fix for #61704, cannot compile with gcc 3.4.1:
+# it's a trivial change and does not affect other compilers...
+PATCHES=( "${FILESDIR}/${P}-Makefile.patch"
+ "${FILESDIR}/${P}-gcc-3.4.patch" )
+
+DOCS=( README HACKING AUTHORS )
+
+src_prepare() {
+ default
+ # Fix parallel compilation
+ sed -ie "s/make EXTRACFLAGS/make \${MAKEOPTS} EXTRACFLAGS/" Makefile || die
+
+ # Honour Gentoo LDFLAGS, see bug #336296
+ sed -ie "s/-o wmsystray/${LDFLAGS} -o wmsystray/" wmsystray/Makefile || die
+}
+
+src_compile() {
+ emake EXTRACFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}/${PN}
+ doman doc/${PN}.1
+ domenu "${FILESDIR}/${PN}.desktop"
+ einstalldocs
+}