summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-04 01:25:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-04 01:26:26 +0200
commitcec84b5e29ebf6738ac3f7febdcf2bde6aa61f59 (patch)
tree6c6451fa29c886408d1380de1d07a1250c8fd893
parentmedia-sound/tomahawk: Drop USE hatchet (diff)
downloadgentoo-cec84b5e29ebf6738ac3f7febdcf2bde6aa61f59.tar.gz
gentoo-cec84b5e29ebf6738ac3f7febdcf2bde6aa61f59.tar.bz2
gentoo-cec84b5e29ebf6738ac3f7febdcf2bde6aa61f59.zip
media-sound/bristol: Fix build, fix QA warning, EAPI-7 bump
Closes: https://bugs.gentoo.org/590510 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
-rw-r--r--media-sound/bristol/bristol-0.60.11-r1.ebuild57
-rw-r--r--media-sound/bristol/files/bristol-0.60.11-dontcompress.patch12
-rw-r--r--media-sound/bristol/files/bristol-0.60.11-rm_alsa-iatomic.h.patch26
3 files changed, 95 insertions, 0 deletions
diff --git a/media-sound/bristol/bristol-0.60.11-r1.ebuild b/media-sound/bristol/bristol-0.60.11-r1.ebuild
new file mode 100644
index 000000000000..0cb211ac2850
--- /dev/null
+++ b/media-sound/bristol/bristol-0.60.11-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Synthesizer keyboard emulation package: Moog, Hammond and others"
+HOMEPAGE="https://sourceforge.net/projects/bristol"
+SRC_URI="mirror://sourceforge/bristol/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa oss static-libs"
+# osc : configure option but no code it seems...
+# jack: fails to build if disabled
+# pulseaudio: not fully supported
+
+RDEPEND="
+ >=media-sound/jack-audio-connection-kit-0.109.2
+ x11-libs/libX11
+ alsa? ( >=media-libs/alsa-lib-1.0.0 )
+"
+# osc? ( >=media-libs/liblo-0.22 )
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+DOCS=( AUTHORS ChangeLog HOWTO NEWS README )
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${P}-implicit-dec.patch
+ "${FILESDIR}"/${P}-dontcompress.patch
+ "${FILESDIR}"/${P}-rm_alsa-iatomic.h.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-version-check \
+ $(use_enable alsa) \
+ $(use_enable oss) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/media-sound/bristol/files/bristol-0.60.11-dontcompress.patch b/media-sound/bristol/files/bristol-0.60.11-dontcompress.patch
new file mode 100644
index 000000000000..0b7cedc9e29d
--- /dev/null
+++ b/media-sound/bristol/files/bristol-0.60.11-dontcompress.patch
@@ -0,0 +1,12 @@
+--- a/Makefile.am 2012-01-12 18:23:23.000000000 +0100
++++ b/Makefile.am 2018-10-04 01:22:03.656483227 +0200
+@@ -9,9 +9,6 @@
+ $(INSTALL) -d $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 0644 $(srcdir)/bristol.1 $(DESTDIR)$(mandir)/man1/
+ $(INSTALL) -m 0644 $(srcdir)/bristoljackstats.1 $(DESTDIR)$(mandir)/man1/
+- gzip -9fn $(DESTDIR)$(mandir)/man1/bristol.1
+- gzip -9fn $(DESTDIR)$(mandir)/man1/bristoljackstats.1
+- cd $(DESTDIR)$(mandir)/man1 && ln -sf bristol.1.gz brighton.1.gz && ln -sf bristol.1.gz startBristol.1.gz
+
+ installdb:
+ mkdir -p -m 0755 $(DESTDIR)$(bristoldir)
diff --git a/media-sound/bristol/files/bristol-0.60.11-rm_alsa-iatomic.h.patch b/media-sound/bristol/files/bristol-0.60.11-rm_alsa-iatomic.h.patch
new file mode 100644
index 000000000000..9d11b4f7d99b
--- /dev/null
+++ b/media-sound/bristol/files/bristol-0.60.11-rm_alsa-iatomic.h.patch
@@ -0,0 +1,26 @@
+Description: Stop using alsa/iatomic.h
+ Technically this is an API breakage in libasound 1.1.2,
+ but it makes sense to me that this header was removed
+ by ALSA upstream.
+ .
+ bristol was the only user in Debian, and even here the
+ code that once used it was already commented out.
+Author: Adrian Bunk <bunk@stusta.de>
+Reviewed-by: James Cowgill <jcowgill@debian.org>
+ Herbert Parentes Fortes Neto <hpfn@debian.org>
+Bug-Debian: https://bugs.debian.org/834180
+Forwarded: no
+Index: bristol-0.60.11/libbristolaudio/audioEngineJack.c
+===================================================================
+--- a/libbristolaudio/audioEngineJack.c
++++ b/libbristolaudio/audioEngineJack.c
+@@ -38,9 +38,6 @@
+ #include <string.h>
+
+ #ifdef _BRISTOL_JACK
+-#if (BRISTOL_HAS_ALSA == 1)
+-#include <alsa/iatomic.h>
+-#endif
+
+ /*
+ * Drop this atomic stuff, it comes from the ALSA library and it not present on