summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-04-25 02:50:48 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-04-25 02:50:48 +0200
commitcf1844adca2f5a036e72fcbc6da710cac78f53ab (patch)
tree67c8b884ee2ec6a0fa1b696df1c1d0e6e960a3cf
parentdev-db/etcd: Version bump to 3.3.4 (diff)
downloadgentoo-cf1844adca2f5a036e72fcbc6da710cac78f53ab.tar.gz
gentoo-cf1844adca2f5a036e72fcbc6da710cac78f53ab.tar.bz2
gentoo-cf1844adca2f5a036e72fcbc6da710cac78f53ab.zip
sys-process/tini: Version bump to 0.18.0
Package-Manager: Portage-2.3.31, Repoman-2.3.9
-rw-r--r--sys-process/tini/Manifest1
-rw-r--r--sys-process/tini/tini-0.18.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sys-process/tini/Manifest b/sys-process/tini/Manifest
index 041e5eac5139..055f4819a958 100644
--- a/sys-process/tini/Manifest
+++ b/sys-process/tini/Manifest
@@ -1,2 +1,3 @@
DIST tini-0.16.1.tar.gz 29641 BLAKE2B 637ee17bbf8553b7803dc78cc40ec55ea919ec003005c7f2524322df6cc93a2e4c6fc017fa25c581f50eb17482956ebf37bf49c7796c33d227c7327ca467a906 SHA512 aa0a802c403a07771a2b28a07b97fa2c93d40b5d5be2cba6556c8e7a92e608453010625d0236d26c27bdd2820aed3ad9ca676b70f7fcd5986d7f91eb928d053c
DIST tini-0.17.0.tar.gz 30881 BLAKE2B 8212bfa56b6ade3b79e1d4d3144b10b98e4daf19e9a9c93f6db44dfea22f80b4c6810619832b339984681d1933d00964f7cfbf516286354141f795d3cb5e745f SHA512 4e59241bd621cd89f9c07dcd7a21754a947c87d3571b06bc5f034c0059a20cbc02d4d22fd08a79633b84fd47980dbf5240e2d2fa382aaf5c32e6003710b7691a
+DIST tini-0.18.0.tar.gz 32152 BLAKE2B d676f0f1b4d9f6dca98cdb626aa7c525ec55e090cfeb1cf0e9ab167f1ef4285123223873e92e81d5d62ceb631e26e9012f16b28b1d35813ac801f8e4594be70b SHA512 83279180b6a875aaff9b6b7446ee7e71fd05357279744afcb4db67c76572dc871acfba86c035857009b5dd88ca75d9f2e815d6a925563cdb3e6e771eb83be9b1
diff --git a/sys-process/tini/tini-0.18.0.ebuild b/sys-process/tini/tini-0.18.0.ebuild
new file mode 100644
index 000000000000..e10889c529fb
--- /dev/null
+++ b/sys-process/tini/tini-0.18.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils flag-o-matic
+
+GIT_COMMIT=fec3683b971d9c3ef73f284f176672c44b448662
+DESCRIPTION="A tiny but valid init for containers"
+HOMEPAGE="https://github.com/krallin/tini"
+SRC_URI="https://github.com/krallin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+args +static"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # Do not strip binary
+ sed -i -e 's/-Wl,-s")$/")/' \
+ -e "s/git.*status --porcelain.*/true/" \
+ -e "s/git.*log -n 1.*/true/" \
+ -e "s/git.\${tini_VERSION_GIT}/git.${GIT_COMMIT}/" \
+ CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=()
+ use args || mycmakeargs+=(-DMINIMAL=ON)
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ append-cflags -DPR_SET_CHILD_SUBREAPER=36 -DPR_GET_CHILD_SUBREAPER=37
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use static; then
+ mv "${ED%/}"/usr/bin/{${PN}-static,${PN}} || die
+ else
+ rm "${ED%/}"/usr/bin/${PN}-static || die
+ fi
+}