summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2015-10-12 13:43:40 +0900
committerBenda Xu <heroxbd@gentoo.org>2015-10-12 13:43:40 +0900
commitd1460f97f0068dfbaeaad3584b7de22b12509840 (patch)
treecad5af47426aac33ce16463db36ad533f6966c3b
parentnet-misc/putty: Old. (diff)
downloadgentoo-d1460f97f0068dfbaeaad3584b7de22b12509840.tar.gz
gentoo-d1460f97f0068dfbaeaad3584b7de22b12509840.tar.bz2
gentoo-d1460f97f0068dfbaeaad3584b7de22b12509840.zip
dev-python/rootpy: version bump to 0.8.0.
Package-Manager: portage-2.2.22
-rw-r--r--dev-python/rootpy/Manifest1
-rw-r--r--dev-python/rootpy/rootpy-0.8.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/rootpy/Manifest b/dev-python/rootpy/Manifest
index de21adb36231..099aa4632957 100644
--- a/dev-python/rootpy/Manifest
+++ b/dev-python/rootpy/Manifest
@@ -1 +1,2 @@
DIST rootpy-0.7.1.tar.gz 305412 SHA256 d36399125ed8540b9a651e7b5c7ddeba686ef3107830d3d6d840cdae4834751c SHA512 460e5d79da08c141c762a5a92cf50694fe1fee8677a2439b5525b67e7d6a1a6af18a4e6dc91d379b394a97dc973da8f6baa534d46e506e0a7a4d0ee632de1a2a WHIRLPOOL d9663274a36c490bb4c872be83527d3dd414d9cca989cf20a2aca1ac5441532c9b29571d0ff885458fd2e820dc7905a679e1c9873305848ccd1fafa7820a84be
+DIST rootpy-0.8.0.tar.gz 415826 SHA256 ec0fc969101b6208e722bb9ae11dfe4a02ea53f8f91f591a5c2ea46f26581948 SHA512 0b9dc9c5bee263a2eb33b464bd96f4f9d0820a03722ca2fe3ccfaf11786caf7ccd6d25ffe4ffd42c4a5481bd3b33576cfbf68c01f2af7a981f6a2c1bedc514e2 WHIRLPOOL 7036db8d78c543259801557ebfd940cec7a3083c21757374cf5464a420643cd95cbadc898fe644181cbaa072587a0e49bd56f74f76a8670636604a32da14ddb4
diff --git a/dev-python/rootpy/rootpy-0.8.0.ebuild b/dev-python/rootpy/rootpy-0.8.0.ebuild
new file mode 100644
index 000000000000..e221456ea09d
--- /dev/null
+++ b/dev-python/rootpy/rootpy-0.8.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="readline"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic layer on top of the ROOT framework's PyROOT bindings"
+HOMEPAGE="http://rootpy.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="
+ sci-physics/root[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytables[${PYTHON_USEDEP}]
+ dev-python/root_numpy[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]"
+
+DEPEND="
+ sci-physics/root[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# TOFIX: tests go in an infinite loop error
+RESTRICT=test
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}