summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-05-30 20:05:42 +0200
committerHans de Graaff <graaff@gentoo.org>2016-05-30 20:11:32 +0200
commitd17d7558719411a598eddf1147b4c6b4a2b9b163 (patch)
treea3d8789209154f2227c19fd8ca0d9db0447bfa13
parentnet-misc/netfleet: remove old (diff)
downloadgentoo-d17d7558719411a598eddf1147b4c6b4a2b9b163.tar.gz
gentoo-d17d7558719411a598eddf1147b4c6b4a2b9b163.tar.bz2
gentoo-d17d7558719411a598eddf1147b4c6b4a2b9b163.zip
dev-ruby/msgpack: fix compilation on x86
Fix bug 582968 by avoiding the default --no-undefined linker flag. This is only an issue on 32bit arches due to a difference in inlining rb_num2int. Package-Manager: portage-2.2.28
-rw-r--r--dev-ruby/msgpack/msgpack-0.7.6.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-ruby/msgpack/msgpack-0.7.6.ebuild b/dev-ruby/msgpack/msgpack-0.7.6.ebuild
index 268ddc80aac3..fc0ae75af735 100644
--- a/dev-ruby/msgpack/msgpack-0.7.6.ebuild
+++ b/dev-ruby/msgpack/msgpack-0.7.6.ebuild
@@ -33,6 +33,10 @@ all_ruby_prepare() {
each_ruby_configure() {
${RUBY} -Cext/${PN} extconf.rb || die "Configuration of extension failed."
+
+ # rb_num2int is not inlined on 32 bit arches but also not explicitly
+ # defined, bug 582968
+ sed -i -e 's:-Wl,--no-undefined::' ext/${PN}/Makefile || die
}
each_ruby_compile() {