summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-06-19 15:41:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-06-19 15:41:18 +0200
commitd3359a2c90cace583c66b1ca85deb0b6751ba23f (patch)
tree856780ebed92e71988111722efa4cb55f113def0
parentsys-apps/acl: switch to mirror://nongnu (diff)
downloadgentoo-d3359a2c90cace583c66b1ca85deb0b6751ba23f.tar.gz
gentoo-d3359a2c90cace583c66b1ca85deb0b6751ba23f.tar.bz2
gentoo-d3359a2c90cace583c66b1ca85deb0b6751ba23f.zip
media-libs/x265: bump to 2.8
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--media-libs/x265/Manifest1
-rw-r--r--media-libs/x265/x265-2.8.ebuild195
-rw-r--r--media-libs/x265/x265-9999.ebuild2
3 files changed, 197 insertions, 1 deletions
diff --git a/media-libs/x265/Manifest b/media-libs/x265/Manifest
index c87e7efc05ae..6b08aed8c9af 100644
--- a/media-libs/x265/Manifest
+++ b/media-libs/x265/Manifest
@@ -1,3 +1,4 @@
DIST x265_2.2.tar.gz 1203801 BLAKE2B 239b34c45b07c5bea83f0555d2d8f44322bd8fb3164264ff10f3887bb244ce7e605a82c2cb0a2f2ae4f2749e009baac19407109996e599dc41bc970a610ed086 SHA512 335bb38cf0892f2c4310033b076d51115c0b7faa9596a4f556dde5e3d1378d04f3d0055cb0bf2441eb725b7f84c246174bdc315eeb4ddde61ef9d79469f44eef
DIST x265_2.6.tar.gz 1271976 BLAKE2B f649c47209af0f1cfff7ff736b9f43f20c9eaaf14e8428f6eff4fd9e3ce925de6e1ecde1be55b5d654321614fc245837d0bc603b72a92c41b92c729dc20f5cb6 SHA512 35c3716313e3dfd1555dd725b60f2b3b00a615d8b8d8267439722b52021d47e34eebf94b837b92a92d40c7ffab7b3198d6391365d62672b257c0a87d1db8a736
DIST x265_2.7.tar.gz 1282742 BLAKE2B 5f7290a71009f1ba177b2a653c48b62d8067930e8e53e4f9dd149037d3cbc69acbcae9c5364d46e6cc127f7d70e2acaaed2abf3ef065ecae303088132f341757 SHA512 58582ff5c282a8ca6213a98495b95fa941f323fa454924e4751dde6d2a0e87a08d6e8d98012164a3d83523f2b004e7a1420b60b64719fe30f460dd10ec075094
+DIST x265_2.8.tar.gz 1379551 BLAKE2B c124864a08492739cdde89e44d72c84ad94a0b236d2c59d995e53a26d1a5fb9ec1557a03640a3065a727be69bfb0c0633b50351dc875c9706a1550f488c8ee24 SHA512 c2a8eaec64aa022badcbcd2a96304a9abd9d08489300b6a9c4c9d76066f3d9848e6948238c84ae16ea91bff0b2fac528a67ee29950d94dcd0ea7c0e9e7baa714
diff --git a/media-libs/x265/x265-2.8.ebuild b/media-libs/x265/x265-2.8.ebuild
new file mode 100644
index 000000000000..b7f4c3f20508
--- /dev/null
+++ b/media-libs/x265/x265-2.8.ebuild
@@ -0,0 +1,195 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit cmake-utils multilib-minimal multilib multibuild flag-o-matic
+
+if [[ ${PV} = 9999* ]]; then
+ inherit mercurial
+ EHG_REPO_URI="https://bitbucket.org/multicoreware/x265"
+else
+ SRC_URI="https://bitbucket.org/multicoreware/x265/downloads/${PN}_${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library for encoding video streams into the H.265/HEVC format"
+HOMEPAGE="http://x265.org/"
+
+LICENSE="GPL-2"
+# subslot = libx265 soname
+SLOT="0/160"
+IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+
+ASM_DEPEND=">=dev-lang/yasm-1.2.0"
+RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ abi_x86_32? ( ${ASM_DEPEND} )
+ abi_x86_64? ( ${ASM_DEPEND} )"
+
+PATCHES=(
+ "${FILESDIR}/arm.patch"
+ "${FILESDIR}/neon.patch"
+ "${FILESDIR}/ppc64.patch"
+)
+
+src_unpack() {
+ if [[ ${PV} = 9999* ]]; then
+ mercurial_src_unpack
+ # Can't set it at global scope due to mercurial.eclass limitations...
+ export S=${WORKDIR}/${P}/source
+ else
+ unpack ${A}
+ export S="$(echo "${WORKDIR}/${PN}_"*"/source")"
+ fi
+}
+
+# By default, the library and the encoder is configured for only one output bit
+# depth. Meaning, one has to rebuild libx265 if (s)he wants to produce HEVC
+# files with a different bit depth, which is annoying. However, upstream
+# supports proper namespacing for 8bits, 10bits & 12bits HEVC and linking all
+# that together so that the resulting library can produce all three of them
+# instead of only one.
+# The API requires the bit depth parameter, so that libx265 can then chose which
+# variant of the encoder to use.
+# To achieve this, we have to build one (static) library for each non-main
+# variant, and link it into the main library.
+# Upstream documents using the 8bit variant as main library, hence we do not
+# allow disabling it: "main" *MUST* come last in the following list.
+
+x265_get_variants() {
+ local variants=""
+ use 12bit && variants+="main12 "
+ use 10bit && variants+="main10 "
+ variants+="main"
+ echo "${variants}"
+}
+
+x265_variant_src_configure() {
+ mkdir -p "${BUILD_DIR}" || die
+ pushd "${BUILD_DIR}" >/dev/null || die
+
+ local mycmakeargs=( "${myabicmakeargs[@]}" )
+ case "${MULTIBUILD_VARIANT}" in
+ "main12")
+ mycmakeargs+=(
+ -DHIGH_BIT_DEPTH=ON
+ -DEXPORT_C_API=OFF
+ -DENABLE_SHARED=OFF
+ -DENABLE_CLI=OFF
+ -DMAIN12=ON
+ )
+ if [[ ${ABI} = x86 ]] ; then
+ mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+ fi
+ if [[ ${ABI} = arm ]] ; then
+ # 589674
+ mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+ fi
+ if [[ ${ABI} = ppc64 ]] ; then
+ # https://bugs.gentoo.org/show_bug.cgi?id=607802#c5
+ mycmakeargs+=( -DENABLE_ASSEMBLY=OFF -DENABLE_ALTIVEC=OFF )
+ fi
+ ;;
+ "main10")
+ mycmakeargs+=(
+ -DHIGH_BIT_DEPTH=ON
+ -DEXPORT_C_API=OFF
+ -DENABLE_SHARED=OFF
+ -DENABLE_CLI=OFF
+ )
+ if [[ ${ABI} = x86 ]] ; then
+ mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+ fi
+ if [[ ${ABI} = arm ]] ; then
+ # 589674
+ mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+ fi
+ if [[ ${ABI} = ppc64 ]] ; then
+ # https://bugs.gentoo.org/show_bug.cgi?id=607802#c5
+ mycmakeargs+=( -DENABLE_ASSEMBLY=OFF -DENABLE_ALTIVEC=OFF )
+ fi
+ ;;
+ "main")
+ if (( "${#MULTIBUILD_VARIANTS[@]}" > 1 )) ; then
+ local myvariants=( "${MULTIBUILD_VARIANTS[@]}" )
+ unset myvariants[${#MULTIBUILD_VARIANTS[@]}-1]
+ local liblist=""
+ for v in "${myvariants[@]}" ; do
+ ln -s "${BUILD_DIR%-*}-${v}/libx265.a" "libx265_${v}.a" || die
+ liblist+="libx265_${v}.a;"
+ done
+ mycmakeargs+=(
+ -DEXTRA_LIB="${liblist}"
+ -DEXTRA_LINK_FLAGS=-L.
+ -DLINKED_10BIT=$(usex 10bit)
+ -DLINKED_12BIT=$(usex 12bit)
+ )
+ fi
+ ;;
+ *)
+ die "Unknown variant: ${MULTIBUILD_VARIANT}";;
+ esac
+ cmake-utils_src_configure
+ popd >/dev/null || die
+}
+
+multilib_src_configure() {
+ append-cflags -fPIC
+ append-cxxflags -fPIC
+ local myabicmakeargs=(
+ $(cmake-utils_use_enable test TESTS)
+ $(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
+ -DENABLE_LIBNUMA=$(usex numa ON OFF)
+ -DCPU_POWER8=$(usex power8 ON OFF)
+ -DENABLE_ALTIVEC=$(usex power8 ON OFF)
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+
+ if [[ ${ABI} = x86 ]] ; then
+ # Bug #528202
+ if use pic ; then
+ ewarn "PIC has been requested but x86 asm is not PIC-safe, disabling it."
+ myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+ fi
+ elif [[ ${ABI} = x32 ]] ; then
+ # bug #510890
+ myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+ elif [[ ${ABI} = arm ]] ; then
+ myabicmakeargs+=( -DENABLE_ASSEMBLY=$(usex pic OFF $(usex cpu_flags_arm_neon ON OFF)) )
+ use cpu_flags_arm_neon && use pic && ewarn "PIC has been requested but arm neon asm is not PIC-safe, disabling it."
+ fi
+
+ local MULTIBUILD_VARIANTS=( $(x265_get_variants) )
+ multibuild_foreach_variant x265_variant_src_configure
+}
+
+multilib_src_compile() {
+ local MULTIBUILD_VARIANTS=( $(x265_get_variants) )
+ multibuild_foreach_variant cmake-utils_src_compile
+}
+
+x265_variant_src_test() {
+ if [ -x "${BUILD_DIR}/test/TestBench" ] ; then
+ "${BUILD_DIR}/test/TestBench" || die
+ else
+ einfo "Unit tests check only assembly."
+ einfo "You do not seem to have any for ABI=${ABI}, x265 variant=${MULTIBUILD_VARIANT}"
+ einfo "Skipping tests."
+ fi
+}
+
+multilib_src_test() {
+ local MULTIBUILD_VARIANTS=( $(x265_get_variants) )
+ multibuild_foreach_variant x265_variant_src_test
+}
+
+multilib_src_install() {
+ # Install only "main" variant since the others are already linked into it.
+ local MULTIBUILD_VARIANTS=( "main" )
+ multibuild_foreach_variant cmake-utils_src_install
+}
+
+multilib_src_install_all() {
+ dodoc -r "${S}/../doc/"*
+}
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
index 8515b0a56138..a8bb14b86fa3 100644
--- a/media-libs/x265/x265-9999.ebuild
+++ b/media-libs/x265/x265-9999.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
-SLOT="0/151"
+SLOT="0/161"
IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"