summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-24 23:44:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-24 23:45:05 +0200
commitd39b643ada53bfb2e3d1508dfd68e592bebbfafa (patch)
treebc9ac112c562af96b8355ac94fd68683472b1cad
parentdev-util/kdstatemachineeditor: Drop 1.2.3 (diff)
downloadgentoo-d39b643ada53bfb2e3d1508dfd68e592bebbfafa.tar.gz
gentoo-d39b643ada53bfb2e3d1508dfd68e592bebbfafa.tar.bz2
gentoo-d39b643ada53bfb2e3d1508dfd68e592bebbfafa.zip
kde-frameworks/kglobalaccel: Fix runtime crashes
Upstream commit abe32ec599397bda0ce73471519410bee2c16059 KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=406426 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-frameworks/kglobalaccel/files/kglobalaccel-5.57.0-runtime-crashfix.patch36
-rw-r--r--kde-frameworks/kglobalaccel/kglobalaccel-5.57.0-r1.ebuild32
2 files changed, 68 insertions, 0 deletions
diff --git a/kde-frameworks/kglobalaccel/files/kglobalaccel-5.57.0-runtime-crashfix.patch b/kde-frameworks/kglobalaccel/files/kglobalaccel-5.57.0-runtime-crashfix.patch
new file mode 100644
index 000000000000..762623d6d4f1
--- /dev/null
+++ b/kde-frameworks/kglobalaccel/files/kglobalaccel-5.57.0-runtime-crashfix.patch
@@ -0,0 +1,36 @@
+From abe32ec599397bda0ce73471519410bee2c16059 Mon Sep 17 00:00:00 2001
+From: Laurent Montel <montel@kde.org>
+Date: Sun, 14 Apr 2019 20:15:31 +0200
+Subject: Don't use qAsConst over a temporary variable
+
+Summary: BUG: 406426
+
+Reviewers: dfaure
+
+Reviewed By: dfaure
+
+Subscribers: kde-frameworks-devel
+
+Tags: #frameworks
+
+Differential Revision: https://phabricator.kde.org/D20555
+---
+ src/runtime/component.cpp | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/runtime/component.cpp b/src/runtime/component.cpp
+index ce276b9..669df67 100644
+--- a/src/runtime/component.cpp
++++ b/src/runtime/component.cpp
+@@ -330,7 +330,8 @@ bool Component::isShortcutAvailable(
+ // context
+ if (component==uniqueName())
+ {
+- for (GlobalShortcut *sc : qAsConst(shortcutContext(context)->_actions))
++ const auto actions = shortcutContext(context)->_actions;
++ for (GlobalShortcut *sc : actions)
+ {
+ if (sc->keys().contains(key)) return false;
+ }
+--
+cgit v1.1
diff --git a/kde-frameworks/kglobalaccel/kglobalaccel-5.57.0-r1.ebuild b/kde-frameworks/kglobalaccel/kglobalaccel-5.57.0-r1.ebuild
new file mode 100644
index 000000000000..8d218d0d3af0
--- /dev/null
+++ b/kde-frameworks/kglobalaccel/kglobalaccel-5.57.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework to handle global shortcuts"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+LICENSE="LGPL-2+"
+IUSE="nls"
+
+BDEPEND="
+ nls? ( $(add_qt_dep linguist-tools) )
+"
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kwindowsystem X)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-runtime-crashfix.patch" )