summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-19 08:41:49 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-19 08:41:49 +0200
commitd489235964e173736007960e8e42f55634284909 (patch)
tree9d86d52b1da62068d18615e8a25a3a9c494563f5
parentdev-ruby/rgen: Remove last-rited pkg (diff)
downloadgentoo-d489235964e173736007960e8e42f55634284909.tar.gz
gentoo-d489235964e173736007960e8e42f55634284909.tar.bz2
gentoo-d489235964e173736007960e8e42f55634284909.zip
dev-ruby/journey: Remove last-rited pkg
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-ruby/journey/Manifest1
-rw-r--r--dev-ruby/journey/files/journey-1.0.4-fix-tests.patch66
-rw-r--r--dev-ruby/journey/journey-1.0.4-r1.ebuild25
-rw-r--r--dev-ruby/journey/metadata.xml11
-rw-r--r--profiles/package.mask2
5 files changed, 0 insertions, 105 deletions
diff --git a/dev-ruby/journey/Manifest b/dev-ruby/journey/Manifest
deleted file mode 100644
index e62bf9fefcb4..000000000000
--- a/dev-ruby/journey/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST journey-1.0.4.gem 28672 BLAKE2B fe78647c9f80ad4b9874eab9488cca199cd69d354e69f3f5b47b417452ca259790109d07a27c4c2d99778683d9264413399d4d7acd7eb4d8e78f7e37ccf2a8d7 SHA512 9e6a06da8b77f6efb9941c58f53254e8cf3a1ebb6f8261a66ef3fed9c21ff4e4a90567fee88507b8e2c1fecc0fbdf204a9d3c8473b671bbb4b8c6b9faa6f2a07
diff --git a/dev-ruby/journey/files/journey-1.0.4-fix-tests.patch b/dev-ruby/journey/files/journey-1.0.4-fix-tests.patch
deleted file mode 100644
index f977172e6464..000000000000
--- a/dev-ruby/journey/files/journey-1.0.4-fix-tests.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From d836e960d9a20c4c5bc986630d2ba34a340959ea Mon Sep 17 00:00:00 2001
-From: Aaron Patterson <aaron.patterson@gmail.com>
-Date: Fri, 27 Jul 2012 11:20:58 -0700
-Subject: [PATCH] fix assertion calls
-
----
- test/path/test_pattern.rb | 22 +++++++++++-----------
- 1 file changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/test/path/test_pattern.rb b/test/path/test_pattern.rb
-index c684a0a..ec93471 100644
---- a/test/path/test_pattern.rb
-+++ b/test/path/test_pattern.rb
-@@ -85,9 +85,9 @@ def test_to_regexp_with_extended_group
- ["/", ".", "?"]
- )
- path = Pattern.new strexp
-- assert_match('/page/tender', path)
-- assert_match('/page/love', path)
-- refute_match('/page/loving', path)
-+ assert_match(path, '/page/tender')
-+ assert_match(path, '/page/love')
-+ refute_match(path, '/page/loving')
- end
-
- def test_optional_names
-@@ -108,8 +108,8 @@ def test_to_regexp_match_non_optional
- ["/", ".", "?"]
- )
- path = Pattern.new strexp
-- assert_match('/123', path)
-- refute_match('/', path)
-+ assert_match(path, '/123')
-+ refute_match(path, '/')
- end
-
- def test_to_regexp_with_group
-@@ -119,9 +119,9 @@ def test_to_regexp_with_group
- ["/", ".", "?"]
- )
- path = Pattern.new strexp
-- assert_match('/page/tender', path)
-- assert_match('/page/love', path)
-- refute_match('/page/loving', path)
-+ assert_match(path, '/page/tender')
-+ assert_match(path, '/page/love')
-+ refute_match(path, '/page/loving')
- end
-
- def test_ast_sets_regular_expressions
-@@ -186,9 +186,9 @@ def test_insensitive_regexp_with_group
- ["/", ".", "?"]
- )
- path = Pattern.new strexp
-- assert_match('/page/TENDER/aaron', path)
-- assert_match('/page/loVE/aaron', path)
-- refute_match('/page/loVE/AAron', path)
-+ assert_match(path, '/page/TENDER/aaron')
-+ assert_match(path, '/page/loVE/aaron')
-+ refute_match(path, '/page/loVE/AAron')
- end
-
- def test_to_regexp_with_strexp
---
-1.9.1
-
diff --git a/dev-ruby/journey/journey-1.0.4-r1.ebuild b/dev-ruby/journey/journey-1.0.4-r1.ebuild
deleted file mode 100644
index 1e510b67e67e..000000000000
--- a/dev-ruby/journey/journey-1.0.4-r1.ebuild
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Journey is a router. It routes requests"
-HOMEPAGE="https://github.com/rails/journey"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/hoe
- dev-ruby/json
- dev-ruby/minitest )"
-
-RUBY_PATCHES=( "${FILESDIR}"/${P}-fix-tests.patch )
diff --git a/dev-ruby/journey/metadata.xml b/dev-ruby/journey/metadata.xml
deleted file mode 100644
index 16111db641b1..000000000000
--- a/dev-ruby/journey/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ruby@gentoo.org</email>
- <name>Gentoo Ruby Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">rails/journey</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 6f8b246b894a..1635ce6dd664 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -406,8 +406,6 @@ dev-ruby/expression_parser
dev-ruby/hoe-seattlerb
# No longer maintained upstream, ruby27 issues, no deps
dev-ruby/inifile
-# Obsolete (merged into rails 4)
-dev-ruby/journey
# Michał Górny <mgorny@gentoo.org> (2020-09-09)
# These packages (or package versions) still require Python 2.7.