summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2019-01-28 20:59:48 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2019-01-28 21:01:33 +0100
commitd6abdc74d3b9741c252a3669fc2444d8a70dfa22 (patch)
treeaf5e715c08e424d864d11124d29ef67dacdf711d
parentsys-apps/s390-tools: mark s390 stable (diff)
downloadgentoo-d6abdc74d3b9741c252a3669fc2444d8a70dfa22.tar.gz
gentoo-d6abdc74d3b9741c252a3669fc2444d8a70dfa22.tar.bz2
gentoo-d6abdc74d3b9741c252a3669fc2444d8a70dfa22.zip
app-text/gtkspell: bump to 3.0.10
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
-rw-r--r--app-text/gtkspell/Manifest1
-rw-r--r--app-text/gtkspell/gtkspell-3.0.10.ebuild46
-rw-r--r--profiles/package.mask5
3 files changed, 52 insertions, 0 deletions
diff --git a/app-text/gtkspell/Manifest b/app-text/gtkspell/Manifest
index 88d739c57e13..78d160b5e3e9 100644
--- a/app-text/gtkspell/Manifest
+++ b/app-text/gtkspell/Manifest
@@ -1,2 +1,3 @@
DIST gtkspell-2.0.16.tar.gz 351277 BLAKE2B ccb49b99c4f9059ed4461bb5ffda4dbeb691c5a062184ba7b51d8464d2461c5be0d648e4f69dbc36fe345be2addbc271af9701a0a387975265585dd3a7926e99 SHA512 7d3afb327c2e15608194e6ee6110107a0ce082e483788d831d636b2e579472304137373c09a966d8e5c0cd2f830bf2e0ee477c9b5fca7da6ee27fd1498915b9d
+DIST gtkspell3-3.0.10.tar.xz 300968 BLAKE2B aa167e9e5068e9c6c5fcf6933a28246de0be8386be43ab3af80a45dfbc092e1381503822d09742d20dde2e0b8dae77210001c955e37a8dab263b832ee52675a1 SHA512 3b1ceaa9ffa06bd3f6dae39c95db951588e5cf2edf4f551cac6972822ba230af3415c5045fa24f7a4dfe05c2e386ab3f67cb80cb779576b4e54293b7b9fbc28e
DIST gtkspell3-3.0.9.tar.xz 298988 BLAKE2B 01a824ba91fff1739046134ef0025cf894ed3f524dcc96a11ba6b23def3b1d84ef66fc5dbf37c1a047d23b276b944b25e89ff6a84ebfe19a1189ccc59d230250 SHA512 de6cc24ca092067a101996142bf2b3cfb6a5af2170ea4b0185a997e5c88adead7ba53c5a297c3110b3a66dc87d37e429720f972895bb2931f9a033fc006e2eab
diff --git a/app-text/gtkspell/gtkspell-3.0.10.ebuild b/app-text/gtkspell/gtkspell-3.0.10.ebuild
new file mode 100644
index 000000000000..a87cfe4fc106
--- /dev/null
+++ b/app-text/gtkspell/gtkspell-3.0.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 vala
+
+DESCRIPTION="Spell checking widget for GTK"
+HOMEPAGE="http://gtkspell.sourceforge.net/"
+MY_P="${PN}3-${PV}"
+SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="3/0"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=app-text/enchant-2.0.0
+ app-text/iso-codes
+ dev-libs/glib:2
+ x11-libs/gtk+:3[introspection?]
+ >=x11-libs/pango-1.8.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.17
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
diff --git a/profiles/package.mask b/profiles/package.mask
index cc636aaf852d..e63e00e2ecec 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -30,9 +30,14 @@
#--- END OF EXAMPLES ---
# Dennis Lamm <expeditioneer@gentoo.org> (28 Jan 2019)
+# Depends on >=app-text/enchant-2.0.0 which is masked
+>=app-text/gtkspell-3.0.10
+
+# Dennis Lamm <expeditioneer@gentoo.org> (28 Jan 2019)
# Depends on >=app-text/enchant-2.1.3 which is masked
>=app-text/gspell-1.8.1
+
# Virgil Dupras <vdupras@gentoo.org> (27 Jan 2019)
# Dead upstream, no revdep. bug #618744
dev-python/fusil