summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2021-06-18 09:34:25 +0200
committerFabian Groffen <grobian@gentoo.org>2021-06-18 10:58:32 +0200
commitd79073fa489f7f736f8b64e8598e2d93ea0c0264 (patch)
tree6e1ee284fbf313ee0e7f9923762baec4280cf113
parentsci-misc/netlogo-bin: remove version with min java 1.5 (diff)
downloadgentoo-d79073fa489f7f736f8b64e8598e2d93ea0c0264.tar.gz
gentoo-d79073fa489f7f736f8b64e8598e2d93ea0c0264.tar.bz2
gentoo-d79073fa489f7f736f8b64e8598e2d93ea0c0264.zip
net-analyzer/openbsd-netcat-1.195-r1: fix compile for real on >=darwin19
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--net-analyzer/openbsd-netcat/files/openbsd-netcat-1.190-darwin13.patch8
-rw-r--r--net-analyzer/openbsd-netcat/openbsd-netcat-1.195-r1.ebuild2
2 files changed, 7 insertions, 3 deletions
diff --git a/net-analyzer/openbsd-netcat/files/openbsd-netcat-1.190-darwin13.patch b/net-analyzer/openbsd-netcat/files/openbsd-netcat-1.190-darwin13.patch
index 5a643a2945f3..216b8c207922 100644
--- a/net-analyzer/openbsd-netcat/files/openbsd-netcat-1.190-darwin13.patch
+++ b/net-analyzer/openbsd-netcat/files/openbsd-netcat-1.190-darwin13.patch
@@ -1,4 +1,8 @@
-strtonum isn't available on <Darwin-10.15
+strtonum isn't available on <Darwin-11
+
+however, it is in the header files on systems like 10.15 with an
+availability clause, so don't define strtonum static such that it
+matches the prototype from stdlib.h
diff --git a/netcat.c b/netcat.c
index a0fb51b..bbb5dd1 100644
@@ -14,7 +18,7 @@ index a0fb51b..bbb5dd1 100644
+ "invalid"
+};
+
-+static long long
++long long
+strtonum(
+ const char *nptr,
+ long long minval,
diff --git a/net-analyzer/openbsd-netcat/openbsd-netcat-1.195-r1.ebuild b/net-analyzer/openbsd-netcat/openbsd-netcat-1.195-r1.ebuild
index 6fd1b2b6f906..b7288f531c86 100644
--- a/net-analyzer/openbsd-netcat/openbsd-netcat-1.195-r1.ebuild
+++ b/net-analyzer/openbsd-netcat/openbsd-netcat-1.195-r1.ebuild
@@ -31,7 +31,7 @@ src_prepare() {
if [[ ${CHOST} == *-darwin* ]] ; then
# this undoes some of the Debian/Linux changes
eapply "${FILESDIR}"/${PN}-1.195-darwin.patch
- if [[ ${CHOST##*-darwin} -lt 19 ]] ; then
+ if [[ ${CHOST##*-darwin} -lt 20 ]] ; then
eapply "${FILESDIR}"/${PN}-1.190-darwin13.patch
fi
fi