summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-05-18 11:26:47 +0200
committerJeroen Roovers <jer@gentoo.org>2016-05-18 11:27:24 +0200
commitd902e6943cc04897a40fbd80aec064734df036de (patch)
tree8d3f3db980717fbf2e5ccf2c9830cf680e792277
parentnet-misc/youtube-dl: Version bump. (diff)
downloadgentoo-d902e6943cc04897a40fbd80aec064734df036de.tar.gz
gentoo-d902e6943cc04897a40fbd80aec064734df036de.tar.bz2
gentoo-d902e6943cc04897a40fbd80aec064734df036de.zip
net-misc/chrony: Version bump.
Package-Manager: portage-2.3.0_rc1
-rw-r--r--net-misc/chrony/Manifest1
-rw-r--r--net-misc/chrony/chrony-2.4_pre1.ebuild117
-rw-r--r--net-misc/chrony/metadata.xml1
3 files changed, 119 insertions, 0 deletions
diff --git a/net-misc/chrony/Manifest b/net-misc/chrony/Manifest
index bc98bbd6ce02..adab8d041750 100644
--- a/net-misc/chrony/Manifest
+++ b/net-misc/chrony/Manifest
@@ -1,2 +1,3 @@
DIST chrony-2.2.1.tar.gz 340514 SHA256 4776fa8e80d698723e9a88eb882170951f6c45860545d84ae9f9d8b9bbd73796 SHA512 caa18a22e7e64186f24f474e02862296bfa74c99671bc98e926caf27b88ce3580282543594602e76ad4be9b7f9623350888def893a7c1d96a7370d13a636442f WHIRLPOOL 77500bc25496dc15f17bce60023b86330205945999011b243272db26a924ac67193da70089c59e19bea7666c05059c8c4c1975ca19057775ec2dd8e468ab8dce
DIST chrony-2.3.tar.gz 355113 SHA256 58bffb523012fb0fa87cc0d94d6e36de9689fe9556519cbd0d1ba254af92ccb2 SHA512 2a9cda6c2bc931438b798bd037614196bdb1533d12432467a690d57095c74013c80c92fcaadbd43fd5b0c816872822527a1ade3014add458d669d7813d5fa080 WHIRLPOOL 06864181ac74b2cf13baf7d9098404f8540c26db41035fe38005fbfea8e12f2de179008f5b1a2544e24ebb7e4cca712421746690edb7f36b90416ad87901e920
+DIST chrony-2.4-pre1.tar.gz 388905 SHA256 3165cd130f6049c08a4e643768adf67c113396ce188b1499e6c9b808b748e118 SHA512 92913bfaba5ef5ef63a32cffa4dab1498683db1d73c593fa7e4f228b57c5d40a6a9bf209c14b02c1a1aa65cf168f59bc3af10fe24d2ad1dfe0a7bc2622e16946 WHIRLPOOL 59932cca6f8a98e581eb99850509c8982bd478745d55db261a6b1c21ecab26b64c08920352d422cee10509f50de5be002da010785538e2d853e27f1fbeda3a36
diff --git a/net-misc/chrony/chrony-2.4_pre1.ebuild b/net-misc/chrony/chrony-2.4_pre1.ebuild
new file mode 100644
index 000000000000..f216018599e7
--- /dev/null
+++ b/net-misc/chrony/chrony-2.4_pre1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd toolchain-funcs
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="http://chrony.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64"
+IUSE="caps +cmdmon html ipv6 libedit +ntp +phc +pps readline +refclock +rtc selinux +adns"
+REQUIRED_USE="
+ ?? ( libedit readline )
+"
+
+CDEPEND="
+ caps? ( sys-libs/libcap )
+ libedit? ( dev-libs/libedit )
+ readline? ( >=sys-libs/readline-4.1-r4:= )
+"
+DEPEND="
+ ${CDEPEND}
+ html? ( dev-ruby/asciidoctor )
+"
+RDEPEND="
+ ${CDEPEND}
+ selinux? ( sec-policy/selinux-chronyd )
+"
+
+RESTRICT=test
+
+S="${WORKDIR}/${P/_/-}"
+
+src_prepare() {
+ sed -i \
+ -e 's:/etc/chrony\.:/etc/chrony/chrony.:g' \
+ -e 's:/var/run:/run:g' \
+ conf.c doc/*.man.in examples/* || die
+}
+
+src_configure() {
+ tc-export CC
+
+ local CHRONY_EDITLINE
+ # ./configure legend:
+ # --disable-readline : disable line editing entirely
+ # --without-readline : do not use sys-libs/readline (enabled by default)
+ # --without-editline : do not use dev-libs/libedit (enabled by default)
+ if ! use readline && ! use libedit; then
+ CHRONY_EDITLINE='--disable-readline'
+ else
+ CHRONY_EDITLINE+=" $(usex readline '' --without-readline)"
+ CHRONY_EDITLINE+=" $(usex libedit '' --without-editline)"
+ fi
+
+ # not an autotools generated script
+ local CHRONY_CONFIGURE="
+ ./configure \
+ $(usex caps '' --disable-linuxcaps) \
+ $(usex cmdmon '' --disable-cmdmon) \
+ $(usex ipv6 '' --disable-ipv6) \
+ $(usex ntp '' --disable-ntp) \
+ $(usex phc '' --disable-phc) \
+ $(usex pps '' --disable-pps) \
+ $(usex rtc '' --disable-rtc) \
+ $(usex refclock '' --disable-refclock) \
+ $(usex adns '' --disable-asyncdns) \
+ ${CHRONY_EDITLINE} \
+ ${EXTRA_ECONF} \
+ --docdir=/usr/share/doc/${PF} \
+ --chronysockdir=/run/chrony \
+ --mandir=/usr/share/man \
+ --prefix=/usr \
+ --sysconfdir=/etc/chrony \
+ --disable-sechash \
+ --without-nss \
+ --without-tomcrypt
+ "
+
+ # print the ./configure call to aid in future debugging
+ einfo ${CHRONY_CONFIGURE}
+ bash ${CHRONY_CONFIGURE} || die
+}
+
+src_compile() {
+ emake all docs
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/chronyd.init-r1 chronyd
+ newconfd "${FILESDIR}"/chronyd.conf chronyd
+
+ insinto /etc/${PN}
+ newins examples/chrony.conf.example1 chrony.conf
+
+ docinto examples
+ dodoc examples/*.example*
+
+ if use html; then
+ docinto html
+ dodoc doc/*.html
+ fi
+
+ keepdir /var/{lib,log}/chrony
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/chrony-2.2.logrotate chrony
+
+ systemd_newunit "${FILESDIR}"/chronyd.service-r2 chronyd.service
+ systemd_enable_ntpunit 50-chrony chronyd.service
+}
diff --git a/net-misc/chrony/metadata.xml b/net-misc/chrony/metadata.xml
index 0a98e63dee79..fe0c5f66743d 100644
--- a/net-misc/chrony/metadata.xml
+++ b/net-misc/chrony/metadata.xml
@@ -19,6 +19,7 @@ Chrony はコンピュータのシステム・クロックの精度を保つた
</longdescription>
<use>
<flag name="cmdmon">Support for command and monitoring</flag>
+<flag name="html">Install HTML documentation</flag>
<flag name="ntp">Support for the Network Time Protocol (NTP)</flag>
<flag name="phc">Support for the PTP (Precision Time Protocol) Hardware Clock (PHC) interface</flag>
<flag name="pps">Support for the Linux Pulse Per Second (PPS) interface</flag>