summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-12-25 23:33:31 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-12-25 23:33:31 +0000
commitd9d3d8f5daa2a86e68d710399e16d4b3612d743b (patch)
treedafae00091109b6c72907b2348945b24b4b5c14f
parentdev-ruby/ammeter: Add ruby23 (diff)
downloadgentoo-d9d3d8f5daa2a86e68d710399e16d4b3612d743b.tar.gz
gentoo-d9d3d8f5daa2a86e68d710399e16d4b3612d743b.tar.bz2
gentoo-d9d3d8f5daa2a86e68d710399e16d4b3612d743b.zip
media-video/makemkv: Version bump to 1.10.4
My new patches were not included this time but upstream has said they should go in for next time. Package-Manager: portage-2.3.3
-rw-r--r--media-video/makemkv/Manifest2
-rw-r--r--media-video/makemkv/makemkv-1.10.4.ebuild129
2 files changed, 131 insertions, 0 deletions
diff --git a/media-video/makemkv/Manifest b/media-video/makemkv/Manifest
index e337340792cf..4614dbb119ed 100644
--- a/media-video/makemkv/Manifest
+++ b/media-video/makemkv/Manifest
@@ -1,2 +1,4 @@
DIST makemkv-bin-1.10.3.tar.gz 8296526 SHA256 5c860fabd58e5d923c1e0f4c336751a9ba61a7874de320169a3988cda33d6cfb SHA512 93cca2516b51794af87dc997aee98e1fa99f75933e49b9ca4eb1bc3896464f3a2de251ddaa430a751f0233493ecc5948e39daaffe4b5b0d884ce47a38c27647f WHIRLPOOL 978cc0cd2eacdc495a39d5b070c7dfe48f2e88ac8644c39e5025c76b702af211c2420cf4204c3fcb5d0d656e704f3d1341c59f66a337c0701fa15adfaaf6e9dc
+DIST makemkv-bin-1.10.4.tar.gz 8315649 SHA256 bc6f66897c09b0b756b352cc02a092c5b3a9547e4c129b3472ae4c605eff94aa SHA512 00482428a6374e37912e0537c1e876b478a5eb9e0a26476b01f74f93c0605ed7aa3547599287211f17dd2d511e5bebf60605e05d0064f501816fdfccd964b98c WHIRLPOOL 29dfa3dcc1f36511bd153ae1c43ca54b6fb2d8cfa8d62960e7605ca460a182d4d1feec05baa9d01dfba5f80734cae4c085b8b9f0ac5d0b0910c58fa766e351f8
DIST makemkv-oss-1.10.3.tar.gz 4419732 SHA256 b89069294c27b298d35be86353baf9c3da8d7e18b6bce53d4ad2ee3a46785760 SHA512 f380aaccd930659f80d937699f82bf39a51631fe67161f81adc7a3380d28ecc107c2921d82c42a7995a9eabdbbf78d289384dca09e84855044eef4cea9c2f0c9 WHIRLPOOL 272b25f17ad221dd408f921221390566ec97e6a7e7a1729731ba5d75ff2c097919d46235f1b271db1b2be037053b3c05629690a696fe8e9723f4abe8fe203cd9
+DIST makemkv-oss-1.10.4.tar.gz 4421220 SHA256 bacbd6a27ebd67f2e6f6c4356cafb92918d54a8bb15872f694232043039f63c4 SHA512 6a792703ae4ab978ebe7a71e9d9f2c298e230168c2701fd2f7fab724f31a1c83388bae408c253a75504c73b9e25f9fb0ba48d5697cfa1f7ae39df133444983c4 WHIRLPOOL 099f0d5d76ec97e3bf3bfa0a0e1ffceb5c539584ca05f9d204b241960d579f9eaabb8dfc8df2a35feec253fa597d9c97ed28c7cef95928f699a6a74bed146bee
diff --git a/media-video/makemkv/makemkv-1.10.4.ebuild b/media-video/makemkv/makemkv-1.10.4.ebuild
new file mode 100644
index 000000000000..fd12203a331c
--- /dev/null
+++ b/media-video/makemkv/makemkv-1.10.4.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils gnome2-utils multilib flag-o-matic
+
+MY_P=makemkv-oss-${PV}
+MY_PB=makemkv-bin-${PV}
+
+DESCRIPTION="Tool for ripping and streaming Blu-ray, HD-DVD and DVD discs"
+HOMEPAGE="http://www.makemkv.com/"
+SRC_URI="http://www.makemkv.com/download/${MY_P}.tar.gz
+ http://www.makemkv.com/download/${MY_PB}.tar.gz"
+
+LICENSE="LGPL-2.1 MPL-1.1 MakeMKV-EULA openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libav multilib qt4 qt5"
+
+QA_PREBUILT="usr/bin/makemkvcon usr/bin/mmdtsdec"
+
+DEPEND="
+ sys-libs/glibc[multilib?]
+ dev-libs/expat
+ dev-libs/openssl:0
+ sys-libs/zlib
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ !qt5? ( qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ ) )
+ !libav? ( >=media-video/ffmpeg-1.0.0:0= )
+ libav? ( >=media-video/libav-0.8.9:0= )
+"
+RDEPEND="${DEPEND}
+ net-misc/wget"
+
+S="${WORKDIR}/makemkv-oss-${PV}"
+
+src_prepare() {
+ PATCHES+=( "${FILESDIR}"/${PN}-{makefile,path,sysmacros,flags}.patch )
+
+ # Qt5 always trumps Qt4 if it is available. There are no configure
+ # options or variables to control this and there is no publicly
+ # available configure.ac either.
+ if use qt5; then
+ PATCHES+=( "${FILESDIR}"/${PN}-qt5.patch )
+ elif use qt4; then
+ PATCHES+=( "${FILESDIR}"/${PN}-qt4.patch )
+ fi
+
+ default
+}
+
+src_configure() {
+ # See bug #439380.
+ replace-flags -O* -Os
+
+ local econf_args=()
+
+ if use qt5 || use qt4; then
+ econf_args+=( '--enable-gui' )
+ else
+ econf_args+=( '--disable-gui' )
+ fi
+
+ econf "${econf_args[@]}"
+}
+
+src_install() {
+ default
+
+ # add missing symlinks for QA
+ dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so.0.${PV}
+ dosym libdriveio.so.0 /usr/$(get_libdir)/libdriveio.so
+ dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so.1.${PV}
+ dosym libmakemkv.so.1 /usr/$(get_libdir)/libmakemkv.so
+ dosym libmmbd.so.0 /usr/$(get_libdir)/libmmbd.so
+ dosym libmmbd.so.0 /usr/$(get_libdir)/libmmbd.so.0.${PV}
+
+ cd "${WORKDIR}"/${MY_PB} || die
+
+ # install prebuilt bins
+ if use x86; then
+ dobin bin/i386/{makemkvcon,mmdtsdec}
+ elif use amd64; then
+ dobin bin/amd64/makemkvcon
+ use multilib && dobin bin/i386/mmdtsdec
+ fi
+
+ # install profiles and locales
+ insinto /usr/share/MakeMKV
+ doins src/share/*.{mo.gz,xml}
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ elog "While MakeMKV is in beta mode, upstream has provided a license"
+ elog "to use if you do not want to purchase one."
+ elog ""
+ elog "See this forum thread for more information, including the key:"
+ elog "http://www.makemkv.com/forum2/viewtopic.php?f=5&t=1053"
+ elog ""
+ elog "Note that beta license may have an expiration date and you will"
+ elog "need to check for newer licenses/releases. "
+ elog ""
+ elog "We previously said to copy default.mmcp.xml to ~/.MakeMKV/. This"
+ elog "is no longer necessary and you should delete it from there to"
+ elog "avoid warning messages."
+ elog ""
+ elog "MakeMKV can also act as a drop-in replacement for libaacs and"
+ elog "libbdplus, allowing transparent decryption of a wider range of"
+ elog "titles under players like VLC and mplayer. To enable this, set"
+ elog "the following variables when launching the player:"
+ elog "LIBAACS_PATH=libmmbd LIBBDPLUS_PATH=libmmbd"
+}
+
+pkg_postrm() { gnome2_icon_cache_update; }