summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-05-11 08:16:58 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-05-11 09:48:03 +0100
commitda1e230b0c948ee3007462b873c7fb45bb1a06c9 (patch)
tree482b757afccb3fdeffabb8e96c94de5a35bf64f3
parentdev-haskell/yesod: bump up to 1.4.3 (diff)
downloadgentoo-da1e230b0c948ee3007462b873c7fb45bb1a06c9.tar.gz
gentoo-da1e230b0c948ee3007462b873c7fb45bb1a06c9.tar.bz2
gentoo-da1e230b0c948ee3007462b873c7fb45bb1a06c9.zip
dev-haskell/yesod-auth: bump up to 1.4.13.2
Package-Manager: portage-2.2.28
-rw-r--r--dev-haskell/yesod-auth/Manifest1
-rw-r--r--dev-haskell/yesod-auth/yesod-auth-1.4.13.2.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-haskell/yesod-auth/Manifest b/dev-haskell/yesod-auth/Manifest
index 153c14eb0584..7eb57db81f4e 100644
--- a/dev-haskell/yesod-auth/Manifest
+++ b/dev-haskell/yesod-auth/Manifest
@@ -1,3 +1,4 @@
DIST yesod-auth-1.2.7.tar.gz 29818 SHA256 93574f918075f7de6aebbe331bb8e78c1ef7c5c45b2c693ba83c9f694ffb3a2b SHA512 e2029095d280d0f7c69e06195c864debe17ab4679e05279d31a37823956880d0fa3abdd6c285c08c44ee658948e7174888d682122687a0a022d229ac376e64b5 WHIRLPOOL b52db4f2325508ac7af358ae3e5836dbeb68af362384f45d8ed0baac3f31799fc0c4a61f0e22a0b4c883514bbe378beb4d05a33aaf000b5cf427180e1c0e6beb
DIST yesod-auth-1.3.1.1.tar.gz 35665 SHA256 390eb48a0e5ee1efc25e258b126b937f18d74a0f5bec79b67d6943fbd0268057 SHA512 daaf65024334a24da78b53dbfa64e78e855d32b29eed1088f43f99d6794c65e4a49541350fdd3d6590ba28e02556888656f185a8aa92bb6b5439635c972dce6e WHIRLPOOL bcf239527ea22ef9ea910286cecaca5290ab897138efc825a8c91aa565e00a848dc6cce3aaa0dc289b432a07a3e197da82e5dc4135ade3cfa204df85d7733dd8
DIST yesod-auth-1.4.11.tar.gz 46006 SHA256 2bf08ed837a32e98002d5d16c5cd751a6871950e7bcb2e8b12045f6c60071a77 SHA512 32670e5a0a017d8aee45314babcd49e4dab9c7adfb0e03ab1c622bf2f5df414ae9dd27e275da97cf74147188a81ddf5523edb31701ca84289790fb20113fd4be WHIRLPOOL 35381578c07c2fbdf17e5c3e0b81c6c9b17117b0144120a5b551362a46e3247deb0ff86e959334750d1c2260d2ba26038a019a41d32033022505d6364a9cd99a
+DIST yesod-auth-1.4.13.2.tar.gz 48670 SHA256 65d4cdc979db56e766aef3f64183075f4976ddedb8e62b07efb09be56f2cca20 SHA512 b22207d0ccf86345a50b87a66b4050727003edda7a54d86f81861471a694b2ccfb21d247bea972f21a2e8693cb79988028777f25791059ea3d2a47ddd8a47731 WHIRLPOOL f6ab7b8ebc16c9aa1d4c8ff4d7ca02168bd884d5329c5088f9de318d18b6737478ad544c8e49cd601dd764d85db8ea5b491b89eada938e4061d23d0160383291
diff --git a/dev-haskell/yesod-auth/yesod-auth-1.4.13.2.ebuild b/dev-haskell/yesod-auth/yesod-auth-1.4.13.2.ebuild
new file mode 100644
index 000000000000..17d0a39065a0
--- /dev/null
+++ b/dev-haskell/yesod-auth/yesod-auth-1.4.13.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Authentication for Yesod"
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/aeson-0.7:=[profile?]
+ >=dev-haskell/authenticate-1.3:=[profile?]
+ dev-haskell/base16-bytestring:=[profile?]
+ dev-haskell/base64-bytestring:=[profile?]
+ dev-haskell/binary:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ dev-haskell/byteable:=[profile?]
+ dev-haskell/conduit:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ dev-haskell/cryptohash:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/email-validate-1.0:=[profile?]
+ dev-haskell/file-embed:=[profile?]
+ dev-haskell/http-client:=[profile?]
+ >=dev-haskell/http-conduit-2.1:=[profile?]
+ dev-haskell/http-types:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/mime-mail-0.3:=[profile?]
+ >=dev-haskell/nonce-1.0.2:=[profile?] <dev-haskell/nonce-1.1:=[profile?]
+ >=dev-haskell/persistent-2.1:=[profile?] <dev-haskell/persistent-2.6:=[profile?]
+ >=dev-haskell/persistent-template-2.1:=[profile?] <dev-haskell/persistent-template-2.6:=[profile?]
+ >=dev-haskell/random-1.0.0.2:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/shakespeare:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-haskell/wai-1.4:=[profile?]
+ >=dev-haskell/yesod-core-1.4.20:=[profile?] <dev-haskell/yesod-core-1.5:=[profile?]
+ >=dev-haskell/yesod-form-1.4:=[profile?] <dev-haskell/yesod-form-1.5:=[profile?]
+ >=dev-haskell/yesod-persistent-1.4:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}