summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-05 00:01:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-05 01:34:28 +0100
commitdb869f1cfa8ee0887d6729bcdc29e3865800e64e (patch)
treee6c9809db3463b5bccfa9b7da5422f1691eb508e
parentapp-text/poppler: Fix configure with USE=-lcms (diff)
downloadgentoo-db869f1cfa8ee0887d6729bcdc29e3865800e64e.tar.gz
gentoo-db869f1cfa8ee0887d6729bcdc29e3865800e64e.tar.bz2
gentoo-db869f1cfa8ee0887d6729bcdc29e3865800e64e.zip
app-office/libreoffice: Fix build w/ USE=pdfimport and poppler-0.62
Closes: https://bugs.gentoo.org/642602 Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--app-office/libreoffice/files/libreoffice-5.4.4.2-poppler-0.62.patch44
-rw-r--r--app-office/libreoffice/libreoffice-5.4.4.2.ebuild3
2 files changed, 46 insertions, 1 deletions
diff --git a/app-office/libreoffice/files/libreoffice-5.4.4.2-poppler-0.62.patch b/app-office/libreoffice/files/libreoffice-5.4.4.2-poppler-0.62.patch
new file mode 100644
index 000000000000..e6d7dff898df
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-5.4.4.2-poppler-0.62.patch
@@ -0,0 +1,44 @@
+Fix build with >=poppler-0.62.0, cleanup ifdef and raise minimum poppler version.
+
+--- a/configure.ac 2017-12-12 18:45:07.000000000 +0100
++++ b/configure.ac 2018-01-04 23:57:16.410999542 +0100
+@@ -10403,7 +10403,7 @@
+ if test "$with_system_poppler" = "yes"; then
+ AC_MSG_RESULT([external])
+ SYSTEM_POPPLER=TRUE
+- PKG_CHECK_MODULES( POPPLER, poppler >= 0.12.0 )
++ PKG_CHECK_MODULES( POPPLER, poppler >= 0.21.1 )
+ AC_LANG_PUSH([C++])
+ save_CXXFLAGS=$CXXFLAGS
+ save_CPPFLAGS=$CPPFLAGS
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx 2017-12-12 18:45:07.000000000 +0100
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx 2018-01-05 00:29:16.541246738 +0100
+@@ -32,13 +32,11 @@
+ #pragma warning(push, 1)
+ #endif
+
+-// sigh, UTF8.h was removed in poppler-0.21.0 and put back in 0.21.1
+ // FIXME: we can't use #if POPPLER_CHECK_VERSION(0, 21, 0) && !POPPLER_CHECK_VERSION(0, 21, 1)
+ // because the internal poppler does not provide poppler-version.h and the macro always returns 0
+-#if POPPLER_CHECK_VERSION(0, 21, 1)
+-#include "UTF8.h"
+-#elif POPPLER_CHECK_VERSION(0, 21, 0)
+-#include "UTF.h"
++// UTF8.h was renamed to UnicodeMapFuncs.h in poppler-0.62.0
++#if POPPLER_CHECK_VERSION(0, 62, 0)
++#include "UnicodeMapFuncs.h"
+ #else
+ #include "UTF8.h"
+ #endif
+@@ -918,7 +916,11 @@
+ );
+
+ // silence spurious warning
++#if POPPLER_CHECK_VERSION(0, 62, 0)
++ (void)&mapUTF16;
++#else
+ (void)&mapUCS2;
++#endif
+
+ char buf[9];
+ for( int i=0; i<uLen; ++i )
diff --git a/app-office/libreoffice/libreoffice-5.4.4.2.ebuild b/app-office/libreoffice/libreoffice-5.4.4.2.ebuild
index 303d903bcb75..2e4b24caa4b4 100644
--- a/app-office/libreoffice/libreoffice-5.4.4.2.ebuild
+++ b/app-office/libreoffice/libreoffice-5.4.4.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -246,6 +246,7 @@ PATCHES=(
# TODO: upstream
"${FILESDIR}/${PN}-5.2.5.1-glibc-2.24.patch"
"${FILESDIR}/${P}-gtk3-no-gtk-build.patch" # bug 641812
+ "${FILESDIR}/${P}-poppler-0.62.patch" # bug 642602
)
pkg_pretend() {