summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-12-25 07:34:35 +0100
committerHans de Graaff <graaff@gentoo.org>2019-12-25 07:34:35 +0100
commitdc7278d897e9d02e1db533ed94e0ad6af676b858 (patch)
treee7272077485f4ec9236b5b7e681f397628b395ac
parentdev-ruby/did_you_mean: add 1.4.0 (diff)
downloadgentoo-dc7278d897e9d02e1db533ed94e0ad6af676b858.tar.gz
gentoo-dc7278d897e9d02e1db533ed94e0ad6af676b858.tar.bz2
gentoo-dc7278d897e9d02e1db533ed94e0ad6af676b858.zip
dev-ruby/rb-inotify: add 0.10.1
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/rb-inotify/Manifest1
-rw-r--r--dev-ruby/rb-inotify/rb-inotify-0.10.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/rb-inotify/Manifest b/dev-ruby/rb-inotify/Manifest
index 56d6ca8cf84d..388f11e088bd 100644
--- a/dev-ruby/rb-inotify/Manifest
+++ b/dev-ruby/rb-inotify/Manifest
@@ -1 +1,2 @@
DIST rb-inotify-0.10.0.gem 15872 BLAKE2B 52647ff17994287810efa9c04bc9553b101c42cdd27cf42d530565127dfce104a589ad729d7019409079731577d327221ec3423fa7a5f746aefa3d817b93d898 SHA512 16aa7fb21e5ed713335e583299cfc72676e3ef66de3d349f74a14885b88020b79e031839b193dc140036a0b6539a45ef3a0c3c6027a7211508d388137d22a13b
+DIST rb-inotify-0.10.1.gem 15872 BLAKE2B 1ddf4fe8de7cdd348e007ac29ab7b41667092439f9b70eeae49d7e917351c73512e43a7ccf6679af1c9225b19efadb6a1581f63e1958d2a31d61f2bce5a13664 SHA512 7831a6228f2d6363e634b8d6b4a12206f19b96098e5dfba1d27b1e994a7284a5cb58cd0299d861a6ff275fc8248c0e68faaaf786d6222ad68f3e6b43ccea29ec
diff --git a/dev-ruby/rb-inotify/rb-inotify-0.10.1.ebuild b/dev-ruby/rb-inotify/rb-inotify-0.10.1.ebuild
new file mode 100644
index 000000000000..fd890af7d202
--- /dev/null
+++ b/dev-ruby/rb-inotify/rb-inotify-0.10.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A thorough inotify wrapper for Ruby using FFI"
+HOMEPAGE="https://github.com/nex3/rb-inotify"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/ffi"
+
+ruby_add_bdepend "test? ( dev-ruby/concurrent-ruby )"
+
+all_ruby_prepare() {
+ # Avoid unneeded dependency on jeweler.
+ sed -i -e '/:build/ s:^:#:' -e '/module Jeweler/,/^end/ s:^:#:' -e '/class Jeweler/,/^end/ s:^:#:' Rakefile || die
+
+ # Remove mandatory markup processor from yard options, bug 436112.
+ sed -i -e '/maruku/d' .yardopts || die
+
+ sed -i -e '/bundler/ s:^:#:' -e '1irequire "pathname"' spec/spec_helper.rb || die
+}