summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Denoncin <ddenoncin@gmail.com>2021-03-02 15:02:19 +0100
committerPatrick McLean <chutzpah@gentoo.org>2021-03-04 19:20:52 -0800
commitdc8debaf1fac0b0aa9b296ba15b421b6ca39b6c5 (patch)
tree83968b5a1f4aa646c7e13c8834c54980cd304f87
parentapp-admin/ansible-modules-hashivault: fix manifest (diff)
downloadgentoo-dc8debaf1fac0b0aa9b296ba15b421b6ca39b6c5.tar.gz
gentoo-dc8debaf1fac0b0aa9b296ba15b421b6ca39b6c5.tar.bz2
gentoo-dc8debaf1fac0b0aa9b296ba15b421b6ca39b6c5.zip
dev-python/pytest-salt: bug fix
When pytest-salt is involved in other package's testing suite, it can cause the corresponding package suite to fail. Closes:https://bugs.gentoo.org/740400 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: David Denoncin <ddenoncin@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19735 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/pytest-salt/files/pytest-salt-2020.1.27-r2.patch14
-rw-r--r--dev-python/pytest-salt/pytest-salt-2020.1.27-r2.ebuild (renamed from dev-python/pytest-salt/pytest-salt-2020.1.27-r1.ebuild)4
2 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/pytest-salt/files/pytest-salt-2020.1.27-r2.patch b/dev-python/pytest-salt/files/pytest-salt-2020.1.27-r2.patch
new file mode 100644
index 000000000000..35dca262478b
--- /dev/null
+++ b/dev-python/pytest-salt/files/pytest-salt-2020.1.27-r2.patch
@@ -0,0 +1,14 @@
+Fixes a Doctestitem has no attribute 'fixturenames'
+Fix by David Denoncin based on https://github.com/saltstack/pytest-salt/issues/48
+
+--- a/pytestsalt/fixtures/daemons.py 2021-03-02 15:19:40.500254583 +0100
++++ b/pytestsalt/fixtures/daemons.py 2021-03-02 15:20:40.706920871 +0100
+@@ -1658,7 +1658,6 @@
+ Fixtures injection based on markers
+ '''
+ for fixture in ('salt_master', 'salt_minion', 'salt_call', 'salt', 'salt_key', 'salt_run'):
+- if fixture in item.fixturenames:
+- after_start_fixture = '{}_after_start'.format(fixture)
++ if fixture in getattr(item, 'fixturenames', ()):
+ if after_start_fixture not in item.fixturenames:
+ item.fixturenames.append(after_start_fixture)
diff --git a/dev-python/pytest-salt/pytest-salt-2020.1.27-r1.ebuild b/dev-python/pytest-salt/pytest-salt-2020.1.27-r2.ebuild
index 65b1f4a6405d..f3d2b483cbdb 100644
--- a/dev-python/pytest-salt/pytest-salt-2020.1.27-r1.ebuild
+++ b/dev-python/pytest-salt/pytest-salt-2020.1.27-r2.ebuild
@@ -28,6 +28,10 @@ RDEPEND="
# test? ( app-admin/salt[${PYTHON_USEDEP}] )
#"
+PATCHES=(
+ "${FILESDIR}/${PN}-2020.1.27-r2.patch"
+)
+
# tests need network access
RESTRICT="test"