summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-01-15 19:24:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-01-15 19:32:03 +0100
commitdde7b805506c71a7e86e08ce4303b9764f5c1f87 (patch)
treebb105d098f8d55345fbefd903ecf5b668798f8fb
parentnet-misc/kafkacat: clean up old. (diff)
downloadgentoo-dde7b805506c71a7e86e08ce4303b9764f5c1f87.tar.gz
gentoo-dde7b805506c71a7e86e08ce4303b9764f5c1f87.tar.bz2
gentoo-dde7b805506c71a7e86e08ce4303b9764f5c1f87.zip
kde-plasma/plasma-workspace: Fix runtime crashes and runaway process
KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=347772 KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=425711 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.20.5-avoid-render-invisible-contents.patch38
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.20.5-fix-crash-on-screen-changes.patch63
-rw-r--r--kde-plasma/plasma-workspace/plasma-workspace-5.20.5-r1.ebuild206
3 files changed, 307 insertions, 0 deletions
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.20.5-avoid-render-invisible-contents.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.20.5-avoid-render-invisible-contents.patch
new file mode 100644
index 000000000000..effea7fdc8e1
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.20.5-avoid-render-invisible-contents.patch
@@ -0,0 +1,38 @@
+From 45e0a722fb85bb5d1ab8bef92080e934254b13aa Mon Sep 17 00:00:00 2001
+From: David Edmundson <kde@davidedmundson.co.uk>
+Date: Thu, 7 Jan 2021 13:36:29 +0000
+Subject: [PATCH] [lookandfeel] Avoid rendering invisible contents
+
+An opacity of 0 but still visible still results in nodes in the
+scenegraph, which is wasteful. This is shown in gammaray with some
+warnings.
+
+Enabled is also bound to visible as if a text field has focus it still
+animates the cursor icon even if inivisble, producing wakeups.
+
+BUG: 347772
+FIXED-IN: 5.21
+---
+ lookandfeel/contents/lockscreen/LockScreenUi.qml | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/lookandfeel/contents/lockscreen/LockScreenUi.qml b/lookandfeel/contents/lockscreen/LockScreenUi.qml
+index a2eba8e6d..83564fc0a 100644
+--- a/lookandfeel/contents/lockscreen/LockScreenUi.qml
++++ b/lookandfeel/contents/lockscreen/LockScreenUi.qml
+@@ -228,6 +228,12 @@ PlasmaCore.ColorScope {
+ height: lockScreenRoot.height + units.gridUnit * 3
+ focus: true //StackView is an implicit focus scope, so we need to give this focus so the item inside will have it
+
++ // this isn't implicit, otherwise items still get processed for the scenegraph
++ visible: opacity > 0
++ // changing enabled will toggle if an item can have activeFocus, which otherwise
++ //keeps the text cursor blinking even when invisble
++ enabled: visible
++
+ initialItem: MainBlock {
+ id: mainBlock
+ lockScreenUiVisible: lockScreenRoot.uiVisible
+--
+GitLab
+
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.20.5-fix-crash-on-screen-changes.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.20.5-fix-crash-on-screen-changes.patch
new file mode 100644
index 000000000000..58f3a50c4911
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.20.5-fix-crash-on-screen-changes.patch
@@ -0,0 +1,63 @@
+From fa2bafea8f0cd9fac0864ac23f23c955d5f15b73 Mon Sep 17 00:00:00 2001
+From: David Edmundson <kde@davidedmundson.co.uk>
+Date: Tue, 5 Jan 2021 23:57:19 +0000
+Subject: [PATCH] [panel] Fix crash on screen changes
+
+There is an error handling path when we fetch the relevant config()
+
+```
+KConfigGroup PanelView::panelConfig(...
+{
+ if (!containment || !screen) {
+ return KConfigGroup();
+ }
+```
+
+which we indiscrimiately call parent() on.
+
+This patch guards that case, which is presumably screen being
+temporarily null.
+
+This code is also Plasma 5.8 compatibility fallback, so arguably we
+could get rid of it.
+
+BUG: 425711
+---
+ shell/panelview.cpp | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/shell/panelview.cpp b/shell/panelview.cpp
+index 28e86d2d3..991364e97 100644
+--- a/shell/panelview.cpp
++++ b/shell/panelview.cpp
+@@ -561,7 +561,8 @@ void PanelView::resizePanel()
+
+ void PanelView::restore()
+ {
+- if (!containment()) {
++ KConfigGroup panelConfig = config();
++ if (!panelConfig.isValid()) {
+ return;
+ }
+
+@@ -572,7 +573,7 @@ void PanelView::restore()
+ //but if fails read it from the resolution dependent one as
+ //the place for this config key is changed in Plasma 5.9
+ //Do NOT use readConfigValueWithFallBack
+- setAlignment((Qt::Alignment)config().parent().readEntry<int>("alignment", config().readEntry<int>("alignment", m_alignment)));
++ setAlignment((Qt::Alignment)panelConfig.parent().readEntry<int>("alignment", panelConfig.readEntry<int>("alignment", m_alignment)));
+
+ // All the other values are read from screen independent values,
+ // but fallback on the screen independent section, as is the only place
+@@ -599,7 +600,7 @@ void PanelView::restore()
+ //but if fails read it from the resolution dependent one as
+ //the place for this config key is changed in Plasma 5.9
+ //Do NOT use readConfigValueWithFallBack
+- setVisibilityMode((VisibilityMode)config().parent().readEntry<int>("panelVisibility", config().readEntry<int>("panelVisibility", (int)NormalPanel)));
++ setVisibilityMode((VisibilityMode)panelConfig.parent().readEntry<int>("panelVisibility", panelConfig.readEntry<int>("panelVisibility", (int)NormalPanel)));
+ m_initCompleted = true;
+ resizePanel();
+ positionPanel();
+--
+GitLab
+
diff --git a/kde-plasma/plasma-workspace/plasma-workspace-5.20.5-r1.ebuild b/kde-plasma/plasma-workspace/plasma-workspace-5.20.5-r1.ebuild
new file mode 100644
index 000000000000..765312b060b8
--- /dev/null
+++ b/kde-plasma/plasma-workspace/plasma-workspace-5.20.5-r1.ebuild
@@ -0,0 +1,206 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="forceoptional"
+ECM_TEST="forceoptional"
+KFMIN=5.74.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="KDE Plasma workspace"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="appstream +calendar +fontconfig geolocation gps qalculate screencast +semantic-desktop systemd telemetry"
+
+REQUIRED_USE="gps? ( geolocation )"
+
+BDEPEND="virtual/pkgconfig"
+COMMON_DEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5[widgets]
+ >=dev-qt/qtgui-${QTMIN}:5=[jpeg]
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtsql-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kactivities-${KFMIN}:5
+ >=kde-frameworks/kactivities-stats-${KFMIN}:5
+ >=kde-frameworks/kauth-${KFMIN}:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ >=kde-frameworks/kded-${KFMIN}:5
+ >=kde-frameworks/kdelibs4support-${KFMIN}:5
+ >=kde-frameworks/kglobalaccel-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kidletime-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
+ >=kde-frameworks/kpeople-${KFMIN}:5
+ >=kde-frameworks/krunner-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ >=kde-frameworks/kwayland-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ >=kde-frameworks/prison-${KFMIN}:5[qml]
+ >=kde-frameworks/solid-${KFMIN}:5
+ >=kde-plasma/breeze-${PVCUT}:5
+ >=kde-plasma/kscreenlocker-${PVCUT}:5
+ >=kde-plasma/kwin-${PVCUT}:5
+ >=kde-plasma/libkscreen-${PVCUT}:5
+ >=kde-plasma/libksysguard-${PVCUT}:5
+ >=kde-plasma/libkworkspace-${PVCUT}:5
+ >=media-libs/phonon-4.11.0
+ sys-libs/zlib
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libxcb
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ appstream? ( dev-libs/appstream[qt5] )
+ calendar? ( >=kde-frameworks/kholidays-${KFMIN}:5 )
+ fontconfig? (
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/libXft
+ x11-libs/xcb-util-image
+ )
+ geolocation? ( >=kde-frameworks/networkmanager-qt-${KFMIN}:5 )
+ gps? ( sci-geosciences/gpsd )
+ qalculate? ( sci-libs/libqalculate:= )
+ screencast? (
+ >=media-video/pipewire-0.3:=
+ x11-libs/libdrm
+ )
+ semantic-desktop? ( >=kde-frameworks/baloo-${KFMIN}:5 )
+ telemetry? ( dev-libs/kuserfeedback:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.1.1
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ x11-base/xorg-proto
+ fontconfig? ( x11-libs/libXrender )
+"
+RDEPEND="${COMMON_DEPEND}
+ app-text/iso-codes
+ >=dev-qt/qdbus-${QTMIN}:5
+ >=dev-qt/qtgraphicaleffects-${QTMIN}:5
+ >=dev-qt/qtpaths-${QTMIN}:5
+ >=dev-qt/qtquickcontrols-${QTMIN}:5[widgets]
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-apps/kio-extras-19.04.3:5
+ >=kde-frameworks/kdesu-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/kquickcharts-${KFMIN}:5
+ >=kde-plasma/ksysguard-${PVCUT}:5
+ >=kde-plasma/milou-${PVCUT}:5
+ >=kde-plasma/plasma-integration-${PVCUT}:5
+ x11-apps/xmessage
+ x11-apps/xprop
+ x11-apps/xrdb
+ x11-apps/xsetroot
+ systemd? ( sys-apps/dbus[user-session] )
+ !systemd? ( sys-apps/dbus )
+ !<kde-plasma/plasma-desktop-5.19.80:5
+"
+PDEPEND="
+ >=kde-plasma/kde-cli-tools-${PVCUT}:5
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-5.14.2-split-libkworkspace.patch"
+ "${FILESDIR}/${P}-avoid-render-invisible-contents.patch" # KDE-Bug 347772
+ "${FILESDIR}/${P}-fix-crash-on-screen-changes.patch" # KDE-Bug 425711
+)
+
+RESTRICT+=" test"
+
+src_prepare() {
+ ecm_src_prepare
+
+ cmake_comment_add_subdirectory libkworkspace
+ # delete colliding libkworkspace translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ find po -type f -name "*po" -and -name "libkworkspace*" -delete || die
+ fi
+
+ # TODO: try to get a build switch upstreamed
+ if ! use screencast; then
+ sed -e "s/^pkg_check_modules.*PipeWire/#&/" \
+ -i CMakeLists.txt || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_xembed-sni-proxy=OFF
+ $(cmake_use_find_package appstream AppStreamQt)
+ $(cmake_use_find_package calendar KF5Holidays)
+ $(cmake_use_find_package fontconfig Fontconfig)
+ $(cmake_use_find_package geolocation KF5NetworkManagerQt)
+ $(cmake_use_find_package qalculate Qalculate)
+ $(cmake_use_find_package semantic-desktop KF5Baloo)
+ $(cmake_use_find_package telemetry KUserFeedback)
+ )
+
+ use geolocation && mycmakeargs+=( $(cmake_use_find_package gps libgps) )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # default startup and shutdown scripts
+ insinto /etc/xdg/plasma-workspace/env
+ doins "${FILESDIR}"/10-agent-startup.sh
+
+ insinto /etc/xdg/plasma-workspace/shutdown
+ doins "${FILESDIR}"/10-agent-shutdown.sh
+ fperms +x /etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ # Clean up pre-5.17.4 dirs
+ rmdir -v "${EROOT}"/etc/plasma{/startup,/shutdown,} 2> /dev/null
+
+ elog "To enable gpg-agent and/or ssh-agent in Plasma sessions,"
+ elog "edit ${EPREFIX}/etc/xdg/plasma-workspace/env/10-agent-startup.sh"
+ elog "and ${EPREFIX}/etc/xdg/plasma-workspace/shutdown/10-agent-shutdown.sh"
+}