summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-05-08 15:19:51 -0700
committerMichał Górny <mgorny@gentoo.org>2017-05-11 20:25:23 +0200
commitde6e62e2a0b19c7f5eb8572eb98387f54c1a0aa0 (patch)
tree4273f2c00eab3ef7ee631bd5f6d745bec1f8d427
parentapp-misc/openastro-data: version bump to 1.7 (diff)
downloadgentoo-de6e62e2a0b19c7f5eb8572eb98387f54c1a0aa0.tar.gz
gentoo-de6e62e2a0b19c7f5eb8572eb98387f54c1a0aa0.tar.bz2
gentoo-de6e62e2a0b19c7f5eb8572eb98387f54c1a0aa0.zip
app-misc/openastro: version bump to 1.1.49
Closes: https://github.com/gentoo/gentoo/pull/4575
-rw-r--r--app-misc/openastro/Manifest1
-rw-r--r--app-misc/openastro/openastro-1.1.49.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/openastro/Manifest b/app-misc/openastro/Manifest
index 0c5d46528b82..ca667e23c304 100644
--- a/app-misc/openastro/Manifest
+++ b/app-misc/openastro/Manifest
@@ -1 +1,2 @@
DIST openastro.org_1.1.48.orig.tar.gz 205879 SHA256 504fe7fa224ef66f3be2752593b7bfde84c7b599c5f26733f6093b55bf2a5b2a SHA512 996e503a8dd2504da252ad2b20ac185301e81523629cbcf05fcf37ec4ca3859ef513a194feb2d05bd7c4cbe796bf514afa4eb242b8cd51c65d134b51165f97d3 WHIRLPOOL a73d27f48aea0ed9e7af55bb7e2efc912b17283b515de705ec72193fe187c05a11635bfb5a1ea98d95a2dcbf39bbf3eda4ece636ca5ab945dcafad6e690fa209
+DIST openastro.org_1.1.49.orig.tar.gz 213256 SHA256 e56d8ea47d0873c2136e78b00448f7f7b00607ba1387754739c7d7335a71a127 SHA512 1028807d2a84850699f47a03ad74a851873b9b448f87169bee7d142e5ca750aafe33313b6181b9ee0ed6ccb66c3a867e86bd56648ebe67f4a7a9e1b914b77cec WHIRLPOOL eefeb6aa921f44bde36ed388647d893aa9e0a48be2fe60e01f35e357c36ef9ad1168559bb8061a3fea63da059f68116164d95131284b694700cdd8ce6fe7657f
diff --git a/app-misc/openastro/openastro-1.1.49.ebuild b/app-misc/openastro/openastro-1.1.49.ebuild
new file mode 100644
index 000000000000..142482203fa1
--- /dev/null
+++ b/app-misc/openastro/openastro-1.1.49.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=${PN}.org
+
+DESCRIPTION="A fully-featured Open Source Astrology Program"
+HOMEPAGE="http://openastro.org"
+SRC_URI="http://ppa.launchpad.net/pellesimon/ubuntu/pool/main/o/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+IUSE="jpeg png"
+
+DEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/pycairo[svg,${PYTHON_USEDEP}]
+ dev-python/librsvg-python[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyswisseph[${PYTHON_USEDEP}]
+ app-misc/openastro-data[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ jpeg? ( media-gfx/imagemagick[jpeg,svg] )
+ png? ( media-gfx/imagemagick[png,svg] )"
+
+S=${WORKDIR}/${MY_PN}-${PV}