summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-03-19 16:35:24 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-04-06 13:47:57 -0400
commitdf452e712eed90bd0faa2038921e24f1fb5aa66d (patch)
treec8258dfcf49b41c3868d8df64fb4a9da276b163e
parentmate-base/libmatekbd: Fix LICENSE (diff)
downloadgentoo-df452e712eed90bd0faa2038921e24f1fb5aa66d.tar.gz
gentoo-df452e712eed90bd0faa2038921e24f1fb5aa66d.tar.bz2
gentoo-df452e712eed90bd0faa2038921e24f1fb5aa66d.zip
media-libs/libmatemixer: Bump to 1.24.0
Package-Manager: Portage-2.3.82, Repoman-2.3.18 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
-rw-r--r--media-libs/libmatemixer/Manifest1
-rw-r--r--media-libs/libmatemixer/libmatemixer-1.22.0.ebuild2
-rw-r--r--media-libs/libmatemixer/libmatemixer-1.24.0.ebuild42
3 files changed, 44 insertions, 1 deletions
diff --git a/media-libs/libmatemixer/Manifest b/media-libs/libmatemixer/Manifest
index 649068104bc3..55e08a758483 100644
--- a/media-libs/libmatemixer/Manifest
+++ b/media-libs/libmatemixer/Manifest
@@ -1 +1,2 @@
DIST libmatemixer-1.22.0.tar.xz 432592 BLAKE2B 36f16c0ed516dea05368ae5b4f287cce275844b547fb7eebe7fb0604d0fddce72649dcac1c16475539dc5199f5d310b8bd19f165efd4bfa5c4f1bf31c1141df7 SHA512 6eaa006142601c077ac70739e637273288a4b9713dfc4179341c4832ae4e3b362e92104e150132ee274224d6c5dc057d812b7e1814e49a7690581de6d81e0db8
+DIST libmatemixer-1.24.0.tar.xz 484808 BLAKE2B 8527514cec0770381ce5943f8c87e66f101e92f34527af2b3d4c15696f63df8304f00102fbbfe5b98ebb9b8d8b515f64a3d63b53312f7892b1b4868895539a6f SHA512 bf8c807bd45f3626bbf881eefa1e4638165daf61637bc63a704492d2a67eeec622e35e58c041649d33411294f96f79c99b3ea2406ae6fcf83294ec625cca9dbf
diff --git a/media-libs/libmatemixer/libmatemixer-1.22.0.ebuild b/media-libs/libmatemixer/libmatemixer-1.22.0.ebuild
index 3bb4a5033c0c..2797c67b6f1c 100644
--- a/media-libs/libmatemixer/libmatemixer-1.22.0.ebuild
+++ b/media-libs/libmatemixer/libmatemixer-1.22.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
diff --git a/media-libs/libmatemixer/libmatemixer-1.24.0.ebuild b/media-libs/libmatemixer/libmatemixer-1.24.0.ebuild
new file mode 100644
index 000000000000..ca97e735cc2a
--- /dev/null
+++ b/media-libs/libmatemixer/libmatemixer-1.24.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Mixer library for MATE Desktop"
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="+alsa oss pulseaudio"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=sys-devel/gettext-0.19.8:*
+ alsa? ( >=media-libs/alsa-lib-1.0.5 )
+ pulseaudio? ( >=media-sound/pulseaudio-5.0.0:0[alsa?,glib] )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ virtual/pkgconfig:*
+"
+
+src_configure() {
+ mate_src_configure \
+ --disable-null \
+ $(use_enable alsa) \
+ $(use_enable oss) \
+ $(use_enable pulseaudio)
+}