summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-09 07:57:33 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-09 09:18:03 +0200
commitdf62099cb4c2e0c109890fd083ecaaec508d4510 (patch)
tree705be6ce49cb946acd7067631c5b53fd502db2d3
parentdev-python/botocore: Bump to 1.17.57 (diff)
downloadgentoo-df62099cb4c2e0c109890fd083ecaaec508d4510.tar.gz
gentoo-df62099cb4c2e0c109890fd083ecaaec508d4510.tar.bz2
gentoo-df62099cb4c2e0c109890fd083ecaaec508d4510.zip
dev-python/boto3: Bump to 1.14.57
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.14.57.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index bdd129a9498c..c69afb9e3a6a 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.14.46.tar.gz 301815 BLAKE2B e389e7e0cd9ed0907fd13a948bf37e00040e320
DIST boto3-1.14.49.tar.gz 301978 BLAKE2B ab27aab54b7e1b531ae063e3a84691820208d5d229664d07aaba4c184d5344eb2a620bd2cf4cd4dc4555cf014926c56c89ee29a9832d7ede4fa46b025914a135 SHA512 bc66702f869cb41c6c6dc7d6f82eb09c962122e108d02daf2c4ee408b7a805193f2f4f9af0c5c96775c8a79975142d1154a32c2fe86b0c6aacd18617ff2934c8
DIST boto3-1.14.52.tar.gz 302219 BLAKE2B 97b93e7e203aba7e0dad8bdace83ac41fb85b5880473721543160dc19da52559db3e095edfea8e0946a8915e1a3c396de598b76a35221a64226d602199b8301e SHA512 f65473d91d45bfbd036413b63ee62688bdf9318a09fb81d7e83d5655b785a7b6b626ec7b61ddc1fef8f3fc46c7acb7becefb632d4ae931335a4568451596673d
DIST boto3-1.14.55.tar.gz 302397 BLAKE2B 61785df9bfbe0668ff7b0537bb86b119ab3a98dc41cbe5118f550c81bb08cbec3c68249d9bffa1420088cd5b6a2aff2267dbeb16e52275e632ba88c8e709c8f3 SHA512 d51b0716f5148b5765e90d0a60146b5b06013e4a789eacfb798e5a4c114d4a8b9b07f5d74c0fa0b50b79e1704b7893d709bf87c9a2dd1d184bd477dbecd21a38
+DIST boto3-1.14.57.tar.gz 334506 BLAKE2B ba422426f36c55eb78e057d886abdb9a435839b4a842bf917e3e02d2f3f80c8c94bbf524ed4f3cab53ae627a9f1aeac41a790bebb72c94f52c73486dbcd3f13b SHA512 b772ec8d1c167e37515643796a569ba4258de24b9e4aa1a5022e140fc9121fdc02472231f36b8336e75115aabafa8dbc8c5422ce2ac137f3ead1202043b1c6c0
diff --git a/dev-python/boto3/boto3-1.14.57.ebuild b/dev-python/boto3/boto3-1.14.57.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.14.57.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}