summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-07-31 13:44:21 +0200
committerPacho Ramos <pacho@gentoo.org>2016-07-31 13:44:42 +0200
commite1235491160e1b58a76e4c3914468a987c22d04d (patch)
treed42dc26c6e7553fdd18c270e972f7e54557c6ecd
parentapp-i18n/unicode-data: Drop old (diff)
downloadgentoo-e1235491160e1b58a76e4c3914468a987c22d04d.tar.gz
gentoo-e1235491160e1b58a76e4c3914468a987c22d04d.tar.bz2
gentoo-e1235491160e1b58a76e4c3914468a987c22d04d.zip
gnome-extra/gucharmap: Version bump
Package-Manager: portage-2.3.0
-rw-r--r--gnome-extra/gucharmap/Manifest1
-rw-r--r--gnome-extra/gucharmap/gucharmap-9.0.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/Manifest b/gnome-extra/gucharmap/Manifest
index 5051deb3c3d4..7da75c239369 100644
--- a/gnome-extra/gucharmap/Manifest
+++ b/gnome-extra/gucharmap/Manifest
@@ -1,3 +1,4 @@
DIST gucharmap-3.0.1.tar.bz2 3275481 SHA256 948a376f13af98ffe6be29c73f1d89d2dbc201abd697bb6e85c717d8242dcf75 SHA512 4d8a2276b5cb1a0b0fadca2a8522755c5884985a12d5b19341b9cefcd7f749ec1286c0271419e38ec84be7edcfa1293e7f0263eb682c75387d692792de3e1fb1 WHIRLPOOL 6c9aaaaf31428db5257f98da741513c192ca32371b5d19952471d09586900186b269192b8ae6902e430e7fb3116bccc7d6ed4bca050ad0ca58eb14d7817d569a
DIST gucharmap-3.16.2.tar.xz 1996036 SHA256 0a3fa996ae271c8f4812a7d8dc573ece0c000d63185b4865fa99387455e1b13d SHA512 b20bf0d4a79bd926b0863b7451c6eaa3bba2741231c3719e4799df17aec86798362862ab0a7b19d0fa76d5f05e5fa34f0c516e76e5c0d0bf8e87d15f6e868662 WHIRLPOOL 285d9091d3a7281b84dc96e009a26eb0f154d63f9b222b3d5ae34d9fd6c3c14d7febaf110d26e5b8168b5be93a6d5f01bd70459606b563faf496a78e28b7c3b5
DIST gucharmap-3.18.2.tar.xz 2031560 SHA256 80141d3e892c3c4812c1a8fad8f89978559ef19e933843267e6e9a5524c09ec9 SHA512 d12eefb56272192762086271aa65bfa8b9a8843ac68a6affa1af3d2c891227b0fdae1c274976ceb883ecce26b7d9a2b28c2712155650c0969d6da77b1ff482b5 WHIRLPOOL 176e29627e33e28e965d07efe94aac1c1110bc2c44603c7220d34e520b36a443f73bfc823a395f48760023e137980a822e49c701910813e9deb280b8be115d38
+DIST gucharmap-9.0.0.tar.xz 1007252 SHA256 d698ce4bba5486f7e32e9a4ec0ecd916926fb876640856746121d8ae8012765c SHA512 6054a392d719ebdb98205cb451b6971ca2ddc9d83b2de8b25412b0a561143d5ddb5b4fa0174ae997697b28dc79d60f477208bc6a112cb06346b250aa90e78fd7 WHIRLPOOL 1004ba7f5db5ced3e11cefc1ff61d3f7c05536de77f9a42520959183be9c6592e2ad93f3976750d277514c88d71d1c003035a275c33142c78a458d5f4f59fda6
diff --git a/gnome-extra/gucharmap/gucharmap-9.0.0.ebuild b/gnome-extra/gucharmap/gucharmap-9.0.0.ebuild
new file mode 100644
index 000000000000..518fc8f048b7
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-9.0.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
+
+LICENSE="GPL-3"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+
+COMMON_DEPEND="
+ >=app-i18n/unicode-data-${PV}
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/pango-1.2.1[introspection?]
+ >=x11-libs/gtk+-3.16:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/gucharmap-3:0
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ dev-util/desktop-file-utils
+ >=dev-util/gtk-doc-am-1
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.1.2 )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ # prevent file collisions with slot 0
+ sed -e "s:GETTEXT_PACKAGE=gucharmap$:GETTEXT_PACKAGE=gucharmap-${SLOT}:" \
+ -i configure.ac configure || die "sed configure.ac configure failed"
+
+ # avoid autoreconf
+ sed -e 's/-Wall //g' -i configure || die "sed failed"
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # unihan is not really conditional
+ # https://bugzilla.gnome.org/show_bug.cgi?id=768210#c5
+ gnome2_src_configure \
+ --disable-static \
+ --with-unicode-data=/usr/share/unicode-data \
+ --enable-unihan \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}