summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-07-13 22:50:37 +0300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-07-13 22:51:17 +0300
commite25cd60ac4a446d637b0889170c1d9c0b2d2e9f7 (patch)
tree3e2f7431f564888e343b89f833a0f804d16ab177
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-e25cd60ac4a446d637b0889170c1d9c0b2d2e9f7.tar.gz
gentoo-e25cd60ac4a446d637b0889170c1d9c0b2d2e9f7.tar.bz2
gentoo-e25cd60ac4a446d637b0889170c1d9c0b2d2e9f7.zip
media-video/obs-v4l2sink: Fix plugin install directory. Bug 723210.
Tested, works. Closes: https://bugs.gentoo.org/723210 Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--media-video/obs-v4l2sink/files/obs-v4l2sink-0.1.0_p20181012-installdirs.patch22
-rw-r--r--media-video/obs-v4l2sink/obs-v4l2sink-0.1.0_p20181012-r2.ebuild (renamed from media-video/obs-v4l2sink/obs-v4l2sink-0.1.0_p20181012-r1.ebuild)4
2 files changed, 26 insertions, 0 deletions
diff --git a/media-video/obs-v4l2sink/files/obs-v4l2sink-0.1.0_p20181012-installdirs.patch b/media-video/obs-v4l2sink/files/obs-v4l2sink-0.1.0_p20181012-installdirs.patch
new file mode 100644
index 000000000000..39af16be2719
--- /dev/null
+++ b/media-video/obs-v4l2sink/files/obs-v4l2sink-0.1.0_p20181012-installdirs.patch
@@ -0,0 +1,22 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 75d85f0..15e6bc1 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,5 +1,6 @@
+ cmake_minimum_required(VERSION 3.5)
+ project(obs-v4l2sink)
++include(GNUInstallDirs)
+
+
+ include(external/FindLibObs.cmake)
+@@ -44,8 +45,8 @@ endif()
+ set_target_properties(v4l2sink PROPERTIES PREFIX "")
+
+ install(TARGETS v4l2sink
+- LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/obs-plugins)
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}/obs-plugins)
+
+ install(DIRECTORY locale/
+- DESTINATION "${CMAKE_INSTALL_PREFIX}/share/obs/obs-plugins/v4l2sink/locale")
++ DESTINATION "${CMAKE_INSTALL_DATAROOTDIR}/obs/obs-plugins/v4l2sink/locale")
+
diff --git a/media-video/obs-v4l2sink/obs-v4l2sink-0.1.0_p20181012-r1.ebuild b/media-video/obs-v4l2sink/obs-v4l2sink-0.1.0_p20181012-r2.ebuild
index 11c55edfea57..4b4f0cc3d8fb 100644
--- a/media-video/obs-v4l2sink/obs-v4l2sink-0.1.0_p20181012-r1.ebuild
+++ b/media-video/obs-v4l2sink/obs-v4l2sink-0.1.0_p20181012-r2.ebuild
@@ -26,6 +26,10 @@ RDEPEND="${DEPEND}"
BDEPEND=""
PDEPEND="media-video/v4l2loopback"
+PATCHES=(
+ "${FILESDIR}/${P}-installdirs.patch"
+)
+
src_prepare() {
sed -i -e '/include(external\/FindLibObs.cmake)/d' -e 's#../UI#UI#' CMakeLists.txt
cmake_src_prepare