summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-02-10 21:18:13 +0100
committerJohannes Huber <johu@gentoo.org>2017-02-10 21:18:26 +0100
commite2969c1d302e3938834de1b370691b786f438dde (patch)
tree3b4d240746ffff5528d7be50a2ea370a4b806281
parentdev-python/PySocks: PYTHON_COMPAT: add python3_6 (diff)
downloadgentoo-e2969c1d302e3938834de1b370691b786f438dde.tar.gz
gentoo-e2969c1d302e3938834de1b370691b786f438dde.tar.bz2
gentoo-e2969c1d302e3938834de1b370691b786f438dde.zip
sci-chemistry/pdbmat: EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--sci-chemistry/pdbmat/pdbmat-3.89.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sci-chemistry/pdbmat/pdbmat-3.89.ebuild b/sci-chemistry/pdbmat/pdbmat-3.89.ebuild
index 89445471ef73..0119b3877d08 100644
--- a/sci-chemistry/pdbmat/pdbmat-3.89.ebuild
+++ b/sci-chemistry/pdbmat/pdbmat-3.89.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit cmake-utils fortran-2
@@ -19,11 +19,14 @@ S="${WORKDIR}"/Source_ENM2011
src_prepare() {
cp "${FILESDIR}"/CMakeLists.txt . || die
+
+ cmake-utils_src_prepare
}
src_configure() {
- mycmakeargs=(
- $(cmake-utils_use examples EXAMPLES)
+ local mycmakeargs=(
+ -DEXAMPLES=$(usex examples)
)
+
cmake-utils_src_configure
}