summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-02 19:27:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-02 21:23:47 +0100
commite4fadd7fc548d240ab76924f3b393beb81360f15 (patch)
tree201d39d907d2fb37a322d4588ddf6b4d42d284f9
parentkde-plasma/ksysguard: 5.21.2 version bump (diff)
downloadgentoo-e4fadd7fc548d240ab76924f3b393beb81360f15.tar.gz
gentoo-e4fadd7fc548d240ab76924f3b393beb81360f15.tar.bz2
gentoo-e4fadd7fc548d240ab76924f3b393beb81360f15.zip
kde-plasma/kwallet-pam: 5.21.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.21.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index bdbd306301b4..5d828aa377c9 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.20.5.tar.xz 19812 BLAKE2B d0ad931e47a35b5589e9c34bce924f697446460bcfbfcceb4e3f0564182bbac822f13488dddc592f7b6a119d774b6176b86df8ddca55fb0c9423d0c7634fa9cc SHA512 5f728c2fbbcbfa7a2b50a2d9b60e557360b48d6a5958ce290ace3e2ae8c253b56f64178942f958d38e7e62e0baf1cad0ddb2aa28e11d145f3b507d58900dcb03
DIST kwallet-pam-5.21.1.tar.xz 19888 BLAKE2B e0f07966ce7889d43d7da6cbebb48524ddfe0332f02b12c0e2cac7a66387a877d28e89df183de9d616e14fd5756892a342b0c029f0a4e855d8948585370e84d9 SHA512 c3b2e5b85c08b4e7a86eee8b77bdfcfba5ac02945364144908d3d73dd83d3ca3663c2257821093d65b07b533466e02183cd5e64b6aafe29311829eb579d1d4cd
+DIST kwallet-pam-5.21.2.tar.xz 19896 BLAKE2B 41b2f4c01a1cc99e13f363ee2d25487e0e81a1548e4492bb2df4b8db0f646cf960a089154d322ec39886452485772a65c63ea7b0f5941fc14a4f24d8bf6bf437 SHA512 0b841dd93022efd06c32f1a0527d613c45e038468260b6713f27a5aeaf6b4c463864a982b263333783df8751948b72299c72eb8bca77992f2b332910d9953de9
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.21.2.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.21.2.ebuild
new file mode 100644
index 000000000000..8a587a1fcf29
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.21.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.78.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}